LINUX.ORG.RU

[GNOME][gentoo] замена notification-daemon на notify-osd


0

1

снёс notificaion-daemon, поставил notify-osd, так как пакеты блокируют друг друга. так вот при emerge -uavDN world происходит тоже самое, и при каждом обновлении за собой тянется notification-daemon, который и блокируется notify-osd.
маскировать пробовал, кричит что замаскирована зависимость.
что можно сделать с этой ерёндой?

notify-osd не может полностью заменить notification-daemon, если я не ошибаюсь, например, он не умеет ставить элементы управления (кнопочки, etc.) в уведомления, а некоторые приложения этим пользуются, поэтому в убунтах многие проги патчат, чтобы они могли работать с notify-osd.

Соответственно тебе нужно как минимум создать локальный репозиторий, в котором эти зависимости будут изменены, но скорее всего этого будет недостаточно, так как пакет, наверное, просто так не соберется.

tiandrey ★★★★★ ()
Ответ на: комментарий от tiandrey

вот такая штука при маскированном пакете:
!!! All ebuilds that could satisfy «x11-misc/notification-daemon» have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-misc/notification-daemon-0.7.3::gentoo (masked by: package.mask)
- x11-misc/notification-daemon-0.5.0::gentoo (masked by: package.mask)

(dependency required by «virtual/notification-daemon-0[gnome]» [installed])
(dependency required by «x11-libs/libnotify-0.7.4» [installed])

porngroovecore ()
Ответ на: комментарий от porngroovecore
$ cat /usr/portage/virtual/notification-daemon/notification-daemon-0.ebuild 
...
RDEPEND="
	gnome? ( || ( x11-misc/notification-daemon
		gnome-base/gnome-shell ) )
	!gnome? ( || ( x11-misc/notification-daemon
		xfce-extra/xfce4-notifyd
		x11-misc/notify-osd
		>=x11-wm/awesome-3.4.4
		kde-base/knotify ) )"
...

Со включенным юзфлагом gnome пакет virtual/notification-daemon будет требовать либо notification-daemon, либо gnome-shell, говоря русским языком.

tiandrey ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.