LINUX.ORG.RU

Debian Squeeze разрешение в tty


0

1

Как сменить разрешение в tty? Сейчас стоит 1280х1024, шрифт мелкий, читается с трудом. Раньше в убунте все решалось добавлением nomodeset в /etc/default/grub, здесь не работает. vga=xxx тоже ничего не дает.

Пробовал делать по мануалу (ссыль), разрешение меняется, но обратно из tty в иксы перейти нельзя (черный экран с указателем мыши)

Видеокарта intel.

Что делать??

video=режим в cmdline, не?

nomodeset же делает последние дрова тыквой, или я что-то путаю?

x3al ★★★★★ ()
Ответ на: комментарий от x3al

video=режим в cmdline, не?

Не работает. Разрешение в tty не меняется, и опять сломался переход в иксы.

nomodeset же делает последние дрова тыквой, или я что-то путаю?

Ну да, зато в консольке разрешение 640х480 и можно не напрягать зрение.

matrasa ()
Ответ на: комментарий от matrasa

Полный отчёт о том, как не работает (включая dmesg), как и по каким докам писался cmdline (и cmdline) ну и версию ядра/видео.

Ну да, зато в консольке разрешение 640х480 и можно не напрягать зрение.

А что, шрифт не настраивается?

x3al ★★★★★ ()
Ответ на: комментарий от x3al

А что, шрифт не настраивается?

Я пробовал настраивать с помощью console-setup, в итоге меняется только количество символов/строк на экране, но размер остается по прежнему мелкий.

Полный отчёт о том, как не работает (включая dmesg), как и по каким докам писался cmdline (и cmdline) ну и версию ядра/видео.

Не знаю как сделать полный отчет, вывод dmesg (ссыль)

Параметры в /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="video=1024x768-24"
GRUB_CMDLINE_LINUX="video=1024x768-24"

ядро - 2.6.32-5-amd64

видео

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 817a
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at dfe00000 (32-bit, non-prefetchable) [size=512K]
	Region 1: I/O ports at 8800 [size=8]
	Region 2: Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Region 3: Memory at dfe80000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915

Кстати, первые несколько секунд Дебиан грузится в нормальном разрешении, если ставить nomodeset - то в 640х480, если дописывать параметр vga=xxx то в нужном разрешении. Но потом оно сбрасывается до 1280х1024, и продолжает грузиться в таком разрешении до gdm

matrasa ()
Ответ на: комментарий от matrasa

>Но потом оно сбрасывается до 1280х1024

Потому, что без modeset грузится uvesafb, который настраивается примерно как KMSные драйверы. Удали его — и с vga=/nomodeset ничего не будет сбрасывать разрешение до 1280x1024.

Но лучше разобраться с размером шрифта/KMS-настройками видеорежима

x3al ★★★★★ ()
Ответ на: комментарий от x3al

>Удали его

А как это сделать? В конфиге груба он не прописан, может надо удалить пакет v86d, но проблема была и до его установки.

Можно подробнее? Я не особо разбираюсь.

matrasa ()
Ответ на: комментарий от x3al

Проблема была и до установки пакета.

Удалил, выставил nomodeset, но все равно на 2 - 3 секунде загрузки разрешение меняется на 1280х1024.

matrasa ()
Ответ на: комментарий от matrasa

Посмотрел вывод xrandr'а. Я так понял, разрешение 1280х1024 75 максимальное для моего монитора. Может быть этот режим можно удалить из сонфига иксов?? Сгенерировал xorg.conf но там почти пусто, и про режимы ничего не сказано

matrasa ()
Ответ на: комментарий от matrasa

При чём тут иксы? Ты можешь (в теории) кроме video=* менять разрешение в фреймбуфере fbset'ом, больше — ничего.

После удаления v86d у тебя ещё что-то меняет разрешение, отмечаясь в dmesg вместо uvesafb.

x3al ★★★★★ ()
Ответ на: комментарий от x3al

>А ты initcpio перегенерировал после удаления v86d?

Какой командой это делается? Я после всех изменений вбил

sudo update-initramfs -u && sudo update-grub2 && sudo reboot

Если кратко, то надо отредактировать файл /etc/grub.d/00_header, вставив в определённом месте set gfxpayload=keep

Не работает, разрешение упорно ставится как 1280х1024

matrasa ()

Прочитал, что после настройки шрифтов с помощью console-setup шрифт сразу не меняется, надо бы еще запустить setupcon и тогда все будет ок.

В каком скрипте эту команду прописать чтобы в tty сразу были нужные мне настройки шрифта?? Пробовал в /etc/rc.local, не помогло.

matrasa ()
Ответ на: комментарий от matrasa

Уже разобрался где файл автозапуска для конкретного пользователя.

Всем спасибо за помощь!

matrasa ()

Debian Squeeze разрешение в tty

matrasa Вы пишите: «Уже разобрался где файл автозапуска для конкретного пользователя.» Можно здесь по подробней-я никак не могу докапаться до решения этого ребуса.После обновления ядра-эти же грабли. С уважением-Олег.К

kollega ()
Ответ на: Debian Squeeze разрешение в tty от kollega

/home/user/.profile - сюда можно прописать команды, которые будут выполняться после логина в tty

Нормальное разрешение в tty у меня таки поставилось. Я отключил KMS, перезагрузился, дописал нужные параметры в grub, обновил груб, включил KMS, и после перезагрузки все заработало

matrasa ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.