LINUX.ORG.RU

[arch] Не работает команда выключения


0

1

Установил на нетбук Eee-pc 1001 pxd Arch linux. При вводе в консоли комманды «shutdown now» компьютер не выключается, а просто выдает сообщение типа «press Ctrl+D for maintenance mode». После нажатия любых клавиш консоль выдает приглашение для ввода login'а. Информация о системе:

Linux atom 2.6.38-ARCH #1 SMP PREEMPT Fri May 13 09:24:47 CEST 2011 x86_64 Intel(R) Atom(TM) CPU N455 @ 1.66GHz GenuineIntel GNU/Linux

Загружаемые модули:

MODULES=(ac battery button processor thermal video cdrom intel-agp intel-gtt tpm_bios tpm tpm_tis tpm_tis tpm_tis drm_kms_helper drm i915 hid i2c-algo-bit i2c-i801 i2c-core evdev joydev pcspkr psmouse serio_raw sparse-keymap uvcvideo v4l2-compat-ioctl32 videodev pci_hotplug shpchp eeepc-wmi wmi iTCO_vendor_support iTCO_wdt snd-mixer-oss snd-pcm-oss snd-hwdep snd snd-page-alloc snd-pcm snd-timer snd-hda-codec snd-hda-intel soundcore scsi_mod ata_piix atl1c mac80211 rfkill ath9k_common ath9k_hw ath9k ath cfg80211 usbhid usbcore ehci-hcd uhci-hcd option usbserial usb_wwan sd_mod sr_mod st sg)

Демоны запускаемые при старте:

DAEMONS=(syslog-ng dbus @network @netfs @crond @gamin)

Как можно исправить данную проблему? Заранее благодарен.

UPDATE: что выдала hwdetect то и запихал в модули.

UPDATE: Спасибо. «Poweroff» работает.

ты стебёшься чтоли, зачем тебе столько модулей

visual_pipe ()

>Как можно исправить данную проблему?
Прочитать man shutdown.

kernelpanic ★★★★★ ()

> При вводе в консоли комманды «shutdown now» компьютер не выключается, а просто выдает сообщение типа «press Ctrl+D for maintenance mode».
man shutdown:

runlevel 1 is used to put to system into a state where administrative tasks can be performed; this is the default if neither the -h or -r flag is given to shutdown.

Нужно было использовать shutdown -h now.

AITap ★★★★★ ()
Ответ на: комментарий от unikum

Спасибо. После установки демона ОС стала реагировать на нажатие клавиши ждущего режима. Но при нажатии её экран моргает и выбрасывает на login manager (у меня установлены Slim и XFCE4). Это как то связано с тем что Slim у меня запускается не как демон, а через inittab?

headbang ()
Ответ на: комментарий от headbang

> но не работает wi-fi

помойму там наоборот надо сделать

If you are having trouble getting the wireless working with either the default kernel or the driver from the UAR, try blacklisting the rt2800lib module by modifying /etc/rc.conf:

MODULES=(... !rt2800lib ...)

This fixed wireless for me (using kernel 2.6.33-ARCH).

https://wiki.archlinux.org/index.php/Asus_Eee_PC_1000

visual_pipe ()
Ответ на: комментарий от visual_pipe

Нетбуки отличаются. Я пробовал по этой статье ставить, но все закончилось пересборкой ядра. Вот модули от wi-fi: th9k_common ath9k_hw ath9k ath cfg80211.

headbang ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.