LINUX.ORG.RU

проблема с vmware под fedora


0

0

Имею Fedora Core 1(2.4.22-1.2115.nptl) и VMWare 4.5 . При конфигурировании дело доходит до вопроса: "What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]" и не двигается дальше. Хедеры не лежат там где предлогается по-умолчанию. Да и вообще полазил по системе - не нашел. Пакета с kernel-headers-2.4.22-1.2115.nptl не нашел ни на дистрибутиве, ни в Инете. Помогите??

anonymous

Ответ на: Re: Re: проблема с vmware под fedora от anonymous

Re: Re: Re: проблема с vmware под fedora

Если указать путь куда установился rpm-овский пакет kernel-source-2.4.22-1.2115.nptl, то будет такая фигня:

What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include] /usr/src/linux-2.4.22-1.2115.nptl/ The path "/usr/src/linux-2.4.22-1.2115.nptl" is an existing directory, but it does not contain at least one of these directories "linux", "asm", "net" as expected.

Из директорий в этой папке есть только net

anonymous ()
Ответ на: Re: Re: Re: проблема с vmware под fedora от anonymous

Re: Re: Re: Re: проблема с vmware под fedora

Пардон! Совсем запутался! Указываю путь /usr/src/linux-2.4.22-1.2115.nptl/include/

выдает

The directory of kernel headers (version 2.4.22FED) does not match your running kernel (version 2.4.22-1.2115.nptl). Even if the module were to compile successfully, it would not load into the running kernel.

Как можно решить эту проблему?

anonymous ()
Ответ на: Re: Re: Re: Re: проблема с vmware под fedora от anonymous

Re: Re: Re: Re: Re: проблема с vmware под fedora

У меня была такая проблема на Федоре 2 - всё дело в устаревшей версии ВМВари, которая плохо настроена на ядро 2.6хх, попробуй найти версию поновее, моя работающая - 4.5.2, билд 8848.

anonymous ()
Ответ на: Re: Re: Re: Re: Re: проблема с vmware под fedora от anonymous

Re: Re: Re: Re: Re: Re: проблема с vmware под fedora

Дело в том . что именно эту версию я и пытаюсь поставить :( Может есть другой вариант? Плиз ХЕЛП?

anonymous ()

Re: проблема с vmware под fedora

У меня проблем не возникало. Но я всегда после установки исходников ядра в /usr/src делаю симлинки:

linux -> linux-2.4 linux-2.4 -> <каталог с ядром>

Может попробовать тоже это же сделать?

Правда у меня сейчас не linux-2.4.22-1.2115.nptl, а kernel-2.4.22-1.2116.nptl.mc.w4l, но не думаю, что это принципиально важно.

kraw ★★★★ ()
Ответ на: Re: проблема с vmware под fedora от kraw

Re: Re: проблема с vmware под fedora

Дело в том,линки все сделаны. Но начав заново установку, заметил то, что раньше видимо не заметил: Your kernel was built with "gcc" version "3.2.3", while you are trying to use "/usr/bin/gcc" version "3.3.2". This configuration is not recommended and VMware Workstation may crash if you'll continue. Please try to use exactly same compiler as one used for building your kernel. Do you want to go with compiler Может в этом все дело. Если да, то как интересно это лечится.Так как переставить gcc один большой гемор. Посоветуйте?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.