LINUX.ORG.RU

Переключение языка в RedHat Kde


0

0

Добрый день! Я установил RedHat 9 с Kde. Для переключения на русский язык по умолчанию стоит в настройках комбинация Ctrl+Alt+K. Однако же она работает только наполовину - переключает на русский и не переключает обратно. Такое впечатление, что после переключения при нажатии на кнопку K она уже воспринимается не как 'к', а как 'Л' и на нее нет реакции. Если поменять комбинацию - то не переключается вовсе. Подскажите как можно устранить это явление и как вообще можно поменять кнопки для переключения например на Ctrl+Shift? В контрольцентре не дают такой возможности, только если с буквой или цифрой комбинация - тогда можно.

Спасибо.

anonymous

Re: Переключение языка в RedHat Kde

Чувак! Есть такой файл, /etc/X11/XF86Conf (правда у меня FreeBSD, но поии, он примерно по этому пути должен находится или где то в /usr) так вот там где клавиатура настройки должны выглядеть примерно так: Option "XkbLayout" "us,ru(winkeys)" Option "XkbOptions" "grp:ctrl_shift_toggle"

В примере указаны раскладка windows и способ переключения! Юзай в свое удовольствие! :)

anonymous ()
Ответ на: Re: Переключение языка в RedHat Kde от anonymous

Re: Re: Переключение языка в RedHat Kde

Йопрст! Рассказываю :)) Я нашёл уже этот способ и попробовал, соответственно не забыл перегрузить X Server, однако ж не заработало. После этого вопросил тут. Теперь дошло - надо в контроль центре раскладки отключить - тогда работает. КДЕ, видимо, если у него включены раскладки, кладет на иксы. Я так это понял. Спасибо тем не менее :)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.