LINUX.ORG.RU

KDE, баг, дыры в окнах.


0

0

Если на панели навести курсор на что-то, чтобы появился попап, в данном случае я навёл курсор на кнопку «кменю», с другой стороны часть окна становится прозрачным и просвечивает то что под ним.
Баг у меня проявляется очень часто, я даже привык к нему, существует с версии 4.2 (более ранние версии не пользовал).
Проявляет себя и на карте Intel, и на карте Nvidia.
Эффекты не использую.
rm -rf ~/.kde не влияет (делал не из-за этого)
От темы плазмы не зависит, от темы Qt тоже.

скриншот

Размер дыры всегда равен размеру попапа, который появился бы в том месте, где дыра. Тоесть в данном случае там расположен попап от иконки переключателя раскладок, по размерам и расположению совпадает с дырой.

Kubuntu Lucid. На данный момент KDE 4.4.5

(Ещё скриншоты: 1, 2)

Обоина шикарная.
УМВР.

bsdfun ★★★★★ ()

Размером отверстие подходит под попап уведомления. И да, классный ковёр.

ThePretender ()

и да - это не баг, а кривые руки!

megabaks ★★★★ ()

У меня ни разу такого непотребства не было в 4х кедах. Карта нвидиа и интел тестед. Хотя тоже везде правое меню. Возможно конфиг ксорга поможет прояснить что нибудь.

Guest_now ()

Хм, ни разу не замечал такого.

(KDE 4.1-4.4 - Arch, KDE 4.4 - OpenSuSe, Nvidia)

Kosyak ★★★★ ()

Мне подсказали попробовать запустить xcompmgr.
Запустил, баг пока не дал о себе знать. И панель плазмы стала полупрозрачной, красота...

firestarter ★★★☆ ()

«Параметры системы» -> «Внешний вид» -> «Стиль» -> Вкладка «Тонкая настройка» -> Выпадающий список «Графические эффекты».

Попробовать выбрать там что-нибудь с высокими настройками.

muzenbaher ()
Ответ на: комментарий от firestarter

У меня в первую же минуту пробования КДЕ4 такое же вышло: http://static.itmages.ru/i/10/0726/h_1280136020_cc4731eca5.png

Карта Nvidia, дрова проприетарные, КДЕ 4.4.4, но поклонники КДЕ4 меня закидали помидорами, что это, мол из-за кривой карты или дров.

Nxx ★★★★★ ()
Ответ на: комментарий от post-factum

>Знакомый ковёр. Это его, кажись, давеча обосрали здесь.

Никто не обсирал, комментирующие положительно отозвались, но тема была удалена модератором из скриншотов не помню по какой причине...

firestarter ★★★☆ ()
Ответ на: комментарий от muzenbaher

«Параметры системы» -> «Внешний вид» -> «Стиль» -> Вкладка «Тонкая настройка» -> Выпадающий список «Графические эффекты».

Попробовать выбрать там что-нибудь с высокими настройками.

Сделал так, баг не исчез. Было «Высокое разрешение, низкая нагрузка на процессор».

firestarter ★★★☆ ()
Ответ на: комментарий от firestarter

> комментирующие положительно отозвались

тема была удалена модератором из скриншотов

/0

Ага, оно, такое тоже имело место...

Какое то неправильное у вас кде.

bsdfun ★★★★★ ()
Ответ на: комментарий от megabaks

>>rm -rf ~/.kde

rm -rf ~/.kde4!!!!


У меня ~/.kde. Помоему кеды4 свой хлам складывают в .kde4 если было обновление с третьих кед. У меня так было когда обновился с Hardy на Jaunty. Но потом Jaunty ставил с нуля, удалив всё что было связано с третьими кедами, KDE4 использовало директорию .kde.

firestarter ★★★☆ ()
Ответ на: комментарий от firestarter

Я в эффектах поставил галочку «Аппаратная отрисовка», без нее тоже были какие-то глюки

Guest_now ()
Ответ на: комментарий от firestarter

Мой xorg.conf

Section "ServerLayout"
    Identifier     "layout1"
    Screen         "screen1" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Module"
    Load           "dbe" # Double-Buffering Extension
    Load           "v4l" # Video for Linux
    Load           "extmod"
    Load           "glx" # 3D layer
EndSection

Section "ServerFlags"

    # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
    Option         "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    Option         "allowmouseopenfail"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    Identifier     "monitor1"
    VendorName     "Plug'n Play"
    ModelName      "SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    ModeLine       "768x576" 50.00 768 832 846 1000 576 590 595 630
    ModeLine       "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
    Identifier     "device1"
    Driver         "nvidia"
    BoardName      "NVIDIA GeForce GT220"
EndSection

Section "Screen"
    Identifier     "screen1"
    Device         "device1"
    Monitor        "monitor1"
    DefaultDepth    24
    Option         "DPMS"
    Option         "DynamicTwinView" "false"
    Option         "AddARGBGLXVisuals"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Guest_now ()
Ответ на: комментарий от firestarter

Я все-таки наткнулся на этот баг :) Видео intel, какое-то старое для celeron D. kde 4.4.3 хотя мне кажется что это может с дровами проблемы :)

Guest_now ()
Ответ на: комментарий от melkor217

>Какой видеодрайвер? Включен ли композит?

На энвидии сейчас драйвер x86-195.36.24

На интеле я не помню какой последний использовался, наверное тот что в репах Karmic. Так как на обоих картах баг вёл себя одинаково, мне кажется карты и их дрова тут непричём.

Эффекты, как я уже писал выше, не включены, но если включить эффекты kwin или xcompmgr, баг себя не проявляет.

firestarter ★★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.