LINUX.ORG.RU

[debian][помогите новичку]где synaptic?


0

0

Поставил дебиан с диска кде. Есть несколько проблем.

Где synaptic?

apt-cache search synaptic
xserver-xorg-input-synaptics - Synaptics TouchPad driver for X.Org/XFree86 server

cat /etc/apt/sources.list
#
# deb cdrom:[Debian GNU/Linux 5.0.5 _Lenny_ - Official i386 kde-CD Binary-1 20100626-18:10]/ lenny main

deb cdrom:[Debian GNU/Linux 5.0.5 _Lenny_ - Official i386 kde-CD Binary-1 20100626-18:10]/ lenny main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ lenny/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ lenny/updates main

# Line commented out by installer because it failed to verify:
deb http://volatile.debian.org/debian-volatile lenny/volatile main
# Line commented out by installer because it failed to verify:
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
deb http://repo.yandex.ru/debian/ lenny main non-free
deb http://deb.opera.com/opera lenny non-free

Как поставить оперу?

apt-get install opera
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
opera: Зависит: gstreamer0.10-plugins-good но он не будет установлен
E: Сломанные пакеты

apt-get update и art-get upgrade делал

★★★★

>Поставил дебиан с диска кде.

Купил себе наган в лыжном магазине.

Где synaptic?


Система-Администрирование-Программа управления пакетами Synaptic (Или как там в кедах, тоже где-то в районе системных настроек).

Как поставить оперу?


Скачать пакет с оф. сайта?

Пакеты, имеющие неудовлетворённые зависимости:


sudo apt-get install -f

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

текст читаем? даже апт-кэш не видит синаптика. в системе его нет. Репы подключены, не помогает.

Я ставил с Official i386 kde-CD Binary-1 20100626-18:10, чем тебе не нравится?

GreyDoom ★★★★ ()
Ответ на: комментарий от GreyDoom

Синаптик стоит сразу уже, его не нужно переставлять/устанавливать. С чего ты взял, что в системе его нет?

Zhbert ★★★★★ ()
Ответ на: комментарий от o4kareg

нужен гуй. Где 4е кеды брать? Или их в ленни не бэкпортили?

GreyDoom ★★★★ ()
Ответ на: комментарий от anonymous

Что мне ещё сделать, чтоб объяснить, что синаптика в системе нет, пакета такого тоже нет, а репы ленни подключеныи и апдейт сделан?

GreyDoom ★★★★ ()
Ответ на: комментарий от powerofanonymous

>В кде разве не kpackagerkit?

Кстати, да, вроде он.

Zhbert ★★★★★ ()

гм. походу яндекса вина была.

подключил американский реп - всё заработало.

GreyDoom ★★★★ ()
Ответ на: комментарий от GreyDoom

Во-первых, не ори, мало ли, может ты из обычного юзера запускал, у которого */sbin в path, естественно, нет.

Во-вторых, repo.yandex.ru - это репозиторий яндексовских программ, яндекс.онлайн там и прочее, там нет синаптика, ни одного. :) Зеркало находится на http://mirror.yandex.ru/debian main contrib non-free

В-третьих, никогда не слушай eclipse, он невменяем.

anonymous ()
Ответ на: комментарий от cuki

Блин, неужели сложно по ссылке пройти, и посмотреть, что такое вообще repo.yandex.ru?

anonymous ()

Я понимаю, что офтоп итп.. Где можно почитать фак нормальный. А то я сталкиваюсь с проблемой и думаю, что она типична. фак русский лучше потому что проблемы специфические (переключалка, шрифты)

И вот вопрос, если я хочу кеды 4.4 в систему и веснот не годичной давности, что мне делать?

GreyDoom ★★★★ ()
Ответ на: комментарий от anonymous

))В-третьих, никогда не слушай eclipse, он невменяем.

а вот и вменяемый адекватный неадекват пожаловал.

elipse ★★★ ()
Ответ на: комментарий от GreyDoom

Wesnoth 1.8.2 есть в Lenny Backpors.

KDE 4.4 в Lenny нет.

anonymous ()
Ответ на: комментарий от GreyDoom

Переключалка в KDE3 это поставить kkbswitch, и настроить через апплет только русский язык, поставить галочку на «включая английский язык», и в параметрах xkb (там же) выбрать нужные опции.

anonymous ()
Ответ на: комментарий от anonymous

Это я всё сделал, не дебил, не работают хоткеи, почитал как можно сделать но всё равно хотел бы более-менее официального решения.

GreyDoom ★★★★ ()
Ответ на: комментарий от GreyDoom

такого до релиза нет
могут вылезти всякие мелкие проблемки ,типа:
обновления udev а потом ведра, корректное закрытие почтовых баз эволюшен перед обновлением...

elipse ★★★ ()
 apt-cache policy opera                                                                                               :)
opera:
  Установлен: 10.60.6386
  Кандидат: 10.60.6386
  Таблица версий:
 *** 10.60.6386 0
        500 http://deb.opera.com stable/non-free Packages
        100 /var/lib/dpkg/status
     10.10-4742-1 0
        500 http://unofficial.debian-maintainers.org sid/restricted Packages

в unofficials более старая версия, например

а вообще, список неофициальных репозов курить тут:

Полезные репозитории для Debian

lazyklimm ★★★★★ ()
Ответ на: комментарий от GreyDoom

если я хочу кеды 4.4 в систему

пока только 4.3.5

deb http://www.debian-desktop.org/pub/linux/debian/kde43 lenny-backports main contrib non.free
но вообще, использовать debian stable на десктопе - излишняя паранойя, я считаю

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

вообще, по поводу debian stable надо в FAQ написать крупными буквами:

НИ ЗА ЧТО НЕ СТАВЬТЕ, ЕСЛИ НЕ ЗНАЕТЕ ЧТО ВАМ ОН ТОЧНО НУЖЕН, есть более подходящие для десктопа testing/sid

Ибо уже далеко не первый раз задаются подобные вопросы, плюс возникает миф о древности дебиановского софта.

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

Ога ,т.е твои заклиная есть гарантия от 300 критических ошибок блокирующих релиз testing ?
Я вот вчера накатил testing -> sid (и создав нового пользователя)
и хрен смог загрузится под учеткой старого юзера из Lenny

.ICEauthority not update - и все тут.

elipse ★★★ ()
Ответ на: комментарий от elipse

>testing -> sid

Lenny

ну так то обновление, двойное причем

как написал, на куче компов уже в районе двух лет живет sid(установленный с нуля), и живет очень хорошо.

300 критических ошибок в тестинге, в сиде обновления-исправления попадают быстрее всего. Тем более, что чаще всего для десктопа эти ошибки неактуальны.

Ах да, в вышедших релизах убунты софт по версиям примерно совпадает с testing-sid, более того, пакеты и мейнтейнеры зачастую одни и те же. Так с какого перепугу в дебиане они должны работать хуже?

Более того, даже stable не даёт 100% гарантии.

lazyklimm ★★★★★ ()
Ответ на: комментарий от elipse

>Пришлось в лоб переустанавливать весь дистр для старого юзверя.

но вообще жесть, максимум с чем приходилось сталкиваться - рекурсивные зависимости(libc) при обновлении lenny(предрелизный testing) до sid.

Так чтоб были проблемы на уровне пользователя - никогда не сталкивался.

ДА, а что, нельзя было завести нового пользователя и перетащить ему нужные настройки старого?

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

>ну так то обновление, двойное причем

Была новая установка testing -> грабли
Далее, обновление до sid - снова грабли.

elipse ★★★ ()
Ответ на: комментарий от lazyklimm

>> Более того, даже stable не даёт 100% гарантии.

НИ ЗА ЧТО НЕ СТАВЬТЕ, ЕСЛИ НЕ ЗНАЕТЕ ЧТО ВАМ ОН ТОЧНО НУЖЕН,


Ага, это были безответственные рекомендации - аки гнутие пальцев

elipse ★★★ ()
Ответ на: комментарий от lazyklimm



ДА, а что, нельзя было завести нового пользователя и перетащить ему нужные настройки старого?


Мне и так после обновления железа и всякой возни пришлось заночевать
у «нового пользователя».))
Еще не хватало экстрима с пользовательскими данными и программами .

elipse ★★★ ()
Ответ на: комментарий от elipse

>Далее, обновление до sid - снова грабли.

В общем, в инсталляции от sidux у меня всё работает (насколько я понял особо глючные пакеты они то-ли маскируют, то ли что-то ещё. А ещё ядро свежее => вероятность подхватывания оборудования скорее всего выше)

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm


А ещё ядро свежее => вероятность подхватывания оборудования скорее всего выше)

ни фига
я у меня зеркалятся эти деятели
ведро они обновляют почти синхронно с Debian, но иначе собирают его.

(насколько я понял особо глючные пакеты они то-ли маскируют, то ли что-то ещё.

Вот не надо создавать мифы.
своих там около сотни пакетов (ведро, оформление, инсталлятор, примочки ..), а все иное прямые репы Debian Sid.

elipse ★★★ ()
Ответ на: комментарий от elipse

ведро они обновляют почти синхронно с Debian, но иначе собирают его.

у этих деятелей ядро появляется практически сразу после ванильного, в отличие от. А пересобирают иначе, да.

Кстати, сейчас в сиде 32-е, 34-е только в экспериментале.

Вот не надо создавать мифы.

нет, ты!

We use Debian «unstable» packages as they come unless some core package is broken. In that case we will offer a fixed package in our sidux repository until Debian offers a fixed package (the patch goes upstream of course).

интервью с разрабами

lazyklimm ★★★★★ ()

> Как поставить оперу?

apt-get install opera

хехе. это тебе не суся

Nxx ★★★★★ ()
Ответ на: комментарий от lazyklimm

>нет, ты!

Доо ...
посмотри сам их репы
зы: зачем мне читать описание их желаний ?))

34-е только в экспериментале.


Какая трагедия ....
Ибо, по версиям xorg и mesa, нефиг ему делать пока в Sid и testing.))

elipse ★★★ ()
Ответ на: комментарий от elipse

Ибо, по версиям xorg и mesa, нефиг ему делать пока в Sid и testing.))

Они вместе приходят(кернелы с иксами и видео драйверами)?

Serge ()
Ответ на: комментарий от elipse

>Ибо, по версиям xorg и mesa, нефиг ему делать пока в Sid и testing.))

ммм, отсутствие свежего xorg в unstable как-то мешает появлению там свежего ядра?

lazyklimm ★★★★★ ()
Ответ на: комментарий от Serge

> Они вместе приходят(кернелы с иксами и видео драйверами)?

Т.е. , версии xorg , mesa , kernel и libdrm ничем уже друг другу не обязаны ?

Только удача и случайное совпадение версий дают некоторое ускорение на свободных дровах ?))


elipse ★★★ ()
Ответ на: комментарий от elipse

Упало в сид Sid:

Следующие пакеты будут обновлены:                
  evince evince-common firmware-linux-free libevince2 linux-base linux-image-2.6.32-5-686 
  linux-libc-dev rsyslog xserver-xorg-video-ati xserver-xorg-video-radeon 

Дрова на ати новые(6.13.1), а ядро старое.

Serge ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.