LINUX.ORG.RU

отваливание usb звука и мышки


0

0

имеется usb радио мышка/клава/динамик от logitech. проблема: через рандомное время после запуска системы отваливается сначала звук, потом спустя некоторое время мышка. Помогает только ребут на убунтуфорумах кто-то постил подобную проблему, но ответов там не давали, в остальном гугл что-то молчит, проблема накипела т.к. комп приходится ребутать раз по 5-6 в час.

В логах присутствует только

[  848.976758] 4:1:1: usb_set_interface failed
[  854.049323] 4:1:1: usb_set_interface failed
[  869.340060] 4:1:1: usb_set_interface failed
[  899.721548] 4:1:1: usb_set_interface failed
[  912.565477] 4:1:1: usb_set_interface failed

Debian-squeeze, uname -a:

Linux lucky 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux


Ответ на: комментарий от megabaks

управление питанием было включено, отключил, та же хрень, щас копаю в сторону alsa. Xреново ещё то что деб мне пишет что OSS не поддерживается аппаратно, хотя в ленни до этого я сидел через него, но причём тут мышка тогда не понимаю, и клавиатура продолжает работать, хотя всё работает через один usb'шник...

Dor ()
Ответ на: комментарий от ZhAN

ой, с прерываниями я не сталкивался, погуглил, но чёт плохо разобрался, прошу прощения, не могли бы вы пояснить немного, вот в общем

cat /proc/interrupts 
           CPU0       CPU1       CPU2       
  0:         43          0          4   IO-APIC-edge      timer
  1:          0          0          4   IO-APIC-edge      i8042
  4:          0          0          2   IO-APIC-edge    
  7:          1          0          0   IO-APIC-edge      parport0
  8:          0          0          1   IO-APIC-edge      rtc0
  9:          0          0          0   IO-APIC-fasteoi   acpi
 12:          0          0          6   IO-APIC-edge      i8042
 14:          2         60       3092   IO-APIC-edge      ide0
 16:          0          0          0   IO-APIC-fasteoi   ehci_hcd:usb3
 17:          0          0         10   IO-APIC-fasteoi   firewire_ohci, uhci_hcd:usb4
 19:          0          0          0   IO-APIC-fasteoi   uhci_hcd:usb5
 21:          0          1       3783   IO-APIC-fasteoi   ehci_hcd:usb2, nvidia
 22:          0         38       3660   IO-APIC-fasteoi   ohci_hcd:usb7
 23:          0         56      12519   IO-APIC-fasteoi   ehci_hcd:usb1, ohci_hcd:usb6
 26:          0         20      14517   PCI-MSI-edge      ahci
 27:          1          9       9399   PCI-MSI-edge      eth0
NMI:          0          0          0   Non-maskable interrupts
LOC:      52098      25718      20914   Local timer interrupts
SPU:          0          0          0   Spurious interrupts
PMI:          0          0          0   Performance monitoring interrupts
PND:          0          0          0   Performance pending work
RES:     100768      75992      47894   Rescheduling interrupts
CAL:         38        147        175   Function call interrupts
TLB:       2461       2859       2699   TLB shootdowns
TRM:          0          0          0   Thermal event interrupts
THR:          0          0          0   Threshold APIC interrupts
MCE:          0          0          0   Machine check exceptions
MCP:          3          3          3   Machine check polls
ERR:          1
MIS:          0
 lsmod | grep usb
snd_usb_audio          63830  1 
snd_pcm                60615  1 snd_usb_audio
snd_usb_lib            13745  1 snd_usb_audio
snd_rawmidi            15483  2 snd_usb_lib,snd_seq_midi
snd_hwdep               5364  1 snd_usb_audio
snd                    46350  9 snd_usb_audio,snd_pcm,snd_rawmidi,snd_hwdep,snd_seq,snd_timer,snd_seq_device
usbhid                 33132  0 
hid                    62825  1 usbhid
usb_storage            38521  2 
scsi_mod              121925  4 firewire_sbp2,sd_mod,usb_storage,libata
usbcore               121703  8 snd_usb_audio,snd_usb_lib,usbhid,usb_storage,uhci_hcd,ohci_hcd,ehci_hcd
nls_base                6377  7 nls_utf8,nls_cp437,isofs,vfat,udf,fat,usbcore
lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 004: ID 046d:0a06 Logitech, Inc. 
Bus 006 Device 003: ID 046d:c51c Logitech, Inc. 
Bus 006 Device 002: ID 0451:2036 Texas Instruments, Inc. TUSB2036 Hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

на что тут надо смотреть?

может кто подскажет где про прерывания можно прочитать, желательно на русском,

Dor ()
Ответ на: комментарий от Dor

Ну это скорее шутка была: в своё время, когда прерывания раздавались не автоматом, а выставлялись вручную в биосе, часто конфликты работы устройств были именно из-за того, что они имели одно прерывание на двоих.

У меня как-то одно прерывание делили звуковуха с мышкой — пока играл плеер мыша отказывалась ездить.

Если действительно хотите их проверить: посмотрите в hwinfo --mouse на каком убс висит мыша, затем в /proc/interrupts посмотрите кто висит на нём же и начинаем думать, что могло сделать одно устройство, и как это повлияло на другое.

В любом случае — на 90% уверен, что дело не в них.

Приёмопередатчик как-нибудь индицирует диодом питание на себе? Возможно правда просто отключается питание.

ZhAN ★★ ()
Ответ на: комментарий от Dor

Я бы поступил следующим образом:

1) включил музыку, подождал пока пропадёт, записал время и бегом грепить логи, что-то в этот момент должно происходить;

2) отрыл запылившийся ливсд и попробовал бы загрузиться с него и выявить подобные глюки (вдруг аппаратное);

3) то же самое, что и 2, но на другом компе.

ZhAN ★★ ()
Ответ на: комментарий от ZhAN

нда, всё печально, загрузился с лайва убунты 9.10, пока подключал и-нет для плагинов к плееру, повис гном, переключаюсь в первый терминал а там... привычная картина

4:1:1: usb_set_interface failed 
4:1:1: usb_set_interface failed 
4:1:1: usb_set_interface failed 
ну и так далее, 

в принципе ядро там то же, что и на моём сквизе вроде стоит, 2.6.32-3 и тут я как-то внимание обратил на пост чела с такой-же проблемой, ему там ничего не ответили, но в логах был тот же чипсет на материнке geForce 8200, как-то всё подозрительно очень, и проблема у него прям точь-в-точь такая. ( http://ubuntuforums.org/showthread.php?t=1399229 )

в общем щас попробую звук пустить через встроенную аудио карту, надеюсь поможет, надоело без звука и мышки сидеть уже =)

Dor ()
Ответ на: комментарий от Dor

кстати, спасибо за подсказку с лайвом, я чёт забыл про него ваще =)

Dor ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.