LINUX.ORG.RU

mplayer и два монитора


0

0

настроил 2 монитора как расширенный рабочий стол (nvidia, opensuse 11.2) - кое как работает
а вот mplayer отказывается воспроизводить видео - звук идет, картинки нет - вот лог:

mplayer -cache 18192 -vo vdpau -vc ffh264vdpau ./WRC.2010.Round03.Jordan.Day1.hr.pdtv.x264-sk0t.mkv
MPlayer dev-SVN-r30099-4.4-openSUSE Linux 11.2 (x86_64)-Packman (C) 2000-2009 MPlayer TeamCan't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing ./WRC.2010.Round03.Jordan.Day1.hr.pdtv.x264-sk0t.mkv.
Cache fill: 0.00% (0 bytes)
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1024x576 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 0.6 (00.5) of 1544.4 (25:44.4) 0.3% 96%

если второй монитор отключить, то mplayer воспроизводит нормально (и использует vdpau)
можно ли починить mplayer для случаz 2х мониторов ?
дрова с nvidia последние

причем - vlc при этом играет нормально

★★★★★

А ты чем расширяешь монитор? ЕМНИП, vdpau будет работать только с TwinView, к примеру, c xinerama vdpau не работает.

Да,

[vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (-vo) device.
у меня вылезает после второго запуска (перезапуска) X-сервера... Причину я так и не понял, драйвера последние (на 190.53 такой проблемы не было).

FakeLinux ()
Ответ на: комментарий от FakeLinux

да, настроено c xinerama
попробую twinview ...

x905 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.