LINUX.ORG.RU

[ШГ] Не применяются настройки шрифтов.


0

0

Здравствуйте.

Вынужден был сменить православный CRT на TFT. Шрифтам, конечно, сразу поплохело.

Ситуация такая. В GNOME всё нормально, стоят такие настройки: сглаживание - grayscale, хинтинг - full, шревт - DejaVu Sans Book, 8pt. Во FluxBox наблюдаю странные цветовые артефакты (крайне малозаметные красные точки, как при неправильном субпиксельном сглаживании).

~/.gtkrc-2.0:

# GTK+ Styles
gtk-theme-name="Elfin3"
#gtk-theme-name="Nodoka-Squared"
#gtk-theme-name="Nodoka-Silver"
#gtk-theme-name="Nodoka"
#gtk-theme-name="Nodoka-Gilouche"
#gtk-theme-name="Nodoka-Rounded"
#gtk-theme-name="Nodoka-Midnight"
#gtk-theme-name="Nodoka-Squared"
#gtk-theme-name="Nodoka-Looks"
#gtk-theme-name="Nodoka-Aqua"
#gtk-theme-name="Shiki-Brave"
#gtk-theme-name="Redmond"
#gtk-theme-name="Gray-Flat"
#gtk-theme-name="Elfin4"

# Icons
#gtk-icon-theme-name="Black-Gnome"
#gtk-icon-theme-name="gnome-brave"
gtk-icon-theme-name="ACYL"
#gtk-icon-theme-name="black-white_2-Style"
#gtk-icon-theme-name="elementary_2.2"
#gtk-icon-theme-name="LaGaDesk-BlackWhite-III"

# Fonts
#gtk-font-name="Droid Sans 8"
gtk-font-name="DejaVu Sans Book 8"
#gtk-font-name="AG_Futura 9"
#gtk-font-name="Sans 7"
#gtk-font-name="Tahoma 8"

# Icon sizes
gtk-menu-images=0
gtk-panel-images=0
gtk-button-images=0
gtk-icon-sizes="panel-menu=16,16:panel=16,16:gtk-button=16,16:gtk-large-toolbar=16,16"

# Disable menu shortcuts underlining
gtk-enable-mnemonics=0

# Toolbar style
gtk-toolbar-style=0

~/.fonts.conf:

<?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintfull</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

Дистрибутив - Debian Lenny.

Что я делаю не так?

Заранее спасибо.

★★★★★

Еще автохинтер выруби

nkt@doriath ~ % cat /etc/fonts/conf.avail/10-no-autohint.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Don't use the Autohinter --> 
  <match target="font">
    <edit name="autohint" mode="assign">
      <bool>false</bool>
    </edit>
  </match>
</fontconfig>

fat_angel ★★★★★ ()
Ответ на: комментарий от fat_angel

И кстати попробуй все же субпиксельное сглаживание, на моем лаптопе оно выглядит намного приятнее. Т.е.

nkt@doriath ~ % cat /etc/fonts/conf.d/10-sub-pixel-rgb.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!--  Enable sub-pixel rendering --> 
  <match target="font">
    <edit name="rgba" mode="assign"><const>rgb</const></edit>
  </match>
</fontconfig>

fat_angel ★★★★★ ()
Ответ на: комментарий от fat_angel

Автохинтер и так был выключен, а субпиксельное сглаживание либо даёт цветной ореол (в FF), либо незаметно (в остальных) программах.

По топику: никаких красных точек под увеличительным стеклом не обнаружил %) Ощущение «неправильности» возникало из-за слегка отличных представлений о DPI у гнома и иксов, похоже.

GotF ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.