LINUX.ORG.RU

Freebsd, Не собирается compiz-fusion


0

0

eva01$ uname -a FreeBSD eva01 7.2-STABLE FreeBSD 7.2-STABLE #0: Thu Jun 11 12:27:03 EEST 2009 paranormal@eva01:/usr/obj/usr/src/sys/EVA01 i386

При попытке установки вывыливается вот этим:

cc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include/startup-notification-1.0 -I/usr/local/include -D_THREAD_SAFE -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include -I/usr/local/include/librsvg-2 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/gtk-2.0 -D_THREAD_SAFE -I/usr/local/include/cairo -I/usr/local/include -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -DORBIT2=1 -D_REENTRANT -I/usr/local/include/gconf/2 -I/usr/local/include/orbit-2.0 -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include -I/usr/local/include/libxml2 -I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -DFUSE_USE_VERSION=26 "-DALL_LINGUAS=\"af ar bg bn bn_IN bs ca cs cy da de el en_GB en_US es eu et fi fr gl gu he hi hr hu id it ja ka km ko lo lt mk mr nb nl or pa pl pt pt_BR ro ru sk sl sr sv ta tr uk vi xh zh_CN zh_TW zu\"" -DLOCALEDIR=\"/usr/local/share/locale\" -DPLUGINDIR=\"/usr/local/lib/compiz\" -DIMAGEDIR=\"/usr/local/share/compiz\" -I../include -I../include -DMETADATADIR=\"/usr/local/share/compiz\" -I/usr/local/include -O2 -fno-strict-aliasing -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -D_FORTIFY_SOURCE=2 -MT png.lo -MD -MP -MF .deps/png.Tpo -c png.c -o png.o >/dev/null 2>&1 mv -f .deps/png.Tpo .deps/png.Plo /bin/sh /usr/local/bin/libtool --tag=CC --mode=link cc -O2 -fno-strict-aliasing -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -D_FORTIFY_SOURCE=2 -module -avoid-version -no-undefined -L/usr/local/lib -pthread -o libpng.la -rpath /usr/local/lib/compiz png.lo -L/usr/local/lib -lpng -lz -lm

*** Warning: Linking the shared library libpng.la against the loadable module *** libpng.so is not portable! rm -fr .libs/libpng.a .libs/libpng.la .libs/libpng.lai .libs/libpng.so cc -shared .libs/png.o -Wl,--rpath -Wl,/usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins/.libs -Wl,--rpath -Wl,/usr/local/lib/compiz -L/usr/local/lib -pthread /usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins/.libs/libpng.so -lz -lm -pthread -pthread -pthread -Wl,-soname -Wl,libpng.so -o .libs/libpng.so cc: /usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins/.libs/libpng.so: No such file or directory

Чего ему надо ? Ума не приложу. Все вроде установлено, а C и libtool я не знаю.

Re: Freebsd, Не собирается compiz-fusion

cc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include/startup-notification-1.0 -I/usr/local/include -D_THREAD_SAFE -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include -I/usr/local/include/librsvg-2 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/gtk-2.0 -D_THREAD_SAFE -I/usr/local/include/cairo -I/usr/local/include -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -DORBIT2=1 -D_REENTRANT -I/usr/local/include/gconf/2 -I/usr/local/include/orbit-2.0 -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include -I/usr/local/include/libxml2 -I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -DFUSE_USE_VERSION=26 "-DALL_LINGUAS=\"af ar bg bn bn_IN bs ca cs cy da de el en_GB en_US es eu et fi fr gl gu he hi hr hu id it ja ka km ko lo lt mk mr nb nl or pa pl pt pt_BR ro ru sk sl sr sv ta tr uk vi xh zh_CN zh_TW zu\"" -DLOCALEDIR=\"/usr/local/share/locale\" -DPLUGINDIR=\"/usr/local/lib/compiz\" -DIMAGEDIR=\"/usr/local/share/compiz\" -I../include -I../include -DMETADATADIR=\"/usr/local/share/compiz\" -I/usr/local/include -O2 -fno-strict-aliasing -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -D_FORTIFY_SOURCE=2 -MT png.lo -MD -MP -MF .deps/png.Tpo -c png.c -o png.o >/dev/null 2>&1
mv -f .deps/png.Tpo .deps/png.Plo
/bin/sh /usr/local/bin/libtool --tag=CC --mode=link cc -O2 -fno-strict-aliasing -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -D_FORTIFY_SOURCE=2 -module -avoid-version -no-undefined -L/usr/local/lib -pthread -o libpng.la -rpath /usr/local/lib/compiz png.lo -L/usr/local/lib -lpng -lz -lm

*** Warning: Linking the shared library libpng.la against the loadable module
*** libpng.so is not portable!
rm -fr .libs/libpng.a .libs/libpng.la .libs/libpng.lai .libs/libpng.so
cc -shared .libs/png.o -Wl,--rpath -Wl,/usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins/.libs -Wl,--rpath -Wl,/usr/local/lib/compiz -L/usr/local/lib -pthread /usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins/.libs/libpng.so -lz -lm -pthread -pthread -pthread -Wl,-soname -Wl,libpng.so -o .libs/libpng.so
cc: /usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins/.libs/libpng.so: No such file or directory
gmake[1]: *** [libpng.la] Ошибка 1
gmake[1]: Leaving directory `/usr/ports/x11-wm/compiz/work/compiz-0.8.2/plugins'
gmake: *** [install-recursive] Ошибка 1
*** Error code 2

Stop in /usr/ports/x11-wm/compiz.
*** Error code 1

Stop in /usr/ports/x11-wm/compiz.
eva01#

paranormal ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.