LINUX.ORG.RU

кодировка в слаке


0

0

как локализовать линукс слаку 9.0? а то все русские файлы отражаются вопросами

в мандрайке - всё просто рпмку скачала и локализовала

а здесь как? если моно подробно :) если моно?

Re: кодировка в слаке

Взято http://multilinux.sakh.com

1. Содержимое файла /etc/rc.d/rc.font
setfont Cyr_a8x16
mapscrn koi2alt
for n in 1 2 3 4 5 6; do
echo -ne "\033(K" > /dev/tty$n
done

2. Содержимое файла /etc/rc.d/rc.keymap
loadkeys ru-ms.map

3. /etc/profile.d/lang.sh
export LC_ALL=
export LANG=ru_RU.KOI8-R
export LC_NUMERIC=C
export LC_TIME=ru_RU.KOI8-R
export LC_COLLATE=ru_RU.KOI8-R
export LC_MONETARY=ru_RU.KOI8-R
export LC_MESSAGES=ru_RU.KOI8-R
export LC_PAPER=ru_RU.KOI8-R
export LC_NAME=ru_RU.KOI8-R
export LC_ADDRESS=ru_RU.KOI8-R
export LC_TELEPHONE=ru_RU.KOI8-R
export LC_MEASUREMENT=ru_RU.KOI8-R
export LC_IDENTIFICATION=ru_RU.KOI8-R

Маленькое замечание- можно просто поставить LC_ALL=ru_RU.KOi8-R, но при таком раскладе в старой Слакваре у меня не все программы работали корректно, в частности LICQ.

4. /usr/share/locale
Денис рекомендует в файле locale.alias заменить секцию russian на:
russian ru
ru ru_RU
ru_RU ru_RU.KOI8-R
Но у меня без всякой замены работает и так.

5. /etc/X11
В файле XF86Config поменялась установка раскладок клавиатуры:
Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

Именно надо не забыть добавить us,ru а то иначе запаритесь искать как обратно переключить раскладку ;)


6. там же
На забудьте прописать пути к truetype шрифтам и для "верочки" желательно перейти в каталог со шрифтами, удалить старый fonts.cache-1 (у меня почему то он не переписывался) и выполнить /usr/X11R6/bin/fc-cache


madfire (*) (2003-04-22 14:53:34.456139)

Narian ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.