LINUX.ORG.RU

То ли лыжи не едут, то ли я...


0

0

Захожу в gimp, выбираю шрифт для надписи, а там шрифтов штук 8 всего.
Я удивился и расстроился (а говоря попросту, ох.ел), потому что
оказалось, что не грузятся ttf'ки.
Захожу в приложения qt - ttf'ки есть.
(Видимо за счет xft2).
Иду в XF86Config-4 (ну и симлинки, естественно, на все выставлены,
типа /etc/X11/XF86Config и т.п.)
Модуль freetype грузится (2.1.3, что ли, короче как у rh).
А в самом конце лога висит надпись
Could not init font path element '/usr/X11R6/lib/X11/fonts/msttf'.
Я захожу туда, путь уже копирую с mc, остальные фонты там,
fonts.dir создан, fonts.alias тоже. Проверяю права на чтение и поиск.
Все есть, но ничего не работает.
У кого была такая проблема - хелп.

★★★★★

Re: То ли лыжи не едут, то ли я...

/etc/X11/fs/config
и да пребудет с вами сила

joker ()

Re: То ли лыжи не едут, то ли я...

chkfontpath --add /usr/X11R6/lib/X11/fonts/msttf

/etc/rc.d/init.d/xfs restart

Перестартануть X server.

wildhoney ()

Re: То ли лыжи не едут, то ли я...

Вы будете долго смеяться.
Ну во-первых, /etc/X11/fs/config был и там было все в порядке
(ибо не первый год замужем :)

Во-вторых, xft сроду не был у меня запущен, но и после запуска
он не помог.

Удивительная проблема решилась переименованием шрифтов в нижний
регистр.
Почему - хз.
Точно помню, что 4.2.0/4.2.1 работали с любыми названиями файлов.
Тут - первую букву фонта в верхний регистр загоняешь и писец.

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.