LINUX.ORG.RU

openSUSE 10.3, обновление до Gnome 2.22 из сырцов, трабла с маунтом устройств


0

0

На свою голову собрал из сырцов новый nautilus 2.22(попутно обновив все чего ему надо было - glib, eel, gnome-desktop и пр.), в итоге адреса вроде computer:/// и burn:///(nautilus-cd-burn тоже обновлял если что) он напрочь перестал понимать(smb видать тоже накрылся). Апофеозом стало то что простым юзерам теперь запрещено маунтить сменные носители, маунтится только то что есть в fstab, все остальное при вставке показывает пустое окошко с заголовком "Ошибка монтирования" :) Понимаю что телепатией мало кто обладает, но есть ли у кого-то какие-либо соображения какого оно взбесилось? :)

★★★★

Re: openSUSE 10.3, обновление до Gnome 2.22 из сырцов, трабла с маунтом устройств

Вы извращенец? Зачем в бинарном дистрибутиве собирать GNOME из исходников, если вы не разработчик? Неудивительно, что ничего не работает.

Для любителей собирать все из исходников есть Gentoo. Для всех остальных есть обновления в дистрибутиве и неофициальные репозитации с самыми свежими версиями пакетов.

Rikz ★★★ ()

Re: openSUSE 10.3, обновление до Gnome 2.22 из сырцов, трабла с маунтом устройств

ну за вычитку морали канеша пасиб, только я хотел бы чего по делу услыш... прочитать т.е. :)

Собранная версия 2.20 работала на ура(видать придется откатится), да и балуясь на другой машине с svn-ом 2.21 тоже подобных трабл не наблюдалось.

Andru ★★★★ ()

Re: openSUSE 10.3, обновление до Gnome 2.22 из сырцов, трабла с маунтом устройств

Не сталкивался, но если подумать, то одно из самых больших изменений в 2.22 - gio и gvfs. Т.е. я бы копал в сторону HAL, dbus и этих двух новинок. Можно попробовать запустить gnome-volume-manager из терминала с ключами на вывод инфы и посмотреть, что он пишет.

Rikz ★★★ ()

Re: openSUSE 10.3, обновление до Gnome 2.22 из сырцов, трабла с маунтом устройств

>>Т.е. я бы копал в сторону HAL
дауж, видать тут явно собака зарыта, т.к. схожие траблы были при апдейте HAL'а до стейбл-версии(в сусе гит-сборка). Но сколько не шаманил с файлами настроек, сколько не прописывал права юзерам в файлах которые указаны в man'е - всегда получал permission denided :) Т.к. все-же нужна рабочая машина, пришлось откатился обратно до 2.20... а жаль, пару приятных мелочей не помешали бы, да и новый brasero теперь зависит от glib 2.16... Порой маниакальная система безопасности начинает доставать.

Andru ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.