LINUX.ORG.RU

VirtualBox - sign the kernel modules?

 ,


0

1

Поставил на новкупленном компе VirtualBox, система Linux Mint Mate 21 (ubuntu 22.04). VB скачаль с oracle virtualbox-7.0_7.0.4-154605~Ubuntu~jammy_amd64.deb. В консоли вижу вот такое:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (5.15.0-58-generic) or it failed to load. Please recompile the kernel module and install it by sudo /sbin/vboxconfig You will not be able to start VMs until this problem is fixed.
Запускаю sudo /sbin/vboxconfig, не помогает
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: Signing VirtualBox kernel modules.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox.  To re-start the set-up process, run /sbin/vboxconfig as root.  If your system is using EFI Secure Boot you may need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.
Поискал в гугле, попробовал часть «рецептов», не помогает. Ставил Минт с uefi, пишут что проблема в этом. В bios нету опции отключить Security Boot. Есть только выбор, либо Windows UEFI или Other OS. Пробовал и то и другое. Бестолку. Есть идеи как преодолеть это безобразие? Пользуюсь VB давно, первый раз такое.

Наше случайно решение. Отпишусь может кому поможет. Во-первых, чтобы убрать все эти проблемы надо зайти не через boot загрузка, а через MOK и ввести пароль. Все ошибки в моем посте исчезнут после перезагрузки. Но VB все равно не работал, а писал AMD-V is disabled in the BIOS. Оказывается AMD-V это SVM в BIOS и он был действительно выключен. После включения все заработало.

rustamych ★★★
()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.