LINUX.ORG.RU

Linux не загружается без nomodeset

 , ,


0

2

Здравствуйте, поставил себе kubuntu и столкнулся с проблемой чёрного экрана при выборе этой ос в списке grub. Запускается только с nomodeset. Если запустить ос, то видно, что местами появляются артефакты (особенно при использовании latte dock). Было ясно, что скорее всего что-то не так с драйверами (у меня amd radeon vega). Но убунтовская прога показывает, что драйверов для меня нет (no additional drivers available). Утилита ubuntu-drivers devices ничего не выводит, какие могут быть варианты? Видать, что-то с xorg, но вот что делать не знаю. (И к тому же, система считает ,что у меня подключено несколько мониторов и периодически предлагает мне выбрать настройки)

Ответ на: комментарий от Mixa

Ничего не помогает, есть дрова, но на ubuntu 19.10 не ставятся, только для 18.04.

IProstoSprosit ()
Ответ на: комментарий от IProstoSprosit

Поконкретнее можешь? Все расплывчато слишком.

Какой дистрибутив у Тебя? Какая видеокарта? Как определил? Какие драйвера берешь? Откуда? Как ставишь? Что не получается?

Для начала вопросов хватит?

Чем больше будет инфо - тем быстрее получишь ответ.

Mixa ()
Ответ на: комментарий от Mixa

Короче, такая ситуация, kubuntu 19.10 стоит второй системой рядом с десяткоой и запускается только с nomodeset. Но с добавлением этого ноумода отключается аппаратное ускорение, а потому и происходят парой мерцания. А при просмотре видео на ютьюбе проц грузится под 80-100. Теперь по вопросам 1)Kubuntu 19.10 2)amd radeon vega 3 3)определил карту из под винды и из описания устройства 4)Пробовал вот эти https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-10-unified не подошли(не устанавливаются на 19.10, а только для 18.04) пробовал еще с припиской 19.30 и 19.50… аналогично 5)Ставлю через консоль(по инструкции) ./amdgpu-install 6)выдаёт, что только для 18.04

IProstoSprosit ()
Ответ на: комментарий от IProstoSprosit

Также переодически, как я уже писал, kubuntu предлагает переключится на внешний монитор, которого нет. И еще ситуация с процом дрянь, (видимо из-за отключения аппаратного ускорения, но может и нет) при открытии например какого-нибудь окна нагрузка подскакивает до 50% и также резко падает, с видео стабильно 80-100%

IProstoSprosit ()
Ответ на: комментарий от IProstoSprosit

У Тебя ноутбук? Если да, то какой?

  1. Тебе как новичку я советовал бы установить Kubuntu 18.04 LTS. Это более стабильная версия чем 19.10.

  2. Есть свободные драйвера для твоей карты AMDGPU, а есть проприетарные AMDGPU pro. Последняя версия 19.50 Здесь описано как устанавливаются драйвера на Debian (Убунту дериват Дебиана).

  3. Насчёт двух мониторов. Выполни в эмуляторе терминала команды

lspci -vv >lspci.txt
inxi -Fxxxrz >inxi.txt

Программу inxi установи из оф.репы (если не установлена). Залей файлы lspci.txt и inxi.txt на pastebin.com и дай ссылки.

Mixa ()
Последнее исправление: Mixa (всего исправлений: 1)
Ответ на: комментарий от Mixa

Итак, поставил 18.04. Проблема глухого зависания с черным экраном не исчезла. Установил драйвера с сайта amd. Они вроде как установились, но, как я понял, с nomodeset запускаться не хотят. Вот такой вывод:WARNING: nomodeset detected in kernel parameters, amdgpu requires KMS А с выключенным nomodeset - черный экран. Нашёл человека, у которого похоже ситуация, один в один как у меня, https://forum.ubuntu.ru/index.php?topic=300431.0 Но решения проблемы там нет.

IProstoSprosit ()
Ответ на: комментарий от IProstoSprosit

Я же писал про свободные драйвера. Ну что за привычка сразу ставить драйвера с сайта производителя.

Статью, ссылку на которую я дал, Ты конечно не читал.

Выводы команд, что я просил, Ты не дал.

ИМХО, У Тебя конфликт драйверов. Определись свободные - удаляй проприетарные, проприетарные - удаляй свободные. На двух стулах усидеть не удастся.

С Live USB Убунту грузиться? Или тоже черный экран?

Всё больше склоняюсь, к мысли, что линукс не для моего железа.

Ну потыкал Linux c live или в Виртуалке. Ну не понравилось. Тебе решать. За уши тащить никто не будет.

Mixa ()
Ответ на: комментарий от IProstoSprosit

Нашёл человека, у которого похоже ситуация, один в один как у меня, https://forum.ubuntu.ru/index.php?topic=300431.0 Но решения проблемы там нет.

Последнее сообщение в теме внимательно прочти. Автор обновил свободные драйвера и все заработало. Или я плохо вычитал?

Если нет желания возится, то просто закрой тему.

Mixa ()
Последнее исправление: Mixa (всего исправлений: 1)

а в этих ваших кубунтах есть нечто подобное firmware-amd-graphics?

amd_amd ★★★ ()
Ответ на: комментарий от Mixa

Последнее сообщение в теме внимательно прочти.

Не, это не автор статьи, просто человек поделился решением с похожей проблемой

Если нет желания возится, то просто закрой тему.

Так,наверное, и сделаю, 4 дня помучился, думаю хватит) Короч, большое тебе спасибо за то, что повозился со мной, побольше бы таких людей на форумах. Но на этом я, пожалуй, приостановлю постижение линукса. Удачи тебе

IProstoSprosit ()
Ответ на: комментарий от amd_amd

В этих наших кубунтах прошивки лежат в linux-firmware, и от AMDшной графики в том числе.

damix9 ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей