LINUX.ORG.RU

Debian 10 netinstall - нет звука

 ,


0

1

Доброго времени суток уважаемому сообществу.

Собрал новый комп. Поставил Debian Netinstall.
Установил alsa-tools alsa-utils pulseaudio pulseaudio-utils normalize-audio - нет звука.
Вот вывод lspci -k

lspci -k
00:00.0 Host bridge: Intel Corporation Device 3e0f (rev 07)
        Subsystem: Gigabyte Technology Co., Ltd Device 5000
        Kernel driver in use: skl_uncore
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
        Kernel driver in use: pcieport
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
        Subsystem: Gigabyte Technology Co., Ltd Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation 200 Series/Z370 Chipset Family USB 3.0 xHCI Controller
        Subsystem: Gigabyte Technology Co., Ltd 200 Series/Z370 Chipset Family USB 3.0 xHCI Controller
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci
00:16.0 Communication controller: Intel Corporation 200 Series PCH CSME HECI
        Subsystem: Gigabyte Technology Co., Ltd 200 Series PCH CSME HECI
        Kernel driver in use: mei_me
        Kernel modules: mei_me
00:17.0 SATA controller: Intel Corporation 200 Series PCH SATA controller [AHCI mode]
        Subsystem: Gigabyte Technology Co., Ltd 200 Series PCH SATA controller [AHCI mode]
        Kernel driver in use: ahci
        Kernel modules: ahci
00:1c.0 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port (rev f0)
        Kernel driver in use: pcieport
00:1c.5 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port (rev f0)
        Kernel driver in use: pcieport
00:1c.6 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port (rev f0)
        Kernel driver in use: pcieport
00:1c.7 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port (rev f0)
        Kernel driver in use: pcieport
00:1d.0 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port (rev f0)
        Kernel driver in use: pcieport
00:1d.2 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port (rev f0)
        Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Device a2ca
        Subsystem: Gigabyte Technology Co., Ltd Device 5001
00:1f.2 Memory controller: Intel Corporation 200 Series/Z370 Chipset Family Power Management Controller
        Subsystem: Gigabyte Technology Co., Ltd 200 Series/Z370 Chipset Family Power Management Controller
00:1f.3 Audio device: Intel Corporation 200 Series PCH HD Audio
        Subsystem: Gigabyte Technology Co., Ltd 200 Series PCH HD Audio
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
00:1f.4 SMBus: Intel Corporation 200 Series/Z370 Chipset Family SMBus Controller
        Subsystem: Gigabyte Technology Co., Ltd 200 Series/Z370 Chipset Family SMBus Controller
        Kernel driver in use: i801_smbus
        Kernel modules: i2c_i801
01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050] (rev a1)
        Subsystem: ASUSTeK Computer Inc. GP107 [GeForce GTX 1050]
        Kernel driver in use: nvidia
        Kernel modules: nvidia
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. GP107GL High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
        Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet
        Kernel driver in use: r8169
        Kernel modules: r8169


В списке устройств, есть только GP107GL High definition audio controller digital stereo (HDMI2). Но alsamixer в консоли, показывает и встроенную звучку Intel. И даже даёт управлять её уровнем громкости. Подозреваю, что нет каких-то драйверов, но каких... В предыдущей версии Debian всё вставало из коробки... А тут... Подскажите пожалуйста - что делать?

В списке устройств, есть только GP107GL High definition audio controller digital stereo (HDMI2).

Так вот же еще - Audio device: Intel Corporation 200 Series PCH HD

Но alsamixer в консоли, показывает и встроенную звучку Intel. И даже даёт управлять её уровнем громкости.

ЕМНИП по дефолту звук в alsamixer замьючен (MM в колонке Master). Может проблема в этом.

bowtda ()

«Если в кране нет воды,

Значит не друг ее выпил, а ты

Если в кране появилась вдруг вода

Значит это друг отлил ее туда»

(с) Кирпичи

Найди себе друзей, и звук появится.

anonymous ()
Ответ на: комментарий от bowtda

В списке устройств, есть только GP107GL High definition audio controller digital stereo (HDMI2).


Я писал о списке устройств в окне настроек системы.

ЕМНИП по дефолту звук в alsamixer замьючен (MM в колонке Master). Может проблема в этом.


Я знаю об этом. Проверил. Все ползунки выкручены на максимум и звук активирован.

То есть я подозреваю, что какие-то драйвера не установились вместе с ALSA. Потому что в списке аудио-устройств в окне настроек системы, есть только HDMI, который на видяхе. Он бы и работал, наверное, будь у меня мультимедийный монитор.

Nextez ()
Ответ на: комментарий от Nextez

Давно не заходил я на ЛОР... Но таки ничего не меняется...

Давно не заходил

«И-го-го, ёжик!»

anonymous ()
Ответ на: комментарий от Nextez

А Джек - это кто?

Ну и на каком ЛОРе ты когда был? Ты НЕ знаешь Джека?! Тебя тут не было и быть не могло.

anonymous ()
Ответ на: комментарий от Nextez

ищи в запущенных процессах jackd или jackdbus. Если запущен - убей его и выясняй откуда он взялся в автозапуске. Джек - это айдиосервер для «звукачей»

ChekPuk ★★★ ()
Ответ на: комментарий от Rootlexx

alsamixer, что любопытно, показывает, что у меня, как бэ, две звучки. И позволяет управлять настройками громкости обеих звучек. Но вот в Панели настроек Plasma, в разделе Мультимедиа, звуковое устройство одно и это HDMI на видяхе. Других звуковых устройств в панели нет.
Почитал про JACK - хотелось бы таки оставить pulseaudio, ибо не все приложения корректно работают с JACK`ом. Я понимаю, что JACK это «хоть что-то», но таки оставлю его на крайний случай.
Может ли быть так, что не хватает каких-то пакетов, для того, чтобы встроенная звучка появилась в панели настроек, где я мог бы уже руками выбрать её как устройство по-умолчанию?

Nextez ()
Ответ на: комментарий от Rootlexx

Уже разобрался. Нужно было, изначально, при сборке системы, сперва поставить звук, а потом - видяху с её HDMI. В общем пересобрал систему в такой последовательности - и вуаля. Звук есть. Всё работает без проблем.

Nextez ()
Ответ на: комментарий от Nextez

Надо просто установить звуковую по умолчанию. И это можно сделать не вырезая гланды через жопу

anonymous ()

установил alsa-tools alsa-utils pulseaudio pulseaudio-utils normalize-audio

нужно только alsa-utils, а потом

# alsactl init
регулировать звук в alsamixer

amd_amd ★★★★ ()
Последнее исправление: amd_amd (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.