LINUX.ORG.RU

lubuntu баг при логине

 ,


1

1

Интересный баг. Ставлю юзерам лубунточку на десктоп, сам тоже сталкивался. По принципу чтобы работало и не ковыряться дальше. Окружение стандартное, работает норм, какое то время. Далее происходит сбой, выражающийся в том что запрашивает пароль и не логинится при вводе правильного, запрос пароля отключаю естественно. Где бы соломки подстелить? Хочу чтобы все просто работало, «поставил и забыл». В принципе лечится конечно же удалением каталога .config.

А «что» было не интересовался? Ошибки аутентификации или ...?

Похожее поведение наблюдал при «порче» .Xauthority и какой-то проблеме в lightdm (тоже не разбирался, но «оно» больше не повторялось).

anymouze ★★ ()
Ответ на: комментарий от ne1rolog

У меня на виртуалке 64 битной та же тема была.

Попробую расписать ситуацию поподробнее. Если где ошибусь, поправишь.

Dm - lightdm? В нём ты прописал автологин? Включаешь компьютер, всё запускается, автологин срабатывает, через пару минут падение сессии и логин?

Deleted ()
Ответ на: комментарий от ne1rolog

Автологин. Просит пароль.

Автологин не просит пароль, если он работает. Вы говорите загадками. Моё описание событий (см. выше) верно или нет?

Deleted ()
Ответ на: комментарий от ne1rolog

Верно. Автологин включен еще при установке

Лечения не знаю. Знаю, что это связано с lightdm. Знаю, что если сразу запустить lxterminal, даже ничего в нём не делая, это значительно увеличивает продолжительность сессии до лага. Знаю, что если lightdm поменять на gdm, лаг исчезнет.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от ne1rolog

Неправильно. Правильно так — включить обновления, обновить по максимуму. Вдруг в новых версиях ПО эту проблему устранили? Нужно посмотреть вывод

sudo apt install -f
на предмет ошибок ещё.

Если не сработает, то попробуй переставить LightDM с удалением конфигов. Делается так: Ctrl+Alt+F2, в tty2 входишь,

sudo systemctl stop lightdm
sudo apt remove --purge lightdm
sudo apt install lightdm
sudo reboot
После этого могут сброситься настройки автологина, придется настраивать. Кстати, где вывод
cat /etc/lightdm/lightdm.conf
?

Если проблема продолжается — возьми и поменяй DM. Как вариант, на фирменный от LXDE — LXDM и настрой в нём автологин.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)

Короче, возьми и поменяй LightDM на LXDM. Вот как это сделать:

  1. Для начала, обнови систему по максимуму. Подключи репозитории с обновлениями, если ты отключил их, и выполни
    sudo apt update && sudo apt upgrade
    Проверь вывод
    sudo apt install -f
    на предмет ошибок.
  2. Перезагрузи машину и войди в свою сессию ещё раз. Потом выполни команду
    sudo apt install lxdm
    , после чего тебя могут спросить, какой DM использовать — выбери LXDM, но если не этого произошло, то выбери его вручную, введя команды
    sudo systemctl disable lightm
    sudo systemctl enable lxdm
  3. Настрой автологин в LXDM. Тут всё просто — введи команду
    echo $USER
    , чтобы узнать имя своего пользователя. Потом введи команду
    sudo sed -i 's/# autologin=dgod/autologin=имятвоегопользователя/' /etc/lxdm/lxdm.conf
    , потом перезагрузи машину.
Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 3)