LINUX.ORG.RU

Ошибка TLS в браузерах на WebKit

 , ,


0

1

Значит, собрал я в своей генте webkit-gtk, поставил Midori, в домашней сетке всё пашет как надо. А в рабочей трафик ходит через HTTP-прокси (задаю в /etc/environment), и Midori вместо любой страницы выдаёт что-то там про unexpected TLS packet. То же самое в surf (тоже на WebKit), который я поставил для проверки. Приложил бы более вразумительное описание ошибки, но оба браузера при этом ничего не выводят в консоль.

Софт, не требующий шифрования, работает: emerge, pyradio, например. Менеджер пакетов в R не работает, ему нужен HTTPS. Так вот, это я что-то не дособирал или просто кривые руки?

Менеджер пакетов в R не работает, ему нужен HTTPS

Так у тебя вообще https не работает, или только в webkit-gtk? Странно, что это повлияло на R. Проверь, работают ли curl и wget.

slvrn ★★★ ()

webkit-gtk

Это говно мамонта ещё живое?

Midori

У кого-нибудь оно не падает на ровном месте (обычно при жоре рамы)?

Для начала синхронизируй время, потом смотри в как у тебя собран openssl.

r3lgar ★★★★★ ()
Ответ на: комментарий от fbiagent

ntpd: time set -64.532684s Много разве?

slvrn, первый раз наткнулся в браузере на WebKit, отсюда и название темы. Ещё пробовал, кстати, links, но там просто вылезла ошибка без подробностей, мол, не удалось подключиться.

Проверь, работают ли curl и wget.

По-моему, что-то из этого используется в emerge, если память не изменяет. А он работает. Но я перепроверю, как буду на работе.

gentoo1love, так ясное дело, что если 2 сетки различаются наличием прокси, то в нём и дело. На виндовой машине рядом я указываю адрес прокси в настройках браузера (кстати, Opera на WebKit), ставлю галку «использовать для всех протоколов», и всё работает. Здесь я пишу в /etc/environment:

http_proxy="http://10.128.x.x:8080/"
https_proxy="https://10.128.x.x:8080/"
HTTP_PROXY="http://10.128.x.x:8080/"
HTTPS_PROXY="https://10.128.x.x:8080/"
но получаю кукиш без масла. В настройках самого Midori тоже пробовал задавать, кстати, с тем же успехом.

al_exquemelin ★★★ ()
Ответ на: комментарий от r3lgar

как у тебя собран openssl

 * Found these USE flags for dev-libs/openssl-1.0.2o-r3:
 U I
 + + asm                : Support assembly hand optimized crypto functions (i.e. faster run time)
 - - bindist            : Disable/Restrict EC algorithms (as they seem to be patented) -- note: changes the
                          ABI
 - - cpu_flags_x86_sse2 : Use the SSE2 instruction set
 - - gmp                : Add support for dev-libs/gmp (GNU MP library)
 - - kerberos           : Add kerberos support
 - - rfc3779            : Enable support for RFC 3779 (X.509 Extensions for IP Addresses and AS Identifiers)
 - - sctp               : Support for Stream Control Transmission Protocol
 - - sslv2              : Support for the old/insecure SSLv2 protocol -- note: not required for TLS/https
 + + sslv3              : Support for the old/insecure SSLv3 protocol -- note: not required for TLS/https
 - - static-libs        : Build static versions of dynamic libraries as well
 - - test               : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2
                          handles this internally, so don't set it in make.conf/package.use anymore
 + + tls-heartbeat      : Enable the Heartbeat Extension in TLS and DTLS
 - - vanilla            : Do not add extra patches which change default behaviour; DO NOT USE THIS ON A GLOBAL
                          SCALE as the severity of the meaning changes drastically
 + + zlib               : Add support for zlib (de)compression
al_exquemelin ★★★ ()
Ответ на: комментарий от al_exquemelin

Попробуй в https_proxy указать протокол http, а не https.

Ну и если не поможет, то выясняй, с каким криптографическим провайдером линкуется webkit, и дальше ищи проблемы уже в нем.

slvrn ★★★ ()
Ответ на: комментарий от slvrn

Попробуй в https_proxy указать протокол http, а не https.

Во, отлично. Так заработал и браузер, и пакетный менеджер в R. Спасибо.

Конфиг с https:// у меня работал под убунтой, поэтому я и удивился, мягко говоря. Но там был Firefox, и он, похоже, не смотрит на значения в /etc/environment. А вот Midori их учитывает и даже предпочитает внутренним настройкам, судя по всему.

al_exquemelin ★★★ ()