LINUX.ORG.RU

Игры не воспринимают клавиатуру

 , , ,


1

3

Игры не воспринимают клавиатуру, если запускать их с включенной русской раскладкой. Если включена английская, то после запуска игры клавиатура воспринимается нормально. В т.ч. русский язык. Не фатально, конечно, но все время следить за раскладкой не хочется. Кто-то знает возможное решение?

Система - Debian 9.

На клавиатуре есть индикатор «Scroll Lock». Можно сделать чтобы когда менялась раскладка на русскую, то он загорался. Как-то так

Section "InputClass"
        Identifier "evdev keyboards-all"
        Driver "evdev"
        Option "XkbLayout" "us,ru"
        Option "XkbVariant" "winkeys"
        Option "XkbOptions" "grp:lctrl_lshift_toggle,grp_
led:scroll"
        MatchIsKeyboard "on"
EndSection

anonymous ()

Похоже, нормального решения нет. Ставь английскую раскладку первой, должно помочь.

aplay ★★★★★ ()

добавь к строке запуска игры смену раскладки через xcb.. \и возможно надо будет сделать раскладку индивидуальной для приложений, но ето не точно.

Thero ★★★★★ ()
Ответ на: комментарий от Thero

Добавлять xcb ко всем играм и программам с opengl - как-то неудобно, знаете ли. К тому же это костыль, но ладно, к костылям я уже привык. А индивидуальная раскладка для окон это идея, она же будет автоматически на первую в списке ставиться при запуске, если я не ошибаюсь. Щас попробую и отпишусь чё как.

nikitosios20031 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.