LINUX.ORG.RU

[РЕШЕНО] Как настроить внешний вид Qt5 приложений в Xfce на Debian Stretch?

 , , , ,


6

3

Много чего перепробовал, не помогло. Прочитал это: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822697 , но рецепт не сработал. Я прописал в ~/.profile в низ строчки

export QT_STYLE_OVERRIDE=gtk2
export QT_QPA_PLATFORMTHEME=gtk2
, но это тоже не сработало. Пакет qt5-gtk-platformtheme установлен, а пакет libqt5libqgtk2 я вообще не смог найти, его походу удалили.

Ответ на: комментарий от Grruzchik

По личному опыту или из теоретических соображений советуешь? Я просто уже слышал об этом способе, планируют проверить.

Vsevolod-linuxoid ★★★★★ ()

Убедительная просьба к тем двум подписавшимся на эту тему: расскажите как вам _не_ удалось решить эту проблему. Это поможет мне не делать заведомо неверных действий.

Vsevolod-linuxoid ★★★★★ ()

Я сумел-таки решить эту проблему! Пришлось всё задавать глобально, правда.

Вот решение: в файл /etc/environment добавляем строчки

QT_QPA_PLATFORMTHEME=gtk2
QT_STYLE_OVERRIDE=gtk2
, и все работает как надо. Ничего больше не нужно, писать «export» тоже, нужно именно так, как процитировал.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от votafak

Ну не знаю. У меня ещё kdegames стоят, возможно в их зависимостях есть нужные библиотеки.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от votafak

Опана! А с ним и у меня не работает, хотя другие приложения на Qt5 подхватывают верно. Просто текущая тема похожа на бриз из кед, вот и не заметил.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

вот именно там не было строчки «gtk2» - пакет smplayer-themes устанавливал

votafak ★★★★★ ()

спасибо, ты спас мои глаза
я уже было отчаялся и плюнул. чсх на jessie стоял софт из портов на культе5, и темы подхватывались, после обновления сломалось

Deleted ()
Ответ на: комментарий от Vsevolod-linuxoid

UPD2: строчка

QT_STYLE_OVERRIDE=gtk2
уже не обязательна, и даже иногда может привести к проблемам, например рецепт с ней не работает с SMPlayer, хотя для других приложений на Qt5 он действует. Но можно зайти в его Настройки\Внешний вид\Стиль — gtk2.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от anonymous

А разработчики xubuntu замутили /etc/X11/Xsession.d/56xubuntu-session с таким содержимым:

# Set default environment vars in Xubuntu
if [ "$DESKTOP_SESSION" = xubuntu ]; then
    # Disable GTK 3.16 overlay scrollbars
    export GTK_OVERLAY_SCROLLING=0
    # QT5 apps to use GTK style
    export QT_QPA_PLATFORMTHEME=gtk2
    # Workaround clutter issue (LP: #1462445)
    export CLUTTER_BACKEND=x11
fi

которое перезапиcывает те же переменные в /etc/environment

dadd ★★★ ()

мне помогла последняя строчка в файле /etc/environment:

##QT_QPA_PLATFORMTHEME=gtk2
##QT_STYLE_OVERRIDE=gtk2
QT_QPA_PLATFORMTHEME="qt5ct"

без нее qt5ct выдавал ошибку qt5ct qt_qpa_platformtheme.

Sund ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.