LINUX.ORG.RU

Debian Sid заявляет, что он Stretch

 ,


0

2
user@debian:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 9.0 (stretch)
Release:	9.0
Codename:	stretch
user@debian:~$ cat /etc/apt/sources.list
deb http://ftp.ru.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ sid main contrib non-free

Так и должно быть?

И что не так?

anonymous ()
Ответ на: комментарий от Vsevolod-linuxoid

А ты хотел чтоб уже Buster? Рано еще, подожди нового тестинга.

mandala ★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Посмотрю ночью скрипт этот — откуда и как оно берет версию системы, но подозреваю что или сам автор скрина поправил, или раньше в дебиане было просто по другому.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)

Сноси это говно, дебиан с системд это уже шлак.

anonymous ()
Ответ на: комментарий от Vsevolod-linuxoid

Это не неверная версия, это мейнтейнерам плевать и они указывают версию именно так. Можешь баг завести, а мне лично пофиг.

откуда и как оно берет версию системы

Тупо дергает lsb_release -sirc. Что ему возвращает это команда, от того и пляшем.

mandala ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.