LINUX.ORG.RU

VirtualBox не стартует гостей

 ,


0

1

после запуска готевухи вылазит

RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/sbin/vboxconfig'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.

вывод dmesg

[ 356.298632] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0 [ 356.298640] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID) [ 356.298647] pcieport 0000:00:1c.0: device [8086:a110] error status/mask=00000001/00002000 [ 356.298651] pcieport 0000:00:1c.0: [ 0] Receiver Error (First)

The VirtualBox kernel modules do not match this version of VirtualBox

Нужны как минимум дистрибутив\версия и вывод пакетного менеджера относительно установленных версий самого VirtualBox'a и его модулей.

Nirvandil ()
Ответ на: комментарий от GaIEoAUatIC

А если со старым ядром загрузиться - работает? В Gentoo после обновления ядра модули VirtualBox'a нужно пересобирать, например, как это обыграно у бинарных дистрибутивов - не знаю, кто-то другой подскажет. Возможно, достаточно будет просто обновиться полностью, а не только ядро.

Nirvandil ()
Ответ на: комментарий от GaIEoAUatIC

А вот так делать не надо. Неужели в репозиториях Mint'a нет VirtualBox'a?

Nirvandil ()
Ответ на: комментарий от GaIEoAUatIC

Модули ядра надо пересобирать. При установке из репозитория при обновлении это делает пакетный менеджер. Если ты ставил сам из скачанного пакета с сайта оракла, то тебе и пересобирать самому.

mandala ★★★★ ()

The VirtualBox kernel modules do not match this version of VirtualBox.

Буквально вчера на debian ставил из репозиторев virtualbox была такая же фигня. Потом попробовал оракловские, ничего не изменилось. И лишь после того, как установил virtualbox-5.0 вместо virtualbox, всё заработало.

Kilte ★★★★★ ()
Ответ на: комментарий от GaIEoAUatIC

Как сделать дунгрейд? Та же шляпа с виртуалкой. После обновления пакетов, вылезла ошибка 1912.

Averyanov ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.