LINUX.ORG.RU

Долго стартует Arch с dwm и slim

 ,


0

1

Крайне долго стартует (минут 5-6), после граба - пока грузится slim (который настроен на автологин), появляется обычный вход пользователя как без менеджера входа. Но потом это все как то просирается и появляется dwm.

[ki@localhost ~]$ systemd-analyze
Startup finished in 2.496s (kernel) + 926ms (userspace) = 3.423s
[ki@localhost ~]$ systemd-analyze blame
           404ms dev-sdb3.device
           114ms systemd-fsck@dev-sdb1.service
            65ms systemd-tmpfiles-clean.service
            62ms systemd-journald.service
            53ms systemd-journal-flush.service
            39ms systemd-udev-trigger.service
            31ms dhcpcd.service
            24ms user@1000.service
            23ms systemd-logind.service
            22ms systemd-tmpfiles-setup-dev.service
            19ms systemd-udevd.service
            17ms sys-kernel-debug.mount
            17ms dev-mqueue.mount
            12ms systemd-sysctl.service
            10ms systemd-random-seed.service
             9ms dev-sdb2.swap
             7ms sys-kernel-config.mount
             5ms kmod-static-nodes.service
             4ms systemd-tmpfiles-setup.service
             4ms systemd-remount-fs.service
             3ms dev-hugepages.mount
             3ms systemd-update-utmp.service
             2ms boot.mount
             1ms systemd-user-sessions.service
             1ms tmp.mount
Выхлоп иксов: http://pastebin.com/tA4MS51v Что может быть?

А как у тебя слим вообще работает? Оо он же депрекэйтед, все дела. Когда пытался завести - отказывался стартовать.

JAkutenshi ★★ ()

Попробуй lxdm.

anonymous ()
Ответ на: комментарий от bytecode

Удалил slim, оставил xinitrc. Все также как и раньше. Может проблема из-за того что монитор подключен по hdmi к видеокарте Radeon'овской. Раньше подключал через Displayport, вообще не хотел запускаться. Опять так же - после загрузки ядра, минуты 5 и потом только появляется ввод логина. Может такое из-за видюхи?

mrjoun ()

Крайне долго стартует (минут 5-6) ... dwm.

А что другое стартует быстро? Сдаётся мне, дело не в dwm.

ashot ★★★ ()
Ответ на: комментарий от ashot

Вот и я уверен что дело не в dwm, когда ядро грузиться просто черный экран. Потом, через минут 5-6 видюха, я так понял понимает что через hdmi подключен и появляется стандартное вход пользователя, без dm.

mrjoun ()

[ 184.836] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=97714550-cfca-4feb-97ea-931ee9f23cc2 rw quiet

Ну так сотри quiet и смотри.
Вангую: какая нибудь некорректная запись в fstab.

arson ★★★★★ ()
Последнее исправление: arson (всего исправлений: 1)
Ответ на: комментарий от arson

Все, работает. journalctrl показал, что ему не хватает wayland'ских заголовочных файлов, поставил пакет, все отлично грузиться. Благодарю

mrjoun ()
Ответ на: комментарий от mrjoun

янв 06 12:41:26 localhost kernel: sd 1:0:0:0: [sdb] tag#10 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
янв 06 12:41:26 localhost kernel: sd 1:0:0:0: [sdb] tag#10 Sense Key : 0x3 [current]
янв 06 12:41:26 localhost kernel: sd 1:0:0:0: [sdb] tag#10 ASC=0x11 ASCQ=0x4
янв 06 12:41:26 localhost kernel: sd 1:0:0:0: [sdb] tag#10 CDB: opcode=0x28 28 00 00 00 03 88 00 00 08 00
янв 06 12:41:26 localhost kernel: blk_update_request: I/O error, dev sdb, sector 904
янв 06 12:41:26 localhost kernel: Buffer I/O error on dev sdb, logical block 113, async page read

Что-то с диском похоже.

arson ★★★★★ ()

Не слушай дядю выше (сейчас проблема в другом, но на диск тоже обрати внимание). Жёсткое проседание в этом месте:

янв 06 12:42:26 localhost systemd-udevd[191]: seq 1525 '/devices/pci0000:00/0000:00:01.0/0000:01:00.0' is taking a long time
янв 06 12:42:27 localhost systemd-udevd[191]: seq 2118 '/devices/virtual/vtconsole/vtcon1' is taking a long time
янв 06 12:43:26 localhost kernel: Failed to send Message.
янв 06 12:43:26 localhost kernel: Failed to send Previous Message.
А сразу после трёх минут попыток:
янв 06 12:43:36 localhost kernel: Failed to send Previous Message.
янв 06 12:43:36 localhost kernel: Failed to send Message.
янв 06 12:43:36 localhost kernel: [drm] Initialized amdgpu 3.3.0 20150101 for 0000:01:00.0 on minor 0
янв 06 12:43:55 localhost login[300]: pam_unix(login:session): session opened for user ki by LOGIN(uid=0)
И потом опять туева хуча ошибок. Копаешь в правильную сторону, дело в амуде.

mr_Heisenberg ()

Внимательно читай арчевики по теме AMDGPU. Краткая выдержка: убедись, что установлен последний xf86-video-amdgpu и linux-firmware, а также нет параметров ядра nomodeset или vga=. Ещё попробуй ранний старт: собери новый initcpio с amdgpu в списке модулей.

mr_Heisenberg ()
Ответ на: комментарий от mr_Heisenberg

Все проверил, все и стояло, но подключил снова через DisplayPort и ура, заработало. В топку эти видеокарты радеоновские

mrjoun ()
Ответ на: комментарий от ashot

Везет... Причем на ноуте стоит относительно старая радеоновская - без проблемм работает. На десктопе по новее но пока я ее не одолел, брыкается

mrjoun ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.