LINUX.ORG.RU

Apple Cinema Display, 2 DVI и Gentoo

 , , ,


0

2

Всем привет. В общем, ситуация такая: достался на работе мне Apple Cinema Display 27". Всем дисплей хорош, кроме одного - не хочет он под гентой работать. Подключен он через кабель конвертер mini Displayport -> DisplayPort к Nvidia GTX 650 Ti Boost.

Помимо него имеется еще 2 моника, подключенные по DVI. Вот эти 2 моника работают, а Apple Cinema Display не работает. Выглядит это следующим образом - при загрузке видеокарта отдает приоритет DVI-0 и моник с ним становится основным. В это время два остальных не работают. Если я гружусь в винду, то Boot Screen у нее идет тоже на DVI-0, а затем основным становится Apple, как указано в настройках драйвера, ну, собственно, все и работает как ожидалось. В линуксе ситуация иная - там Apple вообще не виден, xrandr -q говорит, что DP-0 отключен и нету там ничего. Если же я отключаю DVI-0, и оставляю DVI-1, то на момент загрузки основным становится Apple, до начала запуска иксов все работает, но как только иксы запустились, Apple пропадает и остается только моник, подключенный по DVI. Что я делаю не так (ну кроме того, что использую Apple Cinema Display)?

Что в /var/log/Xorg.0.log и в dmesg?

XMs ★★★★★ ()
Ответ на: комментарий от XMs

http://pastebin.com/t3CsAdm6 - Xorg.0.log

http://pastebin.com/4mLMBivf - dmesg

Забыл сказать, что в качестве драйвера я использую проприетарный версии 370.28. Плюс к этому я затестил LiveCD Ubuntu 15.04 и LiveDVD Gentoo какой-то из более-менее актуальных - везде Apple работает как надо, значит, проблемы где-то в районе ядра или драйвера.

Slaviro ()
Ответ на: комментарий от Slaviro

Ядро твой моник видит, уже хорошо:

[    3.006432] usb 6-1.5: New USB device found, idVendor=05ac, idProduct=8508
[    3.006944] usb 6-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.007420] usb 6-1.5: Product: Display iSight
[    3.007877] usb 6-1.5: Manufacturer: Apple Inc.
[    3.008310] usb 6-1.5: SerialNumber: 8TD3S00F8BS03L00
[    3.009660] uvcvideo: Found UVC 1.00 device Display iSight (05ac:8508)
[    3.014917] input: Display iSight as /devices/pci0000:00/0000:00:14.0/usb6/6-1/6-1.5/6-1.5:1.0/input/input21

Однако X-сервер почему-то нет:

[    11.999] (**) NVIDIA(0): ConnectedMonitor string: «DFP-0, DFP-3»
[    12.445] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    12.445] (--) NVIDIA(0):     CRT-0
[    12.445] (--) NVIDIA(0):     DFP-0 (boot)
[    12.445] (--) NVIDIA(0):     DFP-1
[    12.445] (--) NVIDIA(0):     DFP-2
[    12.445] (--) NVIDIA(0):     DFP-3
[    12.445] (--) NVIDIA(0):     DFP-4
[    12.445] (**) NVIDIA(0): Using ConnectedMonitor string «DFP-0, DFP-3».
[    12.445] (--) NVIDIA(0): CRT-0: disconnected
[    12.445] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[    12.445] (--) NVIDIA(0):
[    12.450] (--) NVIDIA(0): DELL U2412M (DFP-0): connected
[    12.450] (--) NVIDIA(0): DELL U2412M (DFP-0): Internal TMDS
[    12.450] (--) NVIDIA(0): DELL U2412M (DFP-0): 330.0 MHz maximum pixel clock
[    12.450] (--) NVIDIA(0):
[    12.450] (--) NVIDIA(0): DFP-1: disconnected
[    12.451] (--) NVIDIA(0): DFP-1: Internal TMDS
[    12.451] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[    12.451] (--) NVIDIA(0):
[    12.451] (--) NVIDIA(0): DFP-2: disconnected
[    12.451] (--) NVIDIA(0): DFP-2: Internal TMDS
[    12.451] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[    12.451] (--) NVIDIA(0):
[    12.456] (--) NVIDIA(0): DELL U2412M (DFP-3): connected
[    12.456] (--) NVIDIA(0): DELL U2412M (DFP-3): Internal TMDS
[    12.456] (--) NVIDIA(0): DELL U2412M (DFP-3): 330.0 MHz maximum pixel clock
[    12.456] (--) NVIDIA(0):
[    12.456] (--) NVIDIA(0): DFP-4: disconnected
[    12.456] (--) NVIDIA(0): DFP-4: Internal DisplayPort
[    12.456] (--) NVIDIA(0): DFP-4: 960.0 MHz maximum pixel clock

Судя по всему, ты используешь какой-то конфиг для иксов, выложи его тоже. Ещё у тебя какие-то ошибки, связанные с ACPI, видимо, демон не запущен — я не знаю, насколько это важно для невидии, может, дело в них, а может и нет

XMs ★★★★★ ()
Ответ на: комментарий от XMs

Не факт, что это монитор. iSight — это камера.

Deleted ()
Ответ на: комментарий от XMs

Ну, короче, я победил эту фигню. Оказалось, что у меня был файл /etc/xorg.conf, который все портил. Попробовал Nouveau заодно - зависало, вернулся обратно. Теперь есть другой более простой вопрос - как мне сконфигурить все, чтобы был центральный Apple, слева от него вертикальный Dell а справа горизонтальный Dell?

Slaviro ()
Ответ на: комментарий от Slaviro

Я в кедах всю настройку мониторов через kscreen делаю, главный выход там тоже можно задать

XMs ★★★★★ ()
Ответ на: комментарий от XMs

Не вариант через кеды - оно применяется только для кед, соответственно, у меня экран логина окажется на самом приоритетном экране и это окажется самый правый. Через nvidia-settings оно тоже не очень делается, потому что оно задает позицию для левого экрана 0+0, а все остальные уже пляшут от него, соответственно, на вертикальный монитор уходит, например, диалог разлогинивания, а мне надо, чтобы основной во всех смыслах экран был центральный, а уже по бокам от него все остальное.

Slaviro ()
Ответ на: комментарий от Slaviro

xrandr --help во многом поможет.
Через него можно и primary задать и расположение дисплеев относительно друг друга

mersinvald ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.