LINUX.ORG.RU

Репозиторий для Firefox на Debian

 ,


1

1

Посоветуйте пожауйлста репозиторий для Firefox на Debian.

Для Firefox на Debian у меня стоит это в /etc/apt/sources.list:

deb http://packages.linuxmint.com debian import deb-src http://packages.linuxmint.com debian import

но этот репозиторий теперь кажется больше не обновляет Firefox на моем компьютере и на нем всегда с большим опозданием появлялись новые версии, и боюсь что с него на мой Debian могли установиться несовместимые с Debian пакеты при апгрейдах. Уже много конфликтов и ошибок в системе, но неважно - самое главное они пока не заметны и не мешают.

Только пожалуйста не советуйте способы установить не из репозитория,я знаю про них. Я просто хочу чтобы все просто и как положено из репозитория устанавливалось.

Ответ на: комментарий от Darth_Revan

спасибо.. буду смотреть и разбираться.. мне конечно лучше бы если вы просто сказали что добавить в /etc/apt/sources.list:

SamFisu ()
 ~ % apt-cache policy firefox-esr
firefox-esr:
  Installed: 45.0.1esr-1
  Candidate: 45.0.1esr-1
  Version table:
 *** 45.0.1esr-1 990
        990 file:/srv/debian/stretch stretch/main amd64 Packages
        990 http://ftp.debian.org/debian stretch/main amd64 Packages
        500 http://ftp.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
anonymous ()
Ответ на: комментарий от Darth_Revan

да, точно, сейчас добавил deb http://http.debian.net/debian unstable main теперь обновилась новая версия Firefox, все в порядке. извиняюсь за беспокойство я просто раньше был на http://mozilla.debian.net/ и был уверен что я не видел чтобы там были инструкции что какой репозиторий добавить sources.list а теперь все увидел.

SamFisu ()
Ответ на: комментарий от anonymous

да, спасибо, приму к рассмотрению эту информацию тоже.. я имею ввиду я боюсь что добавление «deb http://http.debian.net/debian unstable main» это выглядит так как-будто репозиторий всего дистрибутива, начнет начнет обновлять весь мой дистрибутив с тестинга на unstable, надеюсь этого не будет..

SamFisu ()
Ответ на: комментарий от SamFisu

да, конечно, это не обновляет весь дистрибутив.. я могу видеть aptitude full-upgrade говорит только «Need to get 362 MB of archives.» это конечно не обновление всего дистрибутива

SamFisu ()
Ответ на: комментарий от SamFisu

как я понял так apt-get install -t unstable firefox нужно для того чтобы из unstable ничего лишнего кроме firefox не устанавливалось и это конечно не удобно, потому я предпочитаю просто aptitude full-upgrade хотя я сейчас упрямо все равно выполнил эту команду и да конечно установилось много нового из «deb http://http.debian.net/debian unstable main», но несмотря на это моя тестинг версия все равно работает. В общем буду надеяться обновления оттуда не будут ничего ломать и портить в тестинге. Я просто люблю каждый месяц или два выполнять одно простое aptitude full-upgrade и быть более менее в ногу со временем и не заморачиваться с остальным, хотя конечно наверняка правильнее использовать специальную команду которая не обновляла бы ничего лишнего кроме Firefox из «deb http://http.debian.net/debian unstable main».. может так правильнее было бы а может все равно.. неважно

SamFisu ()
Ответ на: комментарий от ptah_alexs

Вы имеете ввиду пакет firefox-esr? Сейчас установил его себе.. Значит теперь «deb http://http.debian.net/debian unstable main» можно удалить видимо.. Я не знал про существование этого пакета, видимо его раньше не было, видимо он не так давно появился.. у меня обновлялся браузер просто по пакету с названием просто firefox.. iceweasel в репозитории конечно тоже по-прежнему есть.. но это хорошо что появился теперь firefox-esr и не нужно дополнительного репозитория.. спасибо.

SamFisu ()
Ответ на: комментарий от Maks7lu

«deb http://mozilla.debian.net/ jessie-backports firefox-release» конечно будет лучше чем «deb http://http.debian.net/debian unstable main» т.к. не будет устанавливать/обновлять лишнее кроме пакета firefox, но видимо уже лучше придерживаться минимализма и не добавлять лишний репозиторий когда выяснилось что в основном репозитории есть firefox-esr..

SamFisu ()
Ответ на: комментарий от SamFisu

Помню,стоял у меня Iceweasel 25,и памяти меньше жрал и привычнее был.Лучше вообще не обновляться,если всё работает.Поверь..просто поверь....

Maks7lu ()
Ответ на: комментарий от SamFisu

не будет устанавливать/обновлять лишнее кроме пакета firefox

Что мешает сделать файл /etc/apt/preferences.d/unstable и написать туда:

Package: *
Pin: release a=unstable
Pin-Priority: 99

чтоб автоматически не обновлялось из unstable?

в основном репозитории есть firefox-esr

А в unstable есть просто firefox последней версии, не ESR:

https://packages.debian.org/sid/firefox

anonymous ()
Ответ на: комментарий от anonymous

да, наверно так тоже можно.. мне не нравится это ESR, хочу обычный Firefox. Спасибо. Вообще интересно что это за репозиторий такой «deb http://http.debian.net/debian unstable main» потому что обычный репозиторий для unstable был бы на сайте debian.org и выглядел бы также как тестинг «deb http://ftp.us.debian.org/debian/ unstable main contrib non-free» только одну часть изменить на unstable в строчке. Говорят unstable вовсе не такой уж unstable и ничего страшного не случится если до него обновиться.

SamFisu ()
Ответ на: комментарий от Maks7lu

да конечно вы правы. я верю. я просто слишком любопытный в том что касается что нового а новых версиях ПО, в том касается прогресса в Linux. а так от этих обновлений только ошибки и конфликты прибавляются и только система все некорректнее работает. и время которое тратится на обновления и адаптирование к новому интерфейсу и т.д. можно потратить с больше пользой. чего только стоит сколько я времени здесь трачу столько занудно обсуждая репозиторий для нового Firefox другая моя сторона хочет вовсе просто все нужное один раз остановить и ничего не обновлять никогда ничего.

SamFisu ()

Замени debian на betsy:

deb http://packages.linuxmint.com/ betsy import

Сам недавно разбирался, почему не обновляется. Сейчас все ок.

zevilz ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.