LINUX.ORG.RU

[РЕШЕНО +/-] Manjaro и обновления - неверный или поврежденный пакет (PGP-подпись)

 , , , ,


0

1

Manjaro 15.12, только-только поставил в VBox, решил попробовать обновиться и не получается. Но этого мало, выбирал через GUI-обновлялку разные зеркала, но ошибка не прекращается

http://tau.rghost.ru/7yL2HnDf7/image.png

и на этом не остановился, запустился в LiveCD/DVD Manjaro там все так же при обновлении и даже при простой попытке поставить пакет на несколько Кб

ошибка: не удалось завершить запрос (неверный или поврежденный пакет(PGP-подпись))

Пакеты (1) geoip-database-20151201-1

Будет загружено:  0,74 MiB
Будет установлено:  2,25 MiB
Изменение размера:  0,00 MiB

:: Приступить к установке? [Y/n] 
:: Получение пакетов ...
 geoip-database-20151201-1-any                                              762,7 KiB   144K/s 00:05 [############################
(1/1) проверка ключей                                                                                [############################
(1/1) проверяется целостность пакета                                                                 [############################
ошибка: geoip-database: signature from "Evangelos Foutras <evangelos@foutrelis.com>" is unknown trust
:: Файл /var/cache/pacman/pkg/geoip-database-20151201-1-any.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).

Как это лечить и это как в обще частенько в арч или арч-подобном бывает? Гуглил конечно, но что-то свежего и рабочего решения не нашел, у людей встречается, но либо со временем, либо чисто случайно оно решается

★★★★★

Обновить ключи?

man pacman-key

BRE ★★ ()
Ответ на: комментарий от BRE

да я пробовал различные действия, ну вот Вы дали мне man, спасибо, а я еще про ArchWiKi знаю..., так подумать, а вот если новичок ставит, ему обновления и стим нужны, в manjaro это не продумано что ли?

На счет PGP и пробовал различные действия, так и не разрулил, при использовании таких:
http://linuxsay.com/t/unable-to-install-any-packages-in-manjaro-linux-pgp-sig...
http://www.2daygeek.com/manjaro-update-upgrade-fails/
https://bbs.archlinux.org/viewtopic.php?id=202442

NK ★★★★★ ()
echo 'keyserver-options auto-key-retrieve' >> ~/.gnupg/gpg.conf
echo 'keyserver hkp://keys.gnupg.net' >> ~/.gnupg/gpg.conf
unikum ★★★★★ ()
Ответ на: комментарий от NK

Нужно просто подождать. Evangelos закончит праздновать и разрешит проблему.

marcony ()
Ответ на: комментарий от marcony

Спасибо, ну я так и думал гугля и читая ответы на английском.
Что ж подождем конечно, посмотрим что будет, но вот у меня тогда наверно к пользователям Arch Linux вопрос:
в Арче с PGP подписями такое часто бывает при обновлениях?

NK ★★★★★ ()
Ответ на: комментарий от oblepiha_pie

да вот, вроде как делал что-то подобное, когда гуглил

сейчас на чистой системе сделал http://pastebin.com/ugb3k3TZ
в общем все равно не получается

NK ★★★★★ ()

pacman-key --refresh-keys - тоже не помогает
http://archlinux.org.ru/forum/topic/14341/?page=2

[root@manjaro ~]#  pacman-key --refresh-keys
gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: Сбой вызова соединения IPC
gpg: сбой при обновлении с сервера ключей: Нет dirmngr
==> ОШИБКА: Указанный локальный ключ не удалось обновить с сервера ключей.
[root@manjaro ~]# ^C
[root@manjaro ~]# logout
[nk@manjaro Рабочий стол]$ sudo  pacman-key --refresh-keys
gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: Сбой вызова соединения IPC
gpg: сбой при обновлении с сервера ключей: Нет dirmngr
==> ОШИБКА: Указанный локальный ключ не удалось обновить с сервера ключей.
[nk@manjaro Рабочий стол]$ 
NK ★★★★★ ()

Кажется нашел решение http://habrahabr.ru/post/145230/ # pacman-key --populate archlinux
Но тут вопрос встает, а насколько оно правильное учитывая что есть же еще pacman-key --populate manjaro , как думаете в чем же трабл?

Вот сейчас гружусь в manjaro-xfce-15.12-i686 и делаю:

[root@manjaro ~]# pacman -S geoip-database
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) geoip-database-20151201-1

Будет загружено:  0,74 MiB
Будет установлено:  2,25 MiB

:: Приступить к установке? [Y/n] 
:: Получение пакетов ...
 geoip-database-20151201-1-any                                        762,7 KiB   236K/s 00:03 [#######################################################] 100%
(1/1) проверка ключей                                                                          [#######################################################] 100%
(1/1) проверяется целостность пакета                                                           [#######################################################] 100%
ошибка: geoip-database: signature from "Evangelos Foutras <evangelos@foutrelis.com>" is unknown trust
:: Файл /var/cache/pacman/pkg/geoip-database-20151201-1-any.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] 
ошибка: не удалось завершить запрос (неверный или поврежденный пакет(PGP-подпись))
Обнаружены ошибки, пакеты не были обновлены.
[root@manjaro ~]# pacman-key --populate archlinux
==> Добавление ключей из файла archlinux.gpg...
==> Локальное подписывание доверенных ключей в связке...
  -> Локальное подписывание ключа 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
  -> Локальное подписывание ключа 684148BB25B49E986A4944C55184252D824B18E8...
  -> Локальное подписывание ключа 44D4A033AC140143927397D47EFD567D4C7EA887...
  -> Локальное подписывание ключа 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
  -> Локальное подписывание ключа AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> Импорт значений доверия владельцам...
gpg: inserting ownertrust of 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
==> Отсоединение отозванного ключа от связки.
  -> Блокировка ключа F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
  -> Блокировка ключа 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
  -> Блокировка ключа D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
  -> Блокировка ключа BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
  -> Блокировка ключа 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
  -> Блокировка ключа 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
  -> Блокировка ключа 63F395DE2D6398BBE458F281F2DBB4931985A992...
  -> Блокировка ключа 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
  -> Блокировка ключа 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
  -> Блокировка ключа 66BD74A036D522F51DD70A3C7F2A16726521E06D...
  -> Блокировка ключа 81D7F8241DB38BC759C80FCE3A726C6170E80477...
  -> Блокировка ключа E7210A59715F6940CF9A4E36A001876699AD6E84...
==> Обновление таблицы доверия...
gpg: требуется 3 с ограниченным доверием, 1 с полным, модель доверия PGP
gpg: глубина: 0  достоверных:   1  подписанных:   5  доверие: 0-, 0q, 0n, 0m, 0f, 1u
gpg: глубина: 1  достоверных:   5  подписанных:  66  доверие: 0-, 0q, 0n, 5m, 0f, 0u
gpg: глубина: 2  достоверных:  66  подписанных:   6  доверие: 66-, 0q, 0n, 0m, 0f, 0u
gpg: срок следующей проверки таблицы доверия 2016-01-22
[root@manjaro ~]# pacman -S geoip-database
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) geoip-database-20151201-1

Будет загружено:  0,74 MiB
Будет установлено:  2,25 MiB

:: Приступить к установке? [Y/n] 
:: Получение пакетов ...
 geoip-database-20151201-1-any                                        762,7 KiB   230K/s 00:03 [#######################################################] 100%
(1/1) проверка ключей                                                                          [#######################################################] 100%
(1/1) проверяется целостность пакета                                                           [#######################################################] 100%
(1/1) загрузка файлов пакетов                                                                  [#######################################################] 100%
(1/1) проверка конфликтов файлов                                                               [#######################################################] 100%
(1/1) установка geoip-database                                                                 [#######################################################] 100%
[root@manjaro ~]# 

Пробовал на «чистом листе» и когда вместо archlinux писал: pacman-key --populate manjaro - не срабатывало, как pacman-key --populate archlinux ввел - все завелось

NK ★★★★★ ()

еще вот что заметил

[root@manjaro ~]# pacman-key --init
gpg: ключ A4B9A16F создан на 8875 секунд в будущем (петля во времени или проблемы с часами)
[root@manjaro ~]# pacman-key --init
gpg: ключ A4B9A16F создан на 8852 секунд в будущем (петля во времени или проблемы с часами)
[root@manjaro ~]# pacman-key --init
gpg: ключ A4B9A16F создан на 8850 секунд в будущем (петля во времени или проблемы с часами)
[root@manjaro ~]# pacman-key --init
gpg: ключ A4B9A16F создан на 8848 секунд в будущем (петля во времени или проблемы с часами)
[root@manjaro ~]# pacman-key --init
gpg: ключ A4B9A16F создан на 8847 секунд в будущем (петля во времени или проблемы с часами)
[root@manjaro ~]# pacman-key --init
gpg: ключ A4B9A16F создан на 8840 секунд в будущем (петля во времени или проблемы с часами)

NK ★★★★★ ()

Глянул, но так вот ошибка и не ушла, вот вроде выход нашел, отключить проверку эту
https://forum.manjaro.org/index.php?topic=20152.msg197135#msg197135

только вот вопрос к тем кто уже долгое время пользуется pacman:
это проверка на, так сказать действительно этого пакета, но вот в этой проверки случайно еще не заложена проверка, когда уже качну пакет и по md5sum его проверить не битым ли он он скачался?

NK ★★★★★ ()

набери в поисковике Manjaro Linux Блог Сэмма.там строки есть такие 1 sudo pacman-key --populate archlinux 2 sudo pacman-key --populate manjaro 3 sudo pacman -S archlinux-keyring manjaro-keyring Из под root a в теминале. И будет тебе счастье

anonymous ()

И делай это первоначально. Как только систему установил,сразу в терминал,и вводи данные команды. а потом уже систему обновляй. Linux fleks 4.4.9-1-MANJARO #1 SMP PREEMPT Thu May 5 19:18:08 UTC 2016 i686 GNU/Linux

anonymous ()
Ответ на: комментарий от anonymous

ну ладно, вот только поставил в виртуалке 16.06.1

Из под root a в теминале

[nk@manjaro ~]$ sudo su -

1 sudo pacman-key --populate archlinux

[root@manjaro ~]# pacman-key --populate archlinux
==> Добавление ключей из файла 'archlinux.gpg'...
==> Локальное подписывание доверенных ключей в связке...
  -> Локальное подписывание ключа '0E8B644079F599DFC1DDC3973348882F6AC6A4C2'...
==> ОШИБКА: Не удалось локально подписать ключ '0E8B644079F599DFC1DDC3973348882F6AC6A4C2'.
  -> Локальное подписывание ключа '684148BB25B49E986A4944C55184252D824B18E8'...
==> ОШИБКА: Не удалось локально подписать ключ '684148BB25B49E986A4944C55184252D824B18E8'.
  -> Локальное подписывание ключа '91FFE0700E80619CEB73235CA88E23E377514E00'...
==> ОШИБКА: Не удалось локально подписать ключ '91FFE0700E80619CEB73235CA88E23E377514E00'.
  -> Локальное подписывание ключа '44D4A033AC140143927397D47EFD567D4C7EA887'...
==> ОШИБКА: Не удалось локально подписать ключ '44D4A033AC140143927397D47EFD567D4C7EA887'.
  -> Локальное подписывание ключа '27FFC4769E19F096D41D9265A04F9397CDFD6BB0'...
==> ОШИБКА: Не удалось локально подписать ключ '27FFC4769E19F096D41D9265A04F9397CDFD6BB0'.
  -> Локальное подписывание ключа 'AB19265E5D7D20687D303246BA1DFB64FFF979E7'...
==> ОШИБКА: Не удалось локально подписать ключ 'AB19265E5D7D20687D303246BA1DFB64FFF979E7'.

2 sudo pacman-key --populate manjaro

[root@manjaro ~]# pacman-key --populate manjaro
==> Добавление ключей из файла 'manjaro.gpg'...
==> Локальное подписывание доверенных ключей в связке...
  -> Локальное подписывание ключа '7C89F4D439B2BFACF425107B62443D89B35859F8'...
==> ОШИБКА: Не удалось локально подписать ключ '7C89F4D439B2BFACF425107B62443D89B35859F8'.
  -> Локальное подписывание ключа '22C903DE964E6FE321656E318DB9F8C18DF53602'...
==> ОШИБКА: Не удалось локально подписать ключ '22C903DE964E6FE321656E318DB9F8C18DF53602'.
  -> Локальное подписывание ключа '16DC688DF3EECC72323954237EC47C82A42D53A2'...
==> ОШИБКА: Не удалось локально подписать ключ '16DC688DF3EECC72323954237EC47C82A42D53A2'.
  -> Локальное подписывание ключа '5A97ED6B72418199F0C22B23137C934B5DCB998E'...
==> ОШИБКА: Не удалось локально подписать ключ '5A97ED6B72418199F0C22B23137C934B5DCB998E'.
  -> Локальное подписывание ключа 'B4663188A692DB1E45A98EE95BD96CC4247B52CC'...
==> ОШИБКА: Не удалось локально подписать ключ 'B4663188A692DB1E45A98EE95BD96CC4247B52CC'.
  -> Локальное подписывание ключа '2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA'...
==> ОШИБКА: Не удалось локально подписать ключ '2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA'.
  -> Локальное подписывание ключа '35B4FF23EA9477582C2A0AF12B80869C5C0102A6'...
==> ОШИБКА: Не удалось локально подписать ключ '35B4FF23EA9477582C2A0AF12B80869C5C0102A6'.
  -> Локальное подписывание ключа '1E7908935AAB9A00D6B47503363DFFFD59152F77'...
==> ОШИБКА: Не удалось локально подписать ключ '1E7908935AAB9A00D6B47503363DFFFD59152F77'.
  -> Локальное подписывание ключа '77DC01C9971AC3C39A0626F72C089F09AC97B894'...
==> ОШИБКА: Не удалось локально подписать ключ '77DC01C9971AC3C39A0626F72C089F09AC97B894'.
  -> Локальное подписывание ключа '74C2F2CC05A0AB7D859839938934292D604F8BA2'...
==> ОШИБКА: Не удалось локально подписать ключ '74C2F2CC05A0AB7D859839938934292D604F8BA2'.
  -> Локальное подписывание ключа '39F0EC1AE50B37E5F3196F09DAD3B211663CA268'...
==> ОШИБКА: Не удалось локально подписать ключ '39F0EC1AE50B37E5F3196F09DAD3B211663CA268'.
  -> Локальное подписывание ключа 'E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E'...
==> ОШИБКА: Не удалось локально подписать ключ 'E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E'.

3 sudo pacman -S archlinux-keyring manjaro-keyring

[root@manjaro ~]# pacman -S archlinux-keyring manjaro-keyring
предупреждение: archlinux-keyring-20160402-1 не устарел -- переустанавливается
предупреждение: manjaro-keyring-20160527-1 не устарел -- переустанавливается
разрешение зависимостей...
проверка конфликтов...

Пакеты (2) archlinux-keyring-20160402-1  manjaro-keyring-20160527-1

Будет загружено:  0,62 MiB
Будет установлено:  0,86 MiB
Изменение размера:  0,00 MiB

:: Приступить к установке? [Y/n] y
:: Получение пакетов...
 archlinux-keyring-2...   576,7 KiB   239K/s 00:02 [####################] 100%
 manjaro-keyring-201...    59,0 KiB  68,4K/s 00:01 [####################] 100%
(2/2) проверка ключей                              [####################] 100%
(2/2) проверяется целостность пакета               [####################] 100%
ошибка: archlinux-keyring: signature from "Pierre Schmitz <pierre@archlinux.de>" is unknown trust
:: Файл /var/cache/pacman/pkg/archlinux-keyring-20160402-1-any.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: manjaro-keyring: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: Файл /var/cache/pacman/pkg/manjaro-keyring-20160527-1-any.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: не удалось завершить транзакцию (неверный или поврежденный пакет(PGP-подпись))
Обнаружены ошибки, пакеты не обновлены.
[root@manjaro ~]# 
NK ★★★★★ ()

# rm -R /etc/pacman.d/gnupg/ # rm -R /root/.gnupg/ # only if the directory exists # gpg --refresh-keys # pacman-key --init && pacman-key --populate # pacman-key --refresh-keys

anonymous ()
Ответ на: комментарий от NK

пока что способ с указанием SigLevel = Never в /etc/pacman.conf только спасает

NK ★★★★★ ()
Ответ на: комментарий от anonymous

Благодарю, а вот это действительно помогло

[root@manjaro ~]# history
    1  rm -R /etc/pacman.d/gnupg/
    2  rm -R /root/.gnupg/
    3  gpg --refresh-keys
    4  pacman-key --init && pacman-key --populate 
    5  pacman-key --refresh-keys

[root@manjaro ~]# pacman -S geoip-database
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) geoip-database-20160301-2

Будет загружено:  0,78 MiB
Будет установлено:  2,34 MiB

:: Приступить к установке? [Y/n] 
:: Получение пакетов...
 geoip-database-2016...   799,4 KiB   106K/s 00:08 [####################] 100%
(1/1) проверка ключей                              [####################] 100%
(1/1) проверяется целостность пакета               [####################] 100%
(1/1) загрузка файлов пакетов                      [####################] 100%
(1/1) проверка конфликтов файлов                   [####################] 100%
(1/1) проверяется доступное место                  [####################] 100%
:: Processing package changes...
(1/1) установка geoip-database                     [####################] 100%
[root@manjaro ~]#

вот только знаете смотрю я на это, печально что после установки вроде как desktop'ного дистра такое приходится проделывать и задумался, когда эти PGP-ключи обновятся, опять что получается подобное проделывать по-новой?

NK ★★★★★ ()
Ответ на: комментарий от NK

На чистом дистрибутиве Manjaro KDE Edition 16.08 Ellada (32-bit)

всё пункты выполнить или только:

pacman-key --init && pacman-key --populate
pacman-key --refresh-keys

Тему прочитал, но глаза разбежались, не хотелось бы экспериментировать не понимая всего)

hikikomori ★★ ()
Ответ на: комментарий от NK

В ванильном арче действительно в прошлом было несколько технических глюков с keyring, когда приходилось разруливать настройки gpg руками, но сейчас всё уже устаканилось.

Сейчас единственная возможная проблема ­возникает при длительной задержке в обновлениях. В этом случае новые пакеты становится невозможно поставить, т. к. они подписаны новыми ключами, о которых pacman ещё не знает. Тогда приходится вручную устанавливать обновление archlinux-keyring, отключая при этом проверку ключей, а уже потом всё остальное.

Но если обновляться своевременно, то обновление archlinux-keyring прилетает первым, пока старые ключи ещё действуют, а уже потом пакеты начинают подписываться новыми ключами. Как-то так.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от hikikomori

все, их 5
[РЕШЕНО +/-] Manjaro и обновления - неверный или поврежденный пакет (PGP-подпись) (комментарий)

если не поможет, пробуй этот способ
[РЕШЕНО +/-] Manjaro и обновления - неверный или поврежденный пакет (PGP-подпись) (комментарий)

// Странно ты как-то с Cinnamon на KDE переключился, в продолжение темы советую и Xfce попробовать, чисто простое DE, не будешь столько времени на настройку и изучение его тратить, времени на лин сам останется, ну и экономия ресурсов получше чем у KDE. А так KDE - хорошее DE, имеющее место быть

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 3)
Ответ на: комментарий от intelfx

Хм, что ж спасибо, остались видимо еще Арч-пользователи, которые могут внятно объяснить, а не уМВР-ЧяДнТ

NK ★★★★★ ()
Ответ на: комментарий от NK

Ну у меня же коробка из-под кед, надо на неё ноут с кедами ставить)
Спасибо, команды выполнил. Под su root иначе sudo ей мало.

Я новичок в этой системе, а мало того, что в системе, скачанной с офсайта уже аж 333 устаревших пакета, так ещё и конфликты зависимостей, и я понятия не имею как их разрешать. Почему вообще так?

Octopi — обновить систему — Запустить в терминале.
И валятся ошибки. Где жать Yes, а где No понятия не имею.

    :: Запускается полное обновление системы...
    :: Заменить akonadi-contact на extra/akonadi-contacts? [Y/n]
    :: Заменить grantlee-qt5 на extra/grantlee? [Y/n]
    :: Заменить libdbus на core/dbus? [Y/n]
    :: Заменить prison-frameworks на extra/prison? [Y/n]
    :: Заменить quazip-qt5 на extra/quazip? [Y/n]
    разрешение зависимостей...
    проверка конфликтов...
    :: qt5-declarative и qtchooser конфликтуют. Удалить qtchooser? [y/N]
    ошибка: обнаружен неразрешимый конфликт пакетов
    ошибка: не удалось подготовить транзакцию (конфликтующие зависимости)
    :: 'qt5-declarative' и 'qtchooser' конфликтуют
    Чтобы продолжить, нажмите любую клавишу...


НА фоне этого вики доставляет цитатами:

«Pacman способен сам найти зависимости, автоматически загрузить и установить все необходимые пакеты. Как правило, пользователю достаточно выполнить только одну команду для полного обновления всей системы.»


«дружественность к неопытным пользователям, сохраняя мощность Arch как основы, особенно пакетного менеджера Pacman и совместимостью с AUR»

https://ru.wikipedia.org/wiki/Manjaro_Linux

hikikomori ★★ ()
Ответ на: комментарий от NK

Всем спасибо, я осилили сам)
Вчера удалось успешно обновиться отвечая на все вопросы о конфликтах yes

sudo pacman -Syu

Решение отсюда link1, link2

Сразу хочу заметить, что неприятно напрягла необходимость разрешать проблемы зависимостей сразу после установки, ещё перед обновлением, объём которого между прочим составил аж 889,45 MiB (В системе 333 устаревших пакета), и качался в несколько раз дольше чем весь дистрибутив manjaro-kde-16.08-i686.iso. Неужели нельзя выкладывать на официальный сайт проекта свежие сборки?

Так что запасаемся толстым каналом и терпением.

У меня в процессе обновления подвис ПК с мусором в экранной области, пришлось перезагружаться, и повторять, но завершилось всё успешно.

После этого я можно сказать полностью подготовил систему к работе. Где бы годные статьи почитать? Я даже не знаю, как софт из консоли ставить, можно ли .deb пакетами?

hikikomori ★★ ()
Ответ на: комментарий от hikikomori

Неужели нельзя выкладывать на официальный сайт проекта свежие сборки?

Можно все, только кто тестировать будет, ты что ли?
Например ведь может быть людям нужна проверенная версия, скажем, для GParted что бы диски разметить или на ошибки проверить не качать же - непроверенное

И кстати вот разрабатываемые версии и в то же время свежие версии
https://manjaro.org/manjaro-preview-releases/

Где бы годные статьи почитать?

Лучше создай тему, точнее по темам, что тебе надо и спрашивай, наверняка кто-то зайдет и кстати про теги не забывай, наверняка кто-то откликнется.
Последнее когда я смотрел manjaro в основном инфа на англ.языке была, как вот и тот же форум которого ты ссылки привел, а так Arch'а WiKi - это реально мощь, - читай!

Я даже не знаю, как софт из консоли ставить, можно ли .deb пакетами?

deb-пакеты же, ну у тебя арч, одна из его мощностей все так сказать на сайте, есть репы с одним адресом с собранными пакетами, а есть реп с билдами сборки в пакет (aur), у manjaro даже графический инструмент есть и не надо AUR прикручивать самому.
Кстати, opera-dev именно, как раз и из deb и собирается, см. PKGBUILD https://aur.archlinux.org/packages/opera-developer

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 1)
Ответ на: комментарий от NK

Можно все, только кто тестировать будет, ты что ли?



Я вероятно чего не понимаю, но ни в одном опробованном дистро мне не приходилось сразу после установки скачивать обновлений на половину объёма дистрибутива. Это необычно, почему-то в других сборках более актуальные версии.


Насчёт .deb я не вполне понял. Мне бы примеры с работой из консоли. Arch'а WiKi буду читать, внёс в меморисы, спасибо)

А в общем, мне Majaro на KDE понравился несравнимо больше, чем Mint на Gnome. Не в обиду гному.

hikikomori ★★ ()
Ответ на: комментарий от hikikomori

Попробуй Manjaro Deepin 16,08 (стабильная ветка)- будешь приятно удивлен. Сравни его с оригиналом основанном на Debian Deepin 15.3 и переходи на него.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.