LINUX.ORG.RU

X-сервер запускается «через раз»

 ,


0

1

Приветствую, ребята! У меня специфичная проблема: X-сервер запускается через раз. Например, логинюсь через обычного пользователя в tty1, пытаюсь поднять x-сервер командой startx. Но по какой-то неизвестной мне причине он запускается только иногда.

Вот скрин, когда не запускается (сорри за ужасный скрин) http://s020.radikal.ru/i709/1511/cd/c6d139591db3.jpg Просто зависает так, помогает только хард-резет.

cat Xorg.0.log | grep EE и WW(причём при успешном запуске!): http://pastie.org/10576918

При неуспешном запуске ошибок нет, но варнинги те же.

xorg.conf : http://pastie.org/10576923

Видеокарты 2 (ноутбук) возле обеих в lspci: driver : fglrx Такая проблема что при запуске от root, что при запуске от обычного пользователя

Прошу, объясните, в чем может быть проблема?

Пишу сюда первый раз, если нужны еще какие-то логи - скажите. И насчёт оформления тоже если что поправьте

Запости Xorg.?.log при неуспешном запуске.
Не перепутай только какой лог постить, смотри по времени создания.
Когда запуск неудачный работают ли комбинации Ctrl+Alt+F2..F9 ?

Nao ★★★★★ ()

(EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so
(EE) AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so

Найди fglrx_dri.so:

locate fglrx_dri.so

Сделай симлинк
ln -s полный_путь_к_fglrx_dri.so /usr/lib64/dri/fglrx_dri.so

Nao ★★★★★ ()
Ответ на: комментарий от Nao

Xorg.0.log (failed)

После операций с симлинками при неуспешном запуске файл Xorg.0.log пустой, а при успешном ошибки пропали, остались только варнинги.

Данные комбинации не работают. Не работает даже Alt + Ctrl + Del

zooZooz ()
Ответ на: комментарий от zooZooz

Что-то сомневаюсь, если бы вы поставили так, то сообщений, о том, что не найден файл /usr/X11R6/lib64/modules/dri/fglrx_dri.so и прочие не было.

Скорее всего, вы скачали с сайта AMD пакет с драйвером и поставили, если так, то запускайте в начале этот пакет с ключом '--uninstall', а потом ставьте драйвер из репозитория.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Ну, я пытался и пакет постааить, и архив с сайта амд.

А перед тем, как запустить --uninstall, удалять пакет fglrx-driver?

zooZooz ()

Решение есть!

Лично у меня сработало.

Добавил в параметры загрузки ядра:

nomodeset

Далее:

apt-get purge xserver-xorg-video-radeon

apt-get autoremove --purge *

Далее перезагружаемся и всё.

zooZooz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.