LINUX.ORG.RU

Настройка XKB

 , ,


0

2

Настроил под себя переключение раскладок, но беда в том что при подключении к USB-порту клавиатуры или устройств с клавишами, эти настройки слетают на «дефолтные», указаные при установке(наверное). Как правильно указать конфиг для XKB?
И как сделать переключение по shift+caps на английскую раскладку, а caps на русскую?

★★★★★

Ответ на: комментарий от mamboo

В автозагрузке

xkbcomp $HOME/.config/xkb/"файл с настройками" $DISPLAY
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete+ledscroll(group_lock)"	};
	xkb_symbols   { include "pc+us+ru:2+inet(evdev)+capslock(grouplock)+compose(sclk)"	};
	xkb_geometry  { include "pc(pc104)"	};
};

aplay ★★★★★ ()
Ответ на: комментарий от aplay

Трындец... Если я правильно грепнул /usr/share/X11/xkb, эта заумь должна бы выглядеть как-то так:

setxkbmap -model "pc104" -layout "us,ru" -option "grp:caps_toggle,grp_led:scroll,compose:sclk"
Возможно, что-то упустил.

Насколько я знаю, штатным средством установить общесистемные настройки клавиатуры является localectl. Ну, или можно просто состряпать файлик /etc/X11/xorg.conf.d/00-keyboard.conf примерно такого содержания:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbModel" "pc104"
        Option "XkbOptions" "grp:caps_toggle,grp_led:scroll,compose:sclk"
EndSection

mamboo ★★ ()

Я хоть и не опытен в этом деле, но поясните мне чем не устроил людей/разработчиков /etc/default/keyboard (в Debian) там ведь тоже дописать какой язык хотим видеть еще и grp:caps_toggle,grp_led:scroll добавить. Это наверное дистроспецифично?

mul4 ★★★★★ ()
Ответ на: комментарий от mamboo

Ага, спасибо, там и лежал конфиг, на который сбрасывалось.

aplay ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.