LINUX.ORG.RU

Вопрос по драйверам видео + Megafon M100-4 LTE

 , , , ,


0

1

У меня Fedora 20 (KDE). Нетбук Acer Aspire ONE D270. Раньше была сборка KDE Light, были свои проблемы, но видео завелось сразу. Теперь при попытке просто включения ловлю чёрный экран и на встроенном мониторе и на подключенном HDMI. Убрал из загрузчика строки

load_video
set gfxpayload=keep
стал включаться, при подключенном HDMI - изображение есть на встроенный экран и нормальный монитор. Если кабель не подключен при загрузке - встроенный экран чёрный и изображения нет. Как побороть?

Второй вопрос. Взял 4g-модем Megafon M100-4. Сделал

yum install modem-manager-gui
nm-connection-editor --create --type gsm
Всё настроил, как надо. В NetworkManager Version 0.9.3.5 в настройках соединения вместо приоритет LTE, выбираю ТОЛЬКО LTE. Перезагружался несколько раз, настройка не сбрасывается - я проверял. Но почему-то только LTE упадёт до 2 единиц - загорается HSPA+ или UMTS и на LTE обратно не переходит. Как исправить, чтобы принудительно только 4G юзал?

UPDATE:

Вывод AT^SETPORT=?
^SETPORT:1: 3G MODEM
^SETPORT:2: 3G PCUI
^SETPORT:3: 3G DIAG
^SETPORT:5: 3G GPS
^SETPORT:A: BLUE TOOTH
^SETPORT:16: NCM
^SETPORT:A1: CDROM
^SETPORT:A2: SD
^SETPORT:10: 4G MODEM
^SETPORT:12: 4G PCUI
^SETPORT:13: 4G DIAG
^SETPORT:14: 4G GPS
Сделал
echo 'AT^SETPORT="FF;10,12,13,16"' > /dev/ttyUSB0
Всё равно, при коннекте LTE, а потом сваливается на 3G.

UPDATE2:

С модемом разобрались ниже. Решил переставить дрова для видео. Проц Atom N2600, видео Intel GMA 3600. Нашёл Intel(R) Graphics Installer for Fedora* 20, 64-bit, оказалось к моему не подходит. Написано связаться с производителем оборудования (у них глухо), или с поставщиком ОС :(

AT^SETPORT=? - Отображение возможной конфигурации портов.

AT^SETPORT? - Отображение текущей конфигурации портов.

AT^SETPORT=«A1,A2;10,12,16,A1,A2» - Включен режим ( По умолчанию ). AT^SETPORT=«FF;10,12» - Включен режим «Только Модем». AT^SETPORT=«FF;10,12,16» - Включен режим «Только Модем» и «NDIS». AT^SETPORT=«FF;12,16» - Включен режим «Только NDIS».

Для МТС прошивки.

AT^SETPORT=«A1,A2;61,62,76,A1,A2» - Включен режим ( По умолчанию ). AT^SETPORT=«FF;61,62» - Включен режим «Только Модем». AT^SETPORT=«FF;61,62,76» - Включен режим «Только Модем» и «NDIS». AT^SETPORT=«FF;62,76» - Включен режим «Только NDIS».

AT^SYSINFOEX - Чтобы узнать в какой сети ( GSM, WCDMA или LTE ) зарегистрирован Модем.

AT^SYSCFGEX=? - Чтобы узнать диапазоны частот.

ATI - Вывод информации о Модеме.

AT^FHVER - Показывает информацию о версии прошивки и версии железа.

AT^RESET - Перезагрузка Модема, очень полезная команда не требует «передергивать» Модем.

AT^VERSION? - Информация о версии прошивки Модема.

Включение / отключение режимов 3G и 4G.

AT^SYSCFGEX=«00»,3fffffff,2,4,7fffffffffffffff,, - Автоматически. AT^SYSCFGEX=«02»,3fffffff,2,4,7fffffffffffffff,, - Только 3G.

AT^SYSCFGEX=«02»,400000,2,4,7FFFFFFFFFFFFFFF,, - 3G ( 2100 МГц ) AT^SYSCFGEX=«02»,400000,2,4,40,,

AT^SYSCFGEX=«02»,2000000000000,2,4,7FFFFFFFFFFFFFFF,, - 3G ( 900 МГц ) AT^SYSCFGEX=«02»,2000000000000,2,4,40,,

AT^SYSCFGEX=«02»,2000000400000,2,4,40,, - 3G ( 900/2100 МГц )

AT^SYSCFGEX=«03»,3fffffff,2,4,7fffffffffffffff,, - Только 4G. AT^SYSCFGEX=«0302»,3FFFFFFF,1,2,7FFFFFFFFFFFFFFF,, - 4G/3G.

http://4pda.ru/forum/index.php?showtopic=508842&st=300

Ты режимы устройства переключал, а не сети, судя по всему.

sluggard ★★★★★ ()
Последнее исправление: sluggard (всего исправлений: 1)
Ответ на: комментарий от sluggard

AT^SYSCFGEX=«03»,3fffffff,2,4,7fffffffffffffff,, - Только 4G.

Огромное спасибо! Теперь под LTE норм тянет и не отваливается :) Надо каждый раз при перезагрузке сеть переключать, или 1 раз достаточно?

StasON777 ()
Ответ на: комментарий от StasON777

Не в курсе. Почитай по ссылке, или проверь ребутом. )

sluggard ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.