LINUX.ORG.RU

Whiskermenu и хоткей

 ,


0

1

Дано: Mint16, XFCE 4.10, по дефолту в панели xfce стоит whiskermenu-plugin.

Проблема: не получается настроить хоткеи для переключения рабочих столов на Super+1,2,3... Любое нажатие Super_L вызывает Whisker, соответственно переключение стола не срабатывает. В настройках крысы этот хоткей светится, но не удаляется ни из гуя, ни путем редактирования xfce4-keyboard-shortcuts.xml. Удаление самого плагина не помогает, настройка остается в конфигах и так же не удаляется, только теперь на нажатие Super_L крыса начинает ругаться.

Метод отсюда Keyboard Shortcut тоже не помог.

Это создатели Минта куда-то захардкодили вызов Whisker? Как убрать этот хоткей или хотя бы заставить работать параллельно и мои хоткеи?

Любое нажатие Super_L вызывает Whisker, соответственно переключение стола не срабатывает.

Хм, сейчас у себя проверил (на Debian) - такая же фигня.

В настройках крысы этот хоткей светится, но не удаляется ни из гуя, ни путем редактирования xfce4-keyboard-shortcuts.xml

Это как?

Programmist11180 ★★★ ()
Ответ на: комментарий от Programmist11180

Это как?

Значение изменяется, но стоит закрыть и заново открыть настройки, строка в вискером опять там и опять на Super_L. Если руками выпилить строку с ней из файла, то вискер все равно появляется по Super, а строка появится заново если открыть настройки.

Ну хоть не только в минте так, есть надежда что пофиксят.

nagalfar ()
Ответ на: комментарий от nagalfar

Нашел тикет. Автор грешит на минт, но раз баг повторяется и в дебиане, возможно дело в связке крысы с вискером. Печаль.

nagalfar ()
Ответ на: комментарий от nagalfar

Часом в /etc не присутствуют какие-либо глобальные настройки для XFCE? У минта помнится для многих приложений там имеются глобальные настройки.

Programmist11180 ★★★ ()
Ответ на: комментарий от Programmist11180

Минтовцы баг приняли, буквально неделю назад. Вот этот способ мне в общем помог, удалось повесить хоткеи на Super_L+1,2,3,4:

My workaround for this was to edit /usr/share/mint->configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml and remove the unwanted keybind --> save --> Log out and in --> Return to Settings Manager > Keyboard, and add anymore desired keybinds.

Можно пока использовать его, ждем фикса в минте.

nagalfar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.