LINUX.ORG.RU

Проблема с пакетной системой в Debian

 


0

1

Недавно перешёл на Debian testing. Заметил, что часть пакетов не хочет ставиться, хотя есть в репозиториях (поиск на packages.debian.org даёт результат именно для моего выпуска дистрибутива и моей архитектуры). Например, не хочет ставиться браузер Midori (и не только он, а ещё куча пакетов).

kiv@kiv-notebook:~$ sudo apt-get install midori
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Package midori is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'midori' has no installation candidate

Мой /etc/apt/sources.list таков:

# 

#deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20140127-04:08]/ jessie main

#deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20140127-04:08]/ jessie main

deb http://ftp.ru.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ jessie-updates main
deb-src http://ftp.ru.debian.org/debian/ jessie-updates main

# jessie-backports, previously on backports.debian.org
deb http://ftp.ru.debian.org/debian/ jessie-backports main
deb-src http://ftp.ru.debian.org/debian/ jessie-backports main

# dropbox
deb http://linux.dropbox.com/debian wheezy main

# i2p
deb http://deb.i2p2.no/ unstable main
deb-src http://deb.i2p2.no/ unstable main

В чём может быть проблема?

★★★★★

Я что-то ночью не пойму никак почему мне не нравится твои репозитории.

mbwa ()

Ну наверное именно потому, что в частности пакета midori нет в тестовом релизе.

Зайдите на http://packages.debian.org/ru/sid/midori или http://packages.debian.org/search?keywords=midori и вы увидите, что пакет midori доступен для стабильного, старого стабильного не нестабильного реизов. Для тестового релиза пакета нет. Вы можете задействовать смешение веток релизов и сказать, что основной веткой у вас будет тестовая ветка, а пакет midori вы хотите поставить, к примеру из нестабильной ветки.

Exact hits
Package midori

    squeeze (oldstable) (web): fast, lightweight graphical web browser
    0.2.4-3: amd64 armel i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 sparc
    wheezy (stable) (web): fast, lightweight graphical web browser
    0.4.3+dfsg-0.1: amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 s390x sparc
    sid (unstable) (web): fast, lightweight graphical web browser
    0.4.3+dfsg-0.1: alpha amd64 armel armhf hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 m68k mips mipsel powerpc powerpcspe ppc64 s390x sh4 sparc x32
    0.4.1-2 [debports]: sparc64
    0.3.3-0.1 [debports]: hppa

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
midori:
  Installed: (none)
  Candidate: 0.4.3+dfsg-0.1
  Version table:
     0.4.3+dfsg-0.1 0
        500 http://ftp.ru.debian.org/debian/ stable/main amd64 Packages
        950 http://ftp.ru.debian.org/debian/ sid/main amd64 Packages
        400 http://http.kali.org/kali/ kali/main amd64 Packages
Towelie ()
Ответ на: комментарий от kostik87

Большое спасибо за пояснение. Недавно перешёл на Debian с арча и ещё не со всем разобрался.

KivApple ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.