LINUX.ORG.RU

Wheezy: Параметры системы->питание


0

1

Отсутствует назначение реакции на кнопки Power/Sleep
Как теперь назначать реакцию?
Нужен «спящий режим» при нажатии на sleep.
Сейчас срабатывает «ждущий режим» и десктоп остается с крутящимся вентилятором.
На нажатие «power» вообще ни какой реакции.
Приходится в спячку отправлять лишь через «Выключить»

★★

Ответ на: комментарий от roman77

KDE, УМВР

Дешевле поставить «MATE Desktop Environment»
Там есть такие настройки.
#apt-get install kde-standard
Необходимо скачать 285 MB/285 MB архивов.

n0mad ★★ ()
Ответ на: комментарий от anonymous

Не будь столь агрессивным, анон, в ТС про xfce4-power-manager ни слова. У xfce4-power-manager бывают проблемы с перехватом кнопок питания, на арче, например, решается так. Но, насколько я знаю, эти ваши Debian'ы не перешли на systemd ещё.

Deleted ()
Ответ на: комментарий от Akamanah

Как у вас там, в эпохе винтов пятигигабайтных?

Нынешнее закрученноое поколение не ведает бритвы оккама.
Потому в такую жопу и рулим - включая линукс.
Наплодили ад сущностей и борем эти ветряные мельницы.
С другой стороны это работа до конца жизни. Сейчас ведь не модно чтобы всё работало без участия человека. Надо и человеку работать чтобы обосновывать получаемую зряплату.

n0mad ★★ ()
Ответ на: комментарий от anonymous

DE будем угадывать по буквам?

Если это про мою DE то имелась в виду дефолтная DE.
Если бы я поставил что то отличное от дефолта то указал бы. Дистрибутив указан в заголовке.

n0mad ★★ ()
Последнее исправление: n0mad (всего исправлений: 1)
Ответ на: комментарий от uuwaan

Поставь пакет acpi-support, легче по-моему ничего нет.

Он стоит но параметров в диалоге нет.
Если перелогиниться в MATE - параметры есть.
Однако хочется знать как это решать в дефолтном DE

n0mad ★★ ()
Ответ на: комментарий от n0mad

Вообще основная задача наверное нерешаемая.
На работе обесточивают ВСЁ в конце дня, потому надо
простой механизм засыпания - чтобы коллега подошел, ткнул Power и оно уснуло. Однако при заблокированном экране ни sleep ни кнопка power на клаве ни кнопка power на корпусе не отрабатывают.

n0mad ★★ ()
Ответ на: комментарий от n0mad

Судя по всему, менеджер питания GNOME перенимает управление реакциями на события на себя. Найди способ его отключить и настрой через /etc/acpi/events.

anonymous ()
Ответ на: комментарий от anonymous

Судя по всему, менеджер питания GNOME перенимает управление реакциями на события на себя. Найди способ его отключить и настрой через /etc/acpi/events.

Вот и спрашиваю - может кто знает?
Пока нарыл только #dconf-editor и в нем скажем есть:
org->mate->power-manager:button-hibernate,button-power,button-suspend,...
А вот в ветке:
org->gnome->power-manager ни чего подобного нет.
Я в шоке... придется видимо на KDE переползать с гнома - но это немного другой look&feel. Либо оставаться на MATE. Запамятовал правда какой косяк меня с MATE в Gnome classic выгнал... :(

n0mad ★★ ()
Ответ на: комментарий от n0mad

Ты не ведаешь другу сторону бритвы. Отказываясь от единственной полноценной среды рабочего стола, ты окунаешься в дебри пердоленья с системой и тряской над сотней мегабайт.

Akamanah ★★★★★ ()
Ответ на: комментарий от n0mad

dconf editor: org > gnome > settings-daemon > plugins > power. Убери флажок с 'active', перезайди.

anonymous ()
Ответ на: комментарий от n0mad

надо простой механизм засыпания - чтобы коллега подошел, ткнул Power и оно уснуло

Как два пальца. Я когда-то делал. Примерно так:
Правим /etc/acpi/powerbtn-acpi-support.sh и под комментом # Normal handling. shutdown меняем на pm-hibernate

Всё. Будет работать вообще почти в любой момент, вплоть до того, что можно тушить на взлёте, до загрузки иксов.
Если где-то не работает, значит что-то перехватывает события (графический менеджер питания, блокировка).
Менеджер питания выпилить, блокировку сменить на что-то менее инвазивное.

aidaho ★★★★★ ()
Ответ на: комментарий от aidaho

Как два пальца. Я когда-то делал. Примерно так:
Правим /etc/acpi/powerbtn-acpi-support.sh и под комментом # >Normal handling. shutdown меняем на pm-hibernate

И ведь знал! Ведь знал! Спасибо большое за напоминание.
Debian squeeze по дефолту уходит в шатдаун вне зависимости от настроек параметров управления питанием. Проанализировав скрипты выяснил что самый «Debian way» это что то типа
#echo «#! /bin/sh» >>/etc/acpi/powerbtn.sh
#chmod +x /etc/acpi/powerbtn.sh
и принудительный шатдаун по нажатию Power отключается.
На сегодняшний момент еще добавляется:
#echo pm-hibernate >>/etc/acpi/powerbtn.sh

n0mad ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.