LINUX.ORG.RU
решено ФорумAdmin

Проблема mint + AD


0

1

Итак. Есть контроллер домена 2008R2, есть десктоп с Linux Mint 16. Ввожу mint в домен по мануалу http://help.ubuntu.ru/wiki/ввод_в_домен_windows

Все проходит успешно, машина в домен входит, в днс создается запись, вроде бы все хорошо. Но потом не получается авторизоваться под доменной учеткой. Появляется сообщение ( Некорректное имя пользователя или пароль. Символы должны быть введены в правильном регистре).

Смотрю вывод команды # wbinfo -t # wbinfo -u # wbinfo -g C этими все хорошо, пользователей и группы вижу.

При вводе #getent passwd я полагаю что должен быть вывод всех юзеров в домене вместе с локальными, вижу только локальных. Все делал четко по инструкции, в процессе никаких ошибок небыло. Пробовал поднимал DC на eng дистрибутиве, думал из за языков могут быть траблы, но в eng версии все аналогично. В чем может быть загвоздка?

авторизуюсь так DOMAIN.COM\Administrator

во-первых: эти хауту девяностых давно пора сложить в печь и пользоваться sssd

во-вторых: в виндовсе отродясь надо было писать нетбиосовое имя домена перед слешем, а не днсное, т.е. DOMAIN\Administrator. Тут я правда могу ошибаться, ибо в хауту девяностых не было кербероса.

anonymous ()
Ответ на: комментарий от selivan

# /etc/nsswitch.conf

#

# Example configuration of GNU Name Service Switch functionality.

# If you have the `glibc-doc-reference' and `info' packages installed, try:

# `info libc «Name Service Switch»' for information about this file.

passwd: compat winbind

group: compat winbind

shadow: compat

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

networks: files

protocols: db files

services: db files

ethers: db files

rpc: db files

netgroup: nis

Bombila_Xa4 ()
Ответ на: комментарий от Bombila_Xa4

Проверяем: http://packages.debian.org/search?searchon=contents&keywords=libnss_winbi...

Это, правда, дебиан, но убунта один хрен с него скопирована.

Поставь libnss-winbind.

Информация про /lib/libnss_SERVICE.so.X нашлась в man nsswitch.conf. Кстати, наверняка оно ругалось в syslog.

selivan ★★★ ()
Ответ на: комментарий от selivan

После установки libnss-winbind

#getent passwd Стала отображать доменных пользователей, но залогиниться все равно не получается. В суслог ничего необычного не валится.

Самое интересное что где то год назад подобная процедура не вызывала вообще никаких вопросов, а сейчас эта эпопея уже около недели длится.

Bombila_Xa4 ()
Ответ на: комментарий от user_undefined

В общих чертах хоть расскажите как sssd настраивается. Нагуглил тут http://wiki.samba.org/index.php/Local_user_management_and_authentication/sssd...

установил пакет по мануалу создал конфиг, дальше то что, в статье есть пункт testing, там 1 же команда

sss_cache -UG

выдает

No domains configured, fatal error.

Вообще не понятно что с этим делать.

Bombila_Xa4 ()
Ответ на: комментарий от Bombila_Xa4

конфиг показал бы свой, небось не сконфигурил домен, вот он и не стартует

anonymous ()
Ответ на: комментарий от Bombila_Xa4

у меня практически один в один с федоровской докой, разве что ldap_access_filter добавлен, и keytab не делаем

user_undefined ()
Ответ на: комментарий от Bombila_Xa4

Ты только одновременно sssd и самбу не настраивай.

Итак, после того, как его поставили, NSS заработал.

Почему не логинится - это к PAM. Показывай настройки. Лучше на pastebin, не надо километровых постов.

selivan ★★★ ()
Ответ на: комментарий от Bombila_Xa4

PAM показывай, самба и kerberos у тебя вроде впорядке - kinit работает, winbind пользователей показывает.

/etc/pam.d/login и всё, на что он ссылается

selivan ★★★ ()
Ответ на: комментарий от Bombila_Xa4

А теперь внимательно читай, что написано по приведённой тобой же ссылке, в том чисде про PAM: http://help.ubuntu.ru/wiki/ввод_в_домен_windows#авторизация_в_ubuntu_через_по...
%D0%B5%D0%BD%D0%B0

«/etc/pam.d/login и всё, на что он ссылается» - то есть всё, что уплмянуто в @include, а ты только login запостил

selivan ★★★ ()
Ответ на: комментарий от selivan

Из этой инструкции я выполнил

Он-лайн авторизация

Для Ubuntu 10.04 и выше добавьте всего одну строку в файле /etc/pam.d/common-session, т.к. PAM и так неплохо справляется с авторизацией:

session optional pam_mkhomedir.so skel=/etc/skel/ umask=0077

вот этот пункт, остальное не делал

Bombila_Xa4 ()
Ответ на: комментарий от Bombila_Xa4

Тогда эти изменения убери и попробуй тот вариант, который называется «Для Ubuntu 9.10 и ниже придется редактировать несколько файлов (но никто не запрещает использовать этот способ и в 10.04 - он тоже работает)»

Ещё создай /etc/security/pam_winbind.conf:

[global]
# turn on debugging
debug = yes

И смотри syslog и auth.log

Вообще, полезно будет покурить man pam_windind

selivan ★★★ ()
Последнее исправление: selivan (всего исправлений: 1)
Ответ на: комментарий от Bombila_Xa4

os level лучше не трогать - закомментируй.

И есть подозрение, что больше всего виновата опция winbind use default domain = yes. Попробуй закомментировать.

Kiborg ★★★ ()
Ответ на: комментарий от Kiborg

закоментировал, рузультата 0. также пробовал оффлайн авторизацию, результата 0.

в суслоге Dec 3 12:08:27 alex1 mdm[2366]: WARNING: Couldn't authenticate user

Bombila_Xa4 ()
Ответ на: комментарий от Bombila_Xa4

В новых убунтах upstart, там этого нет. Просто перезапусти winbind

И смотри syslog, auth.log

selivan ★★★ ()
Ответ на: комментарий от selivan

Чьерт побьерриии! АААААА Спасибо огромное!!! ЗАРАБОТАЛО!!!

Осталось теперь повторить тоже самое для закрепления. Сейчас буду проверять все на корректную работу!!

Ну и sssd поковырять не помешает. Как я понял из гугла на winbind многие отзываются как о очень кривом пакете.

Bombila_Xa4 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.