LINUX.ORG.RU
решено ФорумAdmin

накосячил с репозиториями и пакетами в proxmox2.3 (debian 6.0.7). HELP


0

1

два компа - две инсталляции proxmox2.3

содержимое /etc/apt/sources.list первой ноды


deb http://ftp.ru.debian.org/debian wheezy main contrib

# PVE packages provided by proxmox.com
deb http://download.proxmox.com/debian wheezy pve

# security updates
deb http://security.debian.org/ wheezy/updates main contrib

по ошибке изменил на

deb http://ftp.debian.org/debian wheezy main contrib

# PVE packages provided by proxmox.com
deb http://download.proxmox.com/debian wheezy pve

# security updates
deb http://security.debian.org/ wheezy/updates main contrib

и выполнил команду #apt-get install ntfs-3g

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  fuse fuse-utils libblkid1 libfuse2 libgnutls26 libmount1 libp11-kit0 mount multiarch-support
The following NEW packages will be installed:
  fuse libmount1 libp11-kit0 multiarch-support ntfs-3g
The following packages will be upgraded:
  fuse-utils libblkid1 libfuse2 libgnutls26 mount
5 upgraded, 5 newly installed, 0 to remove and 436 not upgraded.
Need to get 620 kB/2,156 kB of archives.
After this operation, 2,142 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
в результате на этой ноде обновился fuse до 2.9.0 со всеми зависимостями. Теперь админка proxmox на этой ноде не авторизовывает. С админки второй ноды нет доступа на первую ноду.

Ну понятно что вопрос номер один - это почему изначально было такое содержимое /etc/apt/sources.list если debian 6.0.7 это squeeze и содержимое должно было быть

deb http://ftp.ru.debian.org/debian squeeze main contrib

# PVE packages provided by proxmox.com
deb http://download.proxmox.com/debian squeeze pve

# security updates
deb http://security.debian.org/ squeeze/updates main contrib

и второй вопрос как вернуть пакеты в состояние до команды
apt-get install ntfs-3g

виртуалки пока вроде как работают (но чувствую до перезапуска). Сервер не ребутал. в /etc/pve на первой ноде пусто, на второй все на месте

★★★

proxmox2.7

Извините, у нас сломалась машина времени. Попробуйте обратиться через пару лет.

Mr_Alone ★★★★★ ()

содержимое /etc/apt/sources.list первой ноды

deb http://ftp.ru.debian.org/debian wheezy main contrib

# PVE packages provided by proxmox.com
deb http://download.proxmox.com/debian wheezy pve

# security updates
deb http://security.debian.org/ wheezy/updates main contrib

по ошибке изменил на

deb http://ftp.debian.org/debian wheezy main contrib

# PVE packages provided by proxmox.com
deb http://download.proxmox.com/debian wheezy pve

# security updates
deb http://security.debian.org/ wheezy/updates main contrib

Не вижу разницы, кроме 'ru' в первом случае.

Mr_Alone ★★★★★ ()
Последнее исправление: Mr_Alone (всего исправлений: 1)
Ответ на: комментарий от Mr_Alone

да разница только в 'ru',а ошибка в том что удаляя 'ru' я не заметил что репы от дистра wheezy

как теперь откатить пакеты?
как изменить репозитории понятно.

Vlad-76 ★★★ ()
Последнее исправление: Vlad-76 (всего исправлений: 1)
Ответ на: комментарий от Vlad-76

в debian я не шибко понимаю в типах репов

Тогда изучите Debian Reference Manual целиком.

с подсказки сделал /etc/apt/preferences
так?

Да, должно получиться. Потом сделайте apt-get update и apt-get dist-upgrade.

AITap ★★★★★ ()
Ответ на: комментарий от AITap
The following packages will be REMOVED:
  aptitude-common bootlogd clvm cpp-4.7 fence-agents-pve fuse grub-pc-bin grub2-common initramfs-tools libanyevent-http-perl libapt-inst1.5 libapt-pkg4.12
  libasprintf0c2 libbind9-80 libblas3 libboost-thread1.49.0 libdevmapper-event1.02.1 libdns88 libept1.4.12 libfile-listing-perl libgnutls-openssl27
  libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libisccfg82 libkadm5clnt-mit8 libkadm5srv-mit8
  liblockfile-bin liblwp-mediatypes-perl liblwp-protocol-https-perl libnet-http-perl libperl5.14 libpve-access-control librados2 librbd1 libwww-robotrules-perl
  mc-data pve-cluster pve-kernel-2.6.32-18-pve pve-kernel-2.6.32-19-pve pve-kernel-2.6.32-20-pve pve-kernel-2.6.32-23-pve python2.7 redhat-cluster-pve
  resource-agents-pve
The following NEW packages will be installed:
  cpp-4.4 defoma fancontrol gcc-4.4-base libasync-interrupt-perl libbind9-60 libboost-iostreams1.42.0 libcap-ng0 libcman3 libdb4.7 libdb4.8 libdbi0
  libdigest-sha1-perl libdlm3 libdlmcontrol3 libdns69 libept1 libevent-1.4-2 libfont-freetype-perl libfontenc1 libgmp3c2 libisc62 libisccc60 libisccfg62
  liblogthread3 liblwres60 liblzma2 libnet-libidn-perl libnl1 libpango1.0-common libperl5.10 libsdl1.2debian-alsa libssl0.9.8 libsvga1 libtokyocabinet8 libvirt0
  libx86-1 libxcb-render-util0 libxenstore3.0 libxfont1 lm-sensors lockfile-progs openssh-blacklist python-central python2.6 x-ttcidfont-conf xfonts-encodings
  xfonts-utils
The following packages will be upgraded:
  ksm-control-daemon
The following packages will be DOWNGRADED:
  adduser apt apt-listchanges apt-utils aptitude at attr base-files base-passwd bash bash-completion bc bind9-host bridge-utils bsd-mailx bsdmainutils bsdutils
  busybox bzip2 ca-certificates cifs-utils console-common console-data console-tools coreutils cpio cpp cron cstream dash dc debconf debconf-i18n
  debian-archive-keyring debian-faq debianutils diffutils dmidecode dmsetup dnsutils doc-debian dpkg dtach e2fslibs e2fsprogs eject fdutils file findutils
  fontconfig fontconfig-config ftp gawk gettext-base gnupg gpgv grep groff-base grub-common grub-pc gzip hostname ifenslave-2.6 ifupdown info initscripts insserv
  install-info iproute iptables iputils-arping iputils-ping isc-dhcp-client isc-dhcp-common klibc-utils less libacl1 libaio1 libanyevent-perl libasound2
  libasyncns0 libattr1 libauthen-pam-perl libblas3gf libblkid1 libbsd0 libbz2-1.0 libc-bin libc6 libcaca0 libcairo2 libcap2 libcgroup1 libcomerr2
  libcommon-sense-perl libconsole libconvert-asn1-perl libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcurl3-gnutls
  libcwidget3 libdatrie1 libdbus-1-3 libdevel-cycle-perl libdevmapper1.02.1 libdigest-hmac-perl libdirectfb-1.2-9 libedit2 libexpat1 libffi5 libfile-chdir-perl
  libfile-readbackwards-perl libfile-sync-perl libfilesys-df-perl libflac8 libfontconfig1 libfreetype6 libfuse2 libgc1c2 libgcc1 libgcrypt11 libgdbm3 libgeoip1
  libgfortran3 libglib2.0-0 libgnutls26 libgpg-error0 libgpgme11 libgpm2 libgssapi-krb5-2 libgssglue1 libgssrpc4 libhtml-parser-perl libhtml-tree-perl libice6
  libidn11 libio-multiplex-perl libio-socket-ssl-perl libio-stringy-perl libjpeg62 libjpeg8 libjson-perl libjson-xs-perl libjson0 libk5crypto3 libkeyutils1
  libklibc libkrb5-3 libkrb5support0 libldap-2.4-2 liblinear1 liblinux-inotify2-perl liblocale-gettext-perl liblockfile-simple-perl liblockfile1 liblua5.1-0
  liblzo2-2 libmagic1 libmpc2 libmpfr4 libncurses5 libncursesw5 libnet-dns-perl libnet-ip-perl libnet-ldap-perl libnet-snmp-perl libnet-ssleay-perl libnewt0.52
  libnfnetlink0 libnfsidmap2 libogg0 libopenipmi0 libopts25 libpam-modules libpam-runtime libpam0g libpango1.0-0 libparted0debian1 libpcap0.8 libpci3 libpcre3
  libpixman-1-0 libpng12-0 libpopt0 libpulse0 libreadline5 libreadline6 librpcsecgss3 librrd4 librrds-perl librtmp0 libsasl2-2 libsdl1.2debian libselinux1
  libsemanage-common libsemanage1 libsensors4 libsepol1 libsgutils2-2 libsigc++-2.0-0c2a libslang2 libsm6 libsndfile1 libsnmp-base libsnmp15 libsqlite3-0 libss2
  libssh2-1 libstdc++6 libsysfs2 libtalloc2 libtasn1-3 libtdb1 libterm-readline-gnu-perl libtext-charwidth-perl libtext-iconv-perl libthai-data libthai0 libtirpc1
  libts-0.0-0 libudev0 liburi-perl libusb-0.1-4 libusb-1.0-0 libustr-1.0-1 libuuid1 libvncserver0 libvorbis0a libvorbisenc2 libwbclient0 libwrap0 libwww-perl
  libx11-6 libx11-data libx11-xcb1 libxapian22 libxau6 libxaw7 libxcb-render0 libxcb-shm0 libxcb1 libxcursor1 libxdmcp6 libxext6 libxfixes3 libxft2 libxi6
  libxkbfile1 libxml-parser-perl libxml2 libxml2-utils libxmu6 libxmuu1 libxpm4 libxrender1 libxslt1.1 libxt6 libxtst6 locales login logrotate lsb-base lsof lvm2
  lynx lynx-cur lzop m4 man-db manpages mawk mc memtest86+ mime-support mlocate mount mutt nano ncurses-base ncurses-bin ncurses-term net-tools netbase
  netcat-traditional nfs-common nmap ntp open-iscsi openipmi openssh-client openssh-server openssl parted passwd patch pciutils perl perl-base perl-modules
  postfix procmail procps psmisc python python-apt python-apt-common python-chardet python-debian python-debianbts python-fpconst python-minimal python-openssl
  python-pexpect python-pycurl python-reportbug python-support python2.6-minimal readline-common reportbug rpcbind rrdcached rsync rsyslog samba-common sed
  sensible-utils sg3-utils smbclient snmp sqlite3 ssh ssl-cert strace sysv-rc sysvinit sysvinit-utils tar tasksel tasksel-data tcpdump texinfo time traceroute
  tsconf ttf-dejavu-core tzdata ucf udev unzip usbutils util-linux vim-common vim-tiny vzquota w3m wamerican wget whiptail whois x11-apps x11-common xauth
  xsltproc xz-utils zlib1g
1 upgraded, 48 newly installed, 366 downgraded, 47 to remove and 0 not upgraded.
Need to get 155 MB of archives.
After this operation, 11.5 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y

в списке удалаяемых fuse пакет вижу, но в списке устанавливаемых и downgrade не вижу. Это нормально?

Vlad-76 ★★★ ()
Ответ на: комментарий от Vlad-76

Учитывая, что даунгрейд не поддерживается, да, нормально. fuse действительно будет удалён. Потом, наверное, сможете поставить его обратно. Я бы гораздо больше волновался за

pve-cluster pve-kernel-2.6.32-18-pve pve-kernel-2.6.32-19-pve pve-kernel-2.6.32-20-pve pve-kernel-2.6.32-23-pve python2.7 redhat-cluster-pve resource-agents-pve

Попробуйте запустить aptitude full-upgrade, переключиться в полноэкранный интерфейс командой e и отметить нужные пакеты нужных версий в том интерфейсе.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

побоялся того же самого
выясняется что список репов был правильный. Это я готовился к обновлению с 2.3 до 3.0
как выяснилось скрипт делает замену s/squeeze/wheezy/

root@proxmox1:~/proxmox_update# ./pve-upgrade-2.3-to-3.0
apt-get update
Hit http://ftp.ru.debian.org wheezy Release.gpg
Hit http://ftp.ru.debian.org wheezy Release
Hit http://ftp.ru.debian.org wheezy/main amd64 Packages
Hit http://ftp.ru.debian.org wheezy/contrib amd64 Packages
Hit http://ftp.ru.debian.org wheezy/contrib Translation-en
Hit http://ftp.ru.debian.org wheezy/main Translation-en
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://download.proxmox.com wheezy Release.gpg
Hit http://security.debian.org wheezy/updates Release
Hit http://download.proxmox.com wheezy Release
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://download.proxmox.com wheezy/pve amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib Translation-en
Hit http://security.debian.org wheezy/updates/main Translation-en
Ign http://download.proxmox.com wheezy/pve Translation-en
Reading package lists...
apt-get -f install
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libanyevent-http-perl libanyevent-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
apt-get install debian-archive-keyring
Reading package lists...
Building dependency tree...
Reading state information...
debian-archive-keyring is already the newest version.
The following packages were automatically installed and are no longer required:
  libanyevent-http-perl libanyevent-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sed -i -e "s/squeeze/wheezy/" /etc/apt/sources.list
apt-get update

получается что установка ntfs-3g потянула зависимости в т.ч. и новую версию fuse отчасти запланированную переходом с версии proxmox 2.3 на 3.0. работа кластера кстати криво но восстановилась.Только не понял после чего.

Vlad-76 ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.