LINUX.ORG.RU
ФорумAdmin

GCC


0

0

Люди помогите пжлста.
Хочу на RH9 поставить gcc-3.3.5, сразу же после запуска configure появляется ошибка:
You must set the environment variable CC to a working compiler.
В чем дело, чего нехватает?

anonymous

Re: GCC

Ставь из rmp. Так же всякие девелопмент тулз поставь, возможно решить проблему.

anonymous ()
Ответ на: Re: GCC от anonymous

Re: GCC

Он просит выставить переменную окружения СС
export CC=gcc

Правильно собирать из исходников надо так:

$ pwd
/tmp
$ ls
gcc-3.x
$ mkdir obj_files
cd obj_files
$ ../gcc/configure --enable-version-specific-runtime-libs
$ make  
# make install
# cd /tmp
# rm -rf gcc-3.x obj_files

Лучшее решение - это SRMP!!!
Правишь spec , собираешь пакет, ставишь и радуешься жизни!!! 

kri ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.