LINUX.ORG.RU
ФорумAdmin

Postfix, dovecot, clamsmtp - не отправляют или не приходят письма.

 


0

1

Настраивал все по руководству http://linuxforum.ru/viewtopic.php?id=21932 Но делаю все в virtualbox, виртсетевая настроенна NAT

Проверяю и отправляю почту через telnet на самом сервере:

как отправляю: https://dl.dropbox.com/u/1465661/uploads/command_smtp как получаю: https://dl.dropbox.com/u/1465661/uploads/command_pop

логи сервера при отправке: https://dl.dropbox.com/u/1465661/uploads/log_servera_smtp

логи сервера при получении: https://dl.dropbox.com/u/1465661/uploads/log_servera_pop3

Помогите пожалуйста правильно осознать ошибки указанные в логах и подкрутить правильно конфиг.

основная ошибка как я понял это: Jun 2 22:34:19 localhost postfix/smtp[3837]: 8D5C62017: to=<test@mail.local>, relay=127.0.0.1[127.0.0.1]:10025, delay=1.3, delays=0.2/0.08/1.1/0, dsn=4.4.2, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting) Jun 2 22:34:19 localhost postfix/smtp[3837]: flush_add: site mail.local id 8D5C62017 Jun 2 22:34:19 localhost postfix/smtp[3837]: match_list_match: mail.local: no match Jun 2 22:34:19 localhost postfix/smtp[3837]: flush_add: site mail.local id 8D5C62017 status 4

Я так понимаю если no match он просто не может «достучатся» до себя. Если отправляю на яндекс: Jun 2 22:42:40 localhost postfix/smtp[4126]: 160A82015: to=<yar1k01@yandex.ru>, relay=mx.yandex.ru[93.158.134.89]:25, delay=1.6, delays=0.24/0.07/1.1/0.19, dsn=4.7.1, status=deferred (host mx.yandex.ru[93.158.134.89] said: 451 4.7.1 Sorry, the service is currently unavailable. Please come back later. ciai12kT-ciaKMh2S (in reply to end of DATA command))

Т.е. я все правильно настроил и проблема лишь в том, что это в виртуальной машине и он не может сам до себя достучатся? в днс я пробывал виртуальный ip выданный по dhcp прописывать - телнетом на 25 не заходит.


Если отправляю на яндекс

Яндекс дропает потому что у тебя PTR-днс не сходится с hostname google://mail+ptr

Yustas ★★★★ ()

основная ошибка как я понял это

Похоже на то что постфикс не находит домен в списке обслуживаемых.
Проверь конфиг.

Yustas ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.