LINUX.ORG.RU
ФорумAdmin

Проблема с openswan

 , , ,


0

1

Доброго времени суток.

Возникла проблема с openswan следующего характера. Потребовалось связать две сети через Ipsec решено было использовать openswan. Настроили, все сначала показалось хорошо, пинг показывает 2-3 мс. Но как начали тестировать сразу появилась следующая проблема: к примеру как только из сети 1 начинают копировать любой файл в сеть 2 (например через общий доступ к файлам) то пинг очень сильно возрастает (до 300-600 мс), и так с любым сетевым приложением. Может кто нибудь с таким сталкивался? Или есть какие нибудь идеи? В логах никаких ошибок не видно вроде.

В сети 1 как шлюз используется CentOS
В сети 2 Debian

В сети 1 Openswan IPsec U2.6.32/K2.6.32-220.13.1.el6.i686
В сети 2 Openswan IPsec U2.6.28/K2.6.32-5-686...

Конфиг ipsec.conf:

# basic configuration
config setup
forwardcontrol=yes
plutodebug=«all»
dumpdir=/var/run/pluto/
plutostderrlog=/var/log/pluto.log
protostack=netkey
nat_traversal=no
oe=off
interfaces=%defaultroute

conn filial
authby=secret
auto=start
type=tunnel
left=x.x.x.x
leftsubnet=192.168.2.0/24
leftsourceip=192.168.2.52
right=y.y.y.y
rightsubnet=192.168.1.0/24
pfs=no
aggrmode=yes
auth=esp
esp=3des-sha1
ike=3des-sha1-modp1024


1) А если без ipsec копировать, пинг так же растет?
2) А как там с загрузкой проца во время копирования?

thesis ★★★★★ ()

А должно быть как-то по другому? Канал загружается полностью пакетами от процесса копирования файла, следовательно все остальные пакеты будут стоять в очередях и «ходить» долго.

mky ★★★★★ ()
Ответ на: комментарий от lost

Ну как бы да, если не упирается в процессор, то пинги тупят из-за 100% загрузки канала, сложно ожидать чего-либо еще. И да, OpenSWAN уже закопали давно вроде. Нынче рулит StrongSWAN.

blind_oracle ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.