LINUX.ORG.RU

Нарисовать роуты до нужных сетей провайдера через шлюз локалки вестимо.

blind_oracle ★★★★★ ()

Вариант решения.

Инфо с работающего роутера:

Status
System
Router Name	OpenWrt
Router Model	TP-Link TL-WR1043N/ND v1 
Firmware Version	 OpenWrt Attitude Adjustment r31340 / LuCI Trunk (trunk+svn8588) 
Kernel Version	3.2.15 
Local Time	Mon Apr 23 20:05:09 2012
Uptime	22h 20m 22s
Load Average
Проблему с настройкой DualAccess / Russian PPPoE в OpenWrt решил следующим образом. Вручную поправил файл /etc/system/network
config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
config interface 'server'
	option proto 'pppoe'
	option ifname 'eth0.2'
	option username 'login123'
	option password 'passw123'
И добавил интерфейс server в зону wan в /etc/system/firewall
config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option input 'REJECT'
	option forward 'REJECT'
	option network 'wan server'

Для того, чтобы всё это правильно срабатывало, добавил в /etc/rc.local рестарт сети

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

/etc/init.d/network restart
exit 0

justAmoment ★★★★★ ()
Ответ на: комментарий от justAmoment

Для того, чтобы всё это правильно срабатывало, добавил в /etc/rc.local рестарт сети

С версии 12.09 отпала необходимость в этом.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от justAmoment

Спасибо, давно собирался перешить свой 1043 со стока на OpenWRT.

unfo ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.