LINUX.ORG.RU
ФорумAdmin

траблы с запуском squid


0

0

поставил сквид 2.3 STABLE4
когда меняю дефолтный cache_dir

#/etc/init.d/squid start
Starting squid: init_cache_dir /etc/squid/work/cache... squid

причем структуру каталогов в /etc/squid/work/cache не создает

#/etc/init.d/squid status
squid (pid 5854) is running...
squid: ERROR: No running copy

при дефолтных установках запускается нормально.

когда монтирую в точку /var/spool/squid раздел
#/etc/init.d/squid start
Starting squid: init_cache_dir /var/spool/squid... squid
причем опять структуру не создает
#/etc/init.d/squid status
squid dead but subsys locked
squid: ERROR: No running copy

а мне обязательно надо поставить кэш на монтированую не к корню систему, потому что забил раздел под кэш, а перекраивать винт не хочется.

И где править ?

PS: ставил 2.3 STABLE2 - те же траблы. может 2.2 пробовать?
с-ма: RH7.0 SMP 2.2.16-22
железо: P3/128/ HD IBM 15G 7200RPM
root hda1 - 4G
hda6 - 8G - на этот раздел надо ставить кэш.
буду очень благодарен за любую помощь.


забыл написать, винт на udma-33 /не думаю что это имеет значение, но а вдруг?/


Re: траблы с запуском squid

Делал "squid -z" ?
Файлы /var/lock/subsys/squid и /var/run/squid удалил?
В /etc монтировать ничего _НЕЛЬЗЯ_ монтируй либо в /var/spool/squid либо в
/home/squid . Проверь могет ли юзверь сквид туда ходить и писать.
Удачи!
ЗЫ Я тож хочу СМП ~:)

gdenis ()

Re: траблы с запуском squid


2 gdenis:

спасибо, я уже разобрался -- просто удалил бинарники и собрал руками ;)

и почему это я немогу к /etc/squid/work примонтировать файловую систему? Кто запрещает ?

nCryer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.