LINUX.ORG.RU
ФорумAdmin

Ошибки типа ata2.00: hard resetting link


0

2

Привет всем!
Система: Ubuntu 10.04.3 LTS
2 HDD Seagate Barracuda 7200 RPM, 500 Gb, объединенных в software RAID 1.
Постоянно в лог сыпятся такие сообщения:

root@spring:/# dmesg | tail -n 30
[145178.015598] ata2.00: status: { DRDY }
[145178.026491] ata2.00: hard resetting link
[145178.370014] ata2.01: hard resetting link
[145183.920009] ata2.00: link is slow to respond, please be patient (ready=0)
[145188.060008] ata2.00: SRST failed (errno=-16)
[145188.070728] ata2.00: hard resetting link
[145188.420013] ata2.01: hard resetting link
[145193.970009] ata2.00: link is slow to respond, please be patient (ready=0)
[145196.430054] ata2.00: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[145196.430065] ata2.01: SATA link down (SStatus 0 SControl 300)
[145196.490420] ata2.00: configured for UDMA/33
[145196.490426] ata2.00: device reported invalid CHS sector 0
[145196.490434] ata2: EH complete
[145425.950035] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[145425.960857] ata2.00: failed command: WRITE DMA EXT
[145425.971626] ata2.00: cmd 35/00:08:c0:4b:38/00:00:3a:00:00/e0 tag 0 dma 4096 out
[145425.971627] res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[145426.015105] ata2.00: status: { DRDY }
[145426.025929] ata2.00: hard resetting link
[145426.370014] ata2.01: hard resetting link
[145431.920009] ata2.00: link is slow to respond, please be patient (ready=0)
[145436.060011] ata2.00: SRST failed (errno=-16)
[145436.070644] ata2.00: hard resetting link
[145436.420013] ata2.01: hard resetting link
[145441.970009] ata2.00: link is slow to respond, please be patient (ready=0)
[145444.670050] ata2.00: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[145444.670061] ata2.01: SATA link down (SStatus 0 SControl 300)
[145444.730404] ata2.00: configured for UDMA/33
[145444.730410] ata2.00: device reported invalid CHS


Винты нормальные, почти новые. Тест поверхности никаких сбоев не показал. Файловая система ext4.

Что это может быть? Шлейфы дергал, менял.

Проявляются проблемы в тормозах при файловых операциях, таких как, к примеру, mysqldump или OPTIMIZE TABLE xxx в MYSQL.


вот замметил ещё одно:

root@spring:/# hdparm -iv /dev/sda
......
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6

root@spring:/# hdparm -iv /dev/sdb
......
UDMA modes: udma0 udma1 *udma2 udma3 udma4 udma5 udma6


т.е. на одном винте udma=6, А на втором udma=2.

Может в этом глюк?

BusTeR ()

Очень распространённый вопрос. Проблема заключается либо в том, что помирает БП (проверь напряжения через sensors), либо в том, что отходят SATA кабели. Второе вероятнее

router ★★★★★ ()
Ответ на: комментарий от router

кабели заменил, блок питания заменил. То же самое.
Может это из-за софтварного RAID ?
Как это можно проверить?
Проблемы начинаются после минут 3-4 активного использования HDD.

BusTeR ()
Ответ на: комментарий от BusTeR

>Может это из-за софтварного RAID ?

Вряд ли. У меня ни разу не было проблем с software raid. Если конечно ты не перепутал его с недорейдом (aka fake raid).

Hard resetting link означает именно то, что написано - ось теряет диск. Если ты уверен, что кабели и напряжения в норме - проблема может быть в самих винтах или в материнской плате (особенно в северном мосту. Перегрев?)

router ★★★★★ ()

>Винты нормальные, почти новые.
Это еще ни о чем не говорит.

kernelpanic ★★★★★ ()

Я бы на твоём месте повнимательнее помотил сенсоры. Напряжение мерил?

erfea ★★★★★ ()

А вне RAID такого не наблюдалось?

Были подобные случаи чисто софтовые, из-за бага с ACPI/APM на конкретных материнках. Погугли на эту тему, попробуй отключать APM и ACPI в строке загрузки ядра.

anonymous ()

у меня было что-то похожее на одном из SATA-портов мат. платы. При переносе харда в другой комп больше не проявлялось. Видимо виноват контроллер SATA (кстати какой у тебя). Попробуй поменять материнку

Harald ★★★★★ ()
Ответ на: комментарий от Harald

description: IDE interface
product: 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller
vendor: Intel Corporation
physical id: 1f.2
bus info: pci@0000:00:1f.2
logical name: scsi1
version: 02
width: 32 bits
clock: 66MHz
capabilities: ide pm bus_master cap_list emulated
configuration: driver=ata_piix latency=0

Мать: TYAN Toledo i3210W/i3200R S5211

BusTeR ()
Ответ на: комментарий от true_admin

А есть ли какие-нибудь сторонние утилиты для проверки винта?
Victoria у меня почему-то даже не детектит винты.

BusTeR ()
Ответ на: комментарий от BusTeR

нуу, mhdd, смарт посмотреть... Ну и стоит мультиметром убедится что БП выдаёт положенную мощность, хотя проблемы с этим на брендовых серверах маловероятны

true_admin ★★★★★ ()
Ответ на: комментарий от true_admin

А, mhdd может и не увидеть scsi. Ну я самопальным скриптом проверял который работал по алгоритму mhdd :).

true_admin ★★★★★ ()
Ответ на: комментарий от BusTeR

Диагноз: выход из строя одного из винтов.
Лечение: Замена

BusTeR ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.