LINUX.ORG.RU
решено ФорумAdmin

ospfd. IP источника helo пакета


0

1

Добрый день!
Есть сервер eth0 195.2.32.2/32 eth1 10.0.0.1/24
На нем поднято zebra ospf bgpd. В iptables NAT выключен. В сети 10.0.0.0/24 вист 30 свичей. На всех ospf, все видят друг-друга в соседях. Сервер видит всех, но сам сам сервер ни один свич не видит.
tcpdump -n -i eth1 dst 224.0.0.5
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
16:30:48.314073 IP 10.0.0.15 > 224.0.0.5: OSPFv2, Hello, length: 80
16:30:48.739646 IP 10.0.0.13 > 224.0.0.5: OSPFv2, Hello, length: 80
16:30:48.870483 IP 10.0.0.6 > 224.0.0.5: OSPFv2, Hello, length: 80
16:30:48.630473 IP 195.2.32.2 > 224.0.0.5: OSPFv2, Hello, length: 84

вопрос: почему исходящий IP сервера в Hello 195.2.32.2 ? NAT точно вырублен, маршруты ip route add 224.0.0.0/4 dev eth1 прописаны. Пробовал snat всего уходящего 224.0.0.0/4 менять на 10.0.0.1. Неалё. Вообще, чтобы ни делал, как уходило от 195.2.32.2, так и уходит. А свичи такой адрес не переваривают. Что можно сделать?


zebra version 0.99.18

С почти этим же конфигом на другой машине работало. Изменились только адреса.

gich ()

> Что можно сделать?

показать конфиг. не забудь только лоркод выбрать.

val-amart ★★★★★ ()
Ответ на: комментарий от redixin

cat zebra.conf
------------------------------
hostname zebra
password zebrapass
enable password zebrapass
log file /usr/local/etc/quagga/zebra.log
!
interface eth1
ip address 10.0.0.1/24
ip address 112.146.136.1/24
!
interface eth0
ip address 195.2.32.2/30
!
interface lo0
!
ip route 10.0.0.0/8 Null0 254
ip route 172.16.0.0/12 Null0 254
ip route 192.168.0.0/16 Null0 254
ip route 112.146.136.0/22 Null0 254
!
!
router-id 10.0.0.1
!
ip forwarding
!
ip route 10.0.24.0/21 10.0.0.2
!
line vty
#exec-timeout 0 0
!
-------------------------------
cat ospfd.conf
hostname gw1
password zebra
log file /var/log/quagga/ospfd.log
!
!
interface eth0
!
interface eth1
ip ospf cost 1
!
interface eth1.100
!
interface eth1.4040
!
interface eth1:1
!
interface eth1:2
!
interface lo
!
!
router ospf
ospf router-id 10.0.0.1
redistribute static metric-type 1
network 10.0.0.0/24 area 0.0.0.0
!
passive-interface eth0
passive-interface ifb0
passive-interface lo

# default-information originate
!
line vty



маршруты ip route add 224.0.0.0/4 dev eth1 прописаны

Да посмотреть, что будет, но легче не стало

gich ()
Ответ на: комментарий от gich

После перезагрузки с отключением питания от сервера на 20 сек.!!! все стало работать как надо. Интересный глюк...

gich ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.