LINUX.ORG.RU
ФорумAdmin

virtualbox 4.1.0 - сетевой мост


0

1

Есть локальная сетка 192.168.1.0/24. В этой сетке есть машина 192.168.1.10 (debian 6.0.1) на которой крутится виртуалка (windows xp).
На 192.168.1.10 eth0(192.168.1.10) и eth1(192.168.1.11 для сетевого моста). Так вот с виртуалки пингует всю сеть 192.168.1.0/24 кроме 192.168.1.10 т.е. кроме хоста виртуальных машин. Есть мысли ?

>windows xp

на винфаке спроси

Led ★★★☆☆ ()
Ответ на: комментарий от frankincent

На 192.168.1.10 (хост виртуалок)
iface eth0 inet static
   address 192.168.1.10
   netmask 255.255.255.0
   gateway 192.168.1.1
auto eth1
iface eth1 inet static
   address 192.168.1.11
   netmask 255.255.255.0
   gateway 192.168.1.1

Сетевой интерфейс для виртуалки - сетевой мост eth1
На виртуалке
IP-адрес . . . . . . . . . . . . : 192.168.1.11
Маска подсети . . . . . . . . . . : 255.255.255.0
Основной шлюз . . . . . . . . . . : 192.168.1.1
DNS-серверы . . . . . . . . . . . : 192.168.1.1

ps/ aptitude search brctl молчит :(

eduardoeres ()
Ответ на: комментарий от eduardoeres

Я думал у тебя еще один мост средствами Linux, кроме того, что для виртуалки.

aptitude search bridge-utils
i bridge-utils - Utilities for configuring the Linux Ethernet bridge

Попробуй сделать мост не с eth1, а с eth0 (зачем тебе eth1 тогда вообще?) и потом ifconfig eth1 down. После этого проверь пинги.

frankincent ()
Ответ на: комментарий от frankincent

мост на eth1 для получения 100мбит в реальную сеть на виртуалку. Сделал мост с eth0, тоже самое - вся сеть пингуется кроме 192.168.1.10 (хоста виртуальных машин)

eduardoeres ()
Ответ на: комментарий от eduardoeres

А у тебя одинаковые IP у виртуалки и у хоста? :) Да, или DHCP (если есть) или static

frankincent ()

Вся сетка как я понимаю в eth0 приходит? В Virtualbox пропиши мост на eth0. eth1 на хосте потуши. Внутри виртуалки поставь на сетевой интерфейс 192.168.1.11

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

На машине хосте две сетевые карточки eth0 и eth1. Обе смотрят в одну сеть ..1.10 и ..1.11
На виртуалке поставил ..1.20 : с виртуалки пингует всю сеть кроме ..1.10 и ..1.11 т.е. не пингует интерфейсы хоста.

eduardoeres ()
Ответ на: комментарий от eduardoeres

Может в хосте дело? Покажи вывод iptables -L.
И можешь еще отключить второй интерфейс на хосте, ifconfig eth1 down, на всякий случай, чтобы не мешался

frankincent ()
Ответ на: комментарий от Pinkbyte

s/проблема очевидна/при такой конфигурации проблема очевидна/

Pinkbyte ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.