LINUX.ORG.RU
ФорумAdmin

помогите настроить pppoe


0

1

Не могу настроить pppoe. Помогите. Предпочтительнее- вручную (непосредственно измененить конф. файлы). Дистрибутив- Arch Linux, GUI нет. На шлюз пингует.

Пробовал pppoe-setup, вроде безрезультатно. Честно говоря, пробовал несколько способов (ручная конфигурация, pppoe-setup, pptpsetup), так что уже сам запутался.

Что значит вроде? Если пингуется, то соединение есть.

Sergei ()

man pppd

Не работает-то что? Выражение «на шлюз пингует» отсутствует в моем словаре.

так что уже сам запутался


Если запутался, пойми как функционирует. Здесь не винда. Мышетыкание не поможет.

Macil ★★★★★ ()
Ответ на: комментарий от Macil

ТС и так написал что у него арч без гуйов

anonymous ()
Ответ на: комментарий от Macil

Не надо здесь себя самым умным выставлять. Выражение «на шлюз пингует» означает удачную передачу пакетов на ip-адрес шлюза моего провайдера. Надеюсь про шлюз не надо рассказывать.

markontheboard ()

перепроверить pppoe-setup

fads ★★ ()

> На шлюз пингует.

Судя по эти трём словам, всё у Вас нормально с pppoe в плане связи - маршрутизация поднялась только на адрес сервера, просто роутинг по умолчанию не переписался на этот адрес.

Попробуйте почитать man pppd на предмет defaultroute... ну до кучи ещё и про usepeerdns почитайте на всякий случай.

Slavaz ★★★★★ ()
Ответ на: комментарий от anonymous

Увы, нет. при вызвое pon provider пишет, что утилита ( rp-pppoe ) скомпилен против чего-то там ( сейчас с live-cd сижу, так что дословно не помню).

И в каком то очередном руководстве читал, что вики устаревшая.

markontheboard ()
Ответ на: комментарий от markontheboard

>Увы, нет. при вызвое pon provider пишет

Запомни, пожалуйста. Для всего PPP (диалап, PPTP, PPoE) есть только одна команда: pppd

Все скрипты — так или иначе вызывают именно ее. Проблема в том, что зачастую эти скрипты ужасно кривы, или работают в строго определенных условиях, короче говоря, только усложняют процесс отладки.

А всякие «помощники» конфигурации лепят такую фантастисческую ахинею... Что иногда сомневаешься во вменяемости разработчиков.

Как совет — ВСЕ убрать из /etc/ppp и дальше настраивать по man pppd

Macil ★★★★★ ()
Ответ на: комментарий от Slavaz

*Пошел читать* За совет спасибо, скорее всего придется обратиться еще.

markontheboard ()
Ответ на: комментарий от markontheboard

Ознакомился с опциями pppd. Добавление строки defaultroute в файлы /etc/ppp/peers/provider и /etc/ppp/options не помогло. Вывод ошибок (чрутнулся с юбунты) [code=bash] [root@ubuntu /]# tail /var/log/errors.log Apr 12 02:38:48 mark-laptop pppoe[30238]: ioctl(SIOCGIFHWADDR): Session 0: No such device [/code]

Девайс разумеется eth0, но где-то я его не прописал. Вопрос- где ?

markontheboard ()
Ответ на: комментарий от markontheboard

покажите конфиг /etc/ppp/peers/provider
после установления соединения и после успешного пинга на PPPoE-сервер также покажите вывод команды
route -n

Slavaz ★★★★★ ()
Ответ на: комментарий от Slavaz

Простите за неправильный вопрос. До недавнего времени думал, что у меня pppoe протокол, выяснилось, что pptp. Как оказалось, были такие проблемы: MTU стоял 1500, нужен был 1400. Насчет стандартного маршрута вы были правы. После направления на гейтвей с нужными параметрами все начало работать. НО ! Все таки выводит в лог ошибку

«Cannot determine ethernet address for proxy ARP»

По факту это не влияет на мое соединение, но лучше, если ее не будет. И еще. После подключения таблица переписывается и дефолтные маршруты перестают быть дефолтными, вместо них добавляются другие. Дело в том, что для повторного подключения требуется править таблицу заново. Если нет, то в лог вылетает

«not replacing existing default route via (мой шлюз)».

Как сделать, чтобы не переписывалось, или обходить этот механизм работы pptp, чтобы не ковыряться каждый раз ?

markontheboard ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.