LINUX.ORG.RU
ФорумAdmin

KVM+Windows+Virtio


0

1

Наблюдаю иногда жуткие тормоза прорисовки интерфейса, меню долго прорисовываются. Потом проходит некоторое время и все опять шустро работать начинает. Virtio диск и сеть. Естественно у пользователей база подвисает. Ресурсы что в госте, что на хосте все свободны. Скорость чтения диска 80-90 Mb/s

На что можно грешить? Как бы сузить круг возможных проблем. Просто абстракций много. Все проверять в разных вариантах... На чем сосредоточиться по вашему мнению?

Гость: Windows 7 64, RAM 5Гб, HDD 320Гб.

Хост: Ubuntu Server 10.10, mdadm raid1, (LVM+DRBD для виртуальных дисков), i7, RAM 12Gb

P.S.: DRBD bound=5*1000Mb, вся пропускная способность используется. И еще в этот момент наблюдаю задумчивость со стороны консоли. К стате, такая же ситуация и на втором точно таком же сервере.

★★★★★

<domain type='kvm'>
	<name>mt</name>
	<memory>5242880</memory>
	<vcpu>2</vcpu>
	<os>
		<type arch='x86_64' machine='pc-0.12'>hvm</type>
		<boot dev='hd'/>
		<!--<boot dev='cdrom'/>-->
	</os>
	<features>
		<acpi/>
		<apic/>
		<pae/>
	</features>
	<clock sync="localtime"/>
	<on_poweroff>destroy</on_poweroff>
	<on_reboot>restart</on_reboot>
	<on_crash>restart</on_crash>
	<devices>
		<emulator>/usr/bin/kvm</emulator>
		<disk type='block' device='disk'>
			<driver cache='none'/>
			<source dev='/dev/drbd0'/>
			<!--<target dev='hda' bus='ide'/>-->
			<target dev='vda' bus='virtio'/>
		</disk>
		<!--<disk type='file' device='disk'>
			<source file='/home/variantb/virtio.img'/>
			<target dev='vda' bus='virtio'/>
		</disk>-->
		<!--<disk type='file' device='cdrom'>
			<source file='/mnt/distr/virtio-win-1.1.16.iso'/>
			<target dev='hdc' bus='ide'/>
			<readonly/>
		</disk>-->
		<interface type='bridge'>
			<mac address='52:54:00:56:99:06'/>
			<source bridge='br0'/>
			<target dev='vnet0'/>
			<alias name='net0'/>
			<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
			<model type='virtio'/>
		</interface>
		<!--Используем для совмещения мыши на экране VNC-->
		<input type='tablet' bus='usb'>
			<alias name='input0'/>
		</input>
		<input type='mouse' bus='ps2'/>
		<graphics type='vnc' port='5901' autoport='no' keymap='en-us'/>
		<video>
			<model type='vga' vram='9216' heads='1'/>
			<alias name='video0'/>
			<address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
		</video>
		<sound model='ac97'/>
	</devices>
</domain>

petav ★★★★★ ()
Ответ на: комментарий от petav

Да суть в том, что KVM ну криво работает с Winodws... :-( Увы.

Можете конечно расположить образ VM минуя LVM и drbd на винте скажем где стоит KVM для теста.

DALDON ★★★★★ ()
Ответ на: комментарий от DALDON

Я DRBD разрывал. Скорость не увеличивалась.

petav ★★★★★ ()
Ответ на: комментарий от DALDON

железо да, может быть. Но вот карман заказчика. Ему кластер нужен высокой доступности в бюджетном варианте.

petav ★★★★★ ()

petav> И еще в этот момент наблюдаю задумчивость со стороны консоли. К стате, такая же ситуация и на втором точно таком же сервере.

Без всяких виртуалок нагрузить drbd диск и убедиться в его (не)нормальной работе.

sdio ★★★★★ ()
Ответ на: комментарий от ventilator

не могу там виндовс и какая-то баз самопальная. Ни как не разобрать на сервисы.

petav ★★★★★ ()
Ответ на: комментарий от DALDON

Это не объяснение. Конкретно. В чем здесь проблема по вашему? Примерно такое же но WinXP и без DRBD и LVM нормально дружат на другом сервере. Дружат не дружат. Это субъективно. Ваше мнение я понял. Спасибо за него.

petav ★★★★★ ()
Ответ на: комментарий от sdio

Вот тоже думаю что затык в DRBD. А как его можно проверить? Файлы покопировать и тест какой-то запустить. Я в линукс недавно, подскажите.

petav ★★★★★ ()
Ответ на: комментарий от petav

или cpu-scaling? как вариант в сети нашел, что думаете?

petav ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.