LINUX.ORG.RU
ФорумAdmin

Вопрос по настройке bind


0

1

Установил настроил bind9 на debian мой named.conf.options

acl "virdebian" { 192.168.3.0/24; 127.0.0.1; };
options {
	directory "/var/cache/bind";

	pid-file   "/var/cache/bind/pid";
	dump-file  "/var/cache/bind/cache_dump.db";
	statistics-file  "/var/cache/bind/named_stats.txt";
	memstatistics-file  "/var/cache/bind/named_mem_stats.txt";
	
	#от кого разрешаем принимать запросы 
	allow-query { "virdebian"; };
	
	#Разрешаем выполнять рекурсивные запросы только с virdebian
	
	forwarders { 83.149.24.244;
	83.149.24.244;
	8.8.8.8;
	};

	#скажем на каких портах обслуживать днс запросы
	listen-on port 53 {
	127.0.0.1;
	192.168.3.25;
	};
	#инфа о сервере 
	version "virdebian DNS";
	

	
	auth-nxdomain no;    # conform to RFC1035
	#отключаем ipv 6
	listen-on-v6 { none; };
	};
	#ведение лога
	logging {
	channel warning {
	file "/var/log/bind/dns_warning" versions 3 size 10m;
	severity warning;
	print-category yes;
	print-severity yes;
	print-time yes;
	};
	
	channel general_dns {
	file "/var/log/bind/dns_logs" versions 3 size 10m;
	severity info;
	print-category yes;
	print-severity yes;
	print-time yes;
	};
	category default { warning; };
	category default { general_dns; };

};

зоны пока не трогал делаю

virdebian:/etc/bind# nslookup localhost
Server:         127.0.0.1
Address:        127.0.0.1#53

Name:   localhost
Address: 127.0.0.1

подрубаю инет

virdebian:/etc/bind# nslookup localhost
Server:         83.149.24.244
Address:        83.149.24.244#53

** server can't find localhost: NXDOMAIN

проблема в том что при подключении инета в resolvf.conf автоматом тосуются dns прова , как мне этого избежать (инет gprs модем мегафон )

Правильный способ - отключить перезапись днс-ов в dhcp клиенте. Не правильный - вписать что нужно в resolvf.conf и поставить на него immutable через chattr.

a_andry ()

chattr +i /etc/resolv.conf :) но это дикий костыль. man dhcp, в общем

leave ★★★★★ ()

>автоматом тосуются dns прова

интернет как приходит? DHCP? PPPoE?

если по DHCP - какой dhcp-клиент?

Pinkbyte ★★★★★ ()
Ответ на: комментарий от LILO

Решение проблемы нашел только одно. Это убрать из файла настроек pppd (у меня это /etc/ppp/options) строку usepeerdns. Насколько я понял надо проделать выше пиричисленное ? Но прикол в том что нет там такой строки

drac753 ★★ ()
Ответ на: комментарий от LILO

там у меня 3 файла provide wvdial wvdial-pipe в wvdial есть такя опция но её удаление результата не даёт да и подключаюсь я не чер wvdial

drac753 ★★ ()
Ответ на: комментарий от drac753

по поводу dhcp клиента

 Configuration file for /sbin/dhclient, which is included in Debian's
#	dhcp3-client package.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
#	man page for more information about the syntax of this file
#	and a more comprehensive list of the parameters understood by
#	dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
#	not leave anything out (like the domain name, for example), then
#	few changes must be made to this file, if any.
#

option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;

#send host-name "andare.fugue.com";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
	host-name,netbios-name-servers, netbios-scope, interface-mtu,
	rfc3442-classless-static-routes;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/etc/dhcp3/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;

#alias {
#  interface "eth0";
#  fixed-address 192.5.5.213;
#  option subnet-mask 255.255.255.255;
#}

#lease {
#  interface "eth0";
#  fixed-address 192.33.137.200;
#  medium "link0 link1";
#  option host-name "andare.swiftmedia.com";
#  option subnet-mask 255.255.255.0;
#  option broadcast-address 192.33.137.255;
#  option routers 192.33.137.250;
#  option domain-name-servers 127.0.0.1;
#  renew 2 2000/1/12 00:00:01;
#  rebind 2 2000/1/12 00:00:01;
#  expire 2 2000/1/12 00:00:01;
#}
не помогло

drac753 ★★ ()
Ответ на: комментарий от drac753

ну и на всякий мой interfaces

[code] # and how to activate them. For more information, see interfaces(5).

# The loopback network interface auto lo iface lo inet loopback

# The primary network interface allow-hotplug eth0 iface eth0 inet static    address 192.168.3.25    netmask 255.255.255.0    network 192.168.3.0    broadcast 192.168.3.255    gateway 10.64.64.64    # dns-* options are implemented by the resolvconf package, if installed    dns-nameservers 127.0.0.1

[/code]

drac753 ★★ ()

> подрубаю инет

напиши скрипт для подрубания инета, который будет выполнять команду подрубания, а затем echo нужных нс-ов в resolv.conf =)

Komintern ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.