LINUX.ORG.RU
ФорумAdmin

Ошибки, при работе Samba


0

0

Подскажите, где можно поискать?
В общем стоял сервер, работал себе 4 года, все было нормально, но в один день пошли ошибки при работе с сетевыми дисками сервера.
Те заходишь по ssh - все вроде нормально,в логах тоже все вроде нормально, а при работе с прогами установленными на сервере с виндовых клиентов (через самбу) - такое ощущение, что нет доступа к файлам, хотя эти файлы нормально открываются, например, блокнотом. И это происходит не постоянно, а периодически, и проги, конечно, постоянно вылетают.
Что было сделано.
Линух стоял старый, так что заодно решили обновить сервер, обновили - ошибки остались.
Тогда по быстрому перекинули все на W2003 на другой машине. Там все заработало и проблем уже неделю нет. Но W2003 при загрузке ругается, что есть одинаковые имена в сети, хотя все проверили ip сканером - нет там одинаковых имен.
Уже не знаю, что и делать. Переходить на W2003 - не хочется, да денег на лицензии нет.
Вот сейчас принес сервер в другое место, подключился, и стал переписывать фаром пару больших каталогов. И иногда возникает ошибка - Что данное имя файла в данный момент недоступно, потом жмешь повторить и все едет дальше.
Может подскажете что, уважаемые гуру.


Однопользовательский режим, fsck. Ну или как там в линуксе.

BSD ()
Ответ на: комментарий от BSD

У меня ФС состоит из 2 SCSI дисков, включенных в программное зеркало и одного большого IDE диска - для хлама.
SCSI диски при переустановке форматировал заново, а на IDE были проблемы, которые устранил при первом запуске. Но на всякий пожарный сейчас его снова проверяю на плохие блоки.
Зеркало работает без сбоев.
Когда копировал данные на USB диск с IDE диска, все прошло замечательно, а когда по сети, то иногда лезут ошибки.

mnk ()
Ответ на: комментарий от markevichus

А могут ошибки на IDE диске вызывать такой эффект при чтении с SCSI дисков?

mnk ()
Ответ на: комментарий от mnk

Вообще отключил IDE диск - ошибки остались.
Тест памяти прошел.
Сейчас еще внешнюю сетевую карту попробую (хотя там их 2 и с обеих тот же глюк)
Придется все таки, наверно, W2003 для пробы туда запузырить. Такой ощущение, что что то с компом в части сети, тк все остальное работает без ошибок.

mnk ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.