LINUX.ORG.RU
ФорумAdmin

Fedora 12 и ProFTPd, анонимные пользователи не могут загружать ничего, как быть?


0

0

Здравствуйте!

Использую Fedora 12 x86-64, выполнил установку ProFTPd. В /etc/sysconfig/proftpd прописал PROFTPD_OPTIONS="-DANONYMOUS_FTP" - получилось зайти анонимано на FTP, но не могу загружать ничего.

/etc/proftpd.conf

# A basic anonymous configuration, with an upload directory
# Enable this with PROFTPD_OPTIONS=-DANONYMOUS_FTP in /etc/sysconfig/proftpd
<IfDefine ANONYMOUS_FTP>
  <Anonymous ~ftp>
    User			ftp
    Group			ftp
    AccessGrantMsg		"Anonymous login ok, restrictions apply."

    # We want clients to be able to login with "anonymous" as well as "ftp"
    UserAlias			anonymous ftp

    # Limit the maximum number of anonymous logins
    MaxClients			10 "Sorry, max %m users -- try again later"

    # Put the user into /pub right after login
    #DefaultChdir		/pub

    # We want 'welcome.msg' displayed at login, '.message' displayed in
    # each newly chdired directory and tell users to read README* files. 
    DisplayLogin		/welcome.msg
    DisplayChdir		.message
    DisplayReadme		README*

    # Cosmetic option to make all files appear to be owned by user "ftp"
    DirFakeUser			on ftp
    DirFakeGroup		on ftp

    # Limit WRITE everywhere in the anonymous chroot
    <Limit WRITE SITE_CHMOD>
      DenyAll
    </Limit>

    # An upload directory that allows storing files but not retrieving
    # or creating directories.
    <Directory uploads/*>
      AllowOverwrite		no
      <Limit READ>
        DenyAll
      </Limit>

      <Limit STOR>
        AllowAll
      </Limit>
    </Directory>

    # Don't write anonymous accesses to the system wtmp file (good idea!)
    WtmpLog			off

    # Logging for the anonymous transfers
    ExtendedLog			/var/log/proftpd/access.log WRITE,READ default
    ExtendedLog			/var/log/proftpd/auth.log AUTH auth

  </Anonymous>
</IfDefine>

/vat/ftp

drwxrwxrwx. 2 root root 4096 Фев 19 15:52 pub
drwxrwxrwx. 2 ftp  ftp  4096 Фев 19 15:52 uploads
-rw-r--r--. 1 root root  224 Дек 17  2007 welcome.msg

Прошу помощи, заранее благодарен.

Дак, ХЗ тебя. Ты ведь ничего не написал.

Когда коннектишься анонимно, ls хотя бы попробуй сделать. Отвечает или нет?

И пассивный и активный режимы пробовал?

А у тебя сервер не за NAT-ом случайно?

ansky ★★★★★ ()
<Directory /home/ftp/uploads>
<Limit READ RETR GET WRITE STOR CWD MKD>
AllowAll
</Limit>
<Limit DELE RMD>
DenyAll
</Limit>
</Directory>

так попробуй.

Komintern ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.