LINUX.ORG.RU
ФорумAdmin

Помогите разобратся с dial-in


0

0

Здравствуйте, помогите настроить оное. Сделал как написано в куче статей, настрил mgetty, pppd, входящий звонок принимает, обрабатывает, после вызова pppd коннект обрывается, в логах ничего толког нету, но приведу их, может кто поймет. Если надо могу выложить и конфиги.
/var/log/mgetty/mgetty.ttyS1
12/30 17:57:05 yS1 mgetty: experimental test release 1.1.21-Jul24
12/30 17:57:05 yS1 check for lockfiles
12/30 17:57:05 yS1 checklock: no active process has lock, will remove
12/30 17:57:05 yS1 locking the line
12/30 17:57:05 yS1 makelock(ttyS1) called
12/30 17:57:05 yS1 do_makelock: lock='/var/lock/LCK..ttyS1'
12/30 17:57:05 yS1 lock made
12/30 17:57:06 yS1 tio_get_rs232_lines: status: RTS CTS DSR DTR
12/30 17:57:06 yS1 lowering DTR to reset Modem
12/30 17:57:06 yS1 tss: set speed to 57600 (10001)
12/30 17:57:06 yS1 tio_set_flow_control( HARD )
12/30 17:57:06 yS1 waiting for line to clear (VTIME), read:
12/30 17:57:06 yS1 send: ATS0=0Q0&D3&C1[0d]
12/30 17:57:06 yS1 waiting for ``OK''
12/30 17:57:06 yS1 got: ATS0=0Q0&D3&C1[0d]
12/30 17:57:06 yS1 CND: ATS0=0Q0&D3&C1[0d][0a]OK ** found **
12/30 17:57:06 yS1 waiting for line to clear (VTIME), read: [0d][0a]
12/30 17:57:07 yS1 removing lock file
12/30 17:57:07 yS1 waiting...
12/30 17:57:29 yS1 select returned 1
12/30 17:57:29 yS1 checking lockfiles, locking the line
12/30 17:57:29 yS1 makelock(ttyS1) called
12/30 17:57:29 yS1 do_makelock: lock='/var/lock/LCK..ttyS1'
12/30 17:57:29 yS1 lock made
12/30 17:57:29 yS1 wfr: waiting for ``RING''
12/30 17:57:29 yS1 got: [0d][0a]RING[0d]
12/30 17:57:29 yS1 CND: RING
12/30 17:57:29 yS1 wfr: rc=0, drn=0
12/30 17:57:29 yS1 cannot set controlling tty (ioctl): Operation not permitted
12/30 17:57:29 yS1 >>> this might be caused because you have run mgetty/vgetty
12/30 17:57:29 yS1 >>> from the command line. Don't do that, use /etc/inittab!
12/30 17:57:29 yS1 send: ATA[0d]
12/30 17:57:29 yS1 waiting for ``CONNECT''
12/30 17:57:29 yS1 got: ATA[0d]
12/30 17:57:29 yS1 CND: OKATA[0d][0a]CONNECT ** found **
12/30 17:57:46 yS1 send:
12/30 17:57:46 yS1 waiting for ``_''
12/30 17:57:46 yS1 got: 57600[0d]
12/30 17:57:46 yS1 CND: CONNECT 57600
12/30 17:57:46 yS1 CND: found: 57600 ** found **
12/30 17:57:46 yS1 waiting for line to clear (VTIME), read: [0a]~[ff]}#[c0]!}!}!} }7}"}&} }*} } }%}&}![a5][e3]w}'}"}(}"}-}#}&[d2]N~
12/30 17:57:47 yS1 looking for utmp entry... (my PID: 3080)
12/30 17:57:47 yS1 tio_set_flow_control( HARD )
12/30 17:57:47 yS1 print welcome banner (/etc/issue)
12/30 17:57:47 yS1 getlogname (FIDO AUTO_PPP), read:~[ff]}#[c0]!
12/30 17:57:49 yS1 input finished with '\r', setting ICRNL ONLCR
12/30 17:57:49 yS1 tio_get_rs232_lines: status: RTS CTS DSR DTR DCD
12/30 17:57:49 yS1 login: use login config file /usr/etc/mgetty+sendfax/login.config
12/30 17:57:49 yS1 match: user='/AutoPPP/', key='/AutoPPP/'*** hit!
12/30 17:57:49 yS1 login: utmp entry: a_ppp
12/30 17:57:49 yS1 looking for utmp entry... (my PID: 3080)
12/30 17:57:49 yS1 calling login: cmd='/usr/sbin/pppd', argv[]='pppd file /etc/ppp/options.dialin'
12/30 17:57:49 ##### data dev=ttyS1, pid=3080, caller='none', conn='57600', name='', cmd='/usr/sbin/pppd', user='/AutoPPP/'

12/30 17:57:49 yS1 setenv: 'CALLER_ID=none'
12/30 17:57:49 yS1 setenv: 'CALLED_ID='
12/30 17:57:49 yS1 setenv: 'CONNECT=57600'

Уровень логирования поставил максимальным, но мне это все равно ничего не говорит. Авторизация проводится pap, с юзерами в pap-secrets.
Заранее спасиба за помощь.

anonymous

Ответ на: комментарий от McMCC

Я тоже думаю что проблема в pppd, но тем не менее я не могу понять в чем именно эта проблема, удаленная система говорит, что сервер не может что-то сделать, и сама ложит трубку. В чем может быть дело? Вот конфиг pppd:

~: cat /etc/ppp/options.dialin
lock
login
auth
modem
crtscts
refuse-chap
require-pap
mtu 576
mru 576
ms-dns 192.168.0.3
192.168.0.3:192.168.0.12

Может что не так?

~: cat /etc/ppp/pap-secrets
# PAP authentication file: /etc/ppp/pap-secrets
# This file should have a permission of 600.
# ~# chmod 600 /etc/ppp/pap-secrets
# Username Server Password IP addresses
"AYJ49302" * "Hiryewt6"
"banderos" * "bpass" *
"demo" * "demo" *

~: cat /etc/mgetty+sendfax/login.config
/AutoPPP/ - a_ppp /usr/sbin/pppd file /etc/ppp/options.dialin

~: cat /etc/mgetty+sendfax/mgetty.config
debug 9
fax-id 00 00 000000
speed 57600
direct NO
blocking NO
port-owner uucp
port-group uucp
port-mode 0660
toggle-dtr YES
toggle-dtr-waittime 500
data-only YES
fax-only NO
modem-type auto
init-chat "" ATS0=0Q0&D3&C1 OK
modem-check-time 3600
rings 0
answer-chat "" ATA CONNECT \c \r
answer-chat-timeout 80
autobauding NO
ringback NO
ringback-time 30
ignore-carrier false
issue-file /etc/issue
prompt-waittime 500
login-prompt @!login:
login-time 240
diskspace 1024
notify faxadmin
fax-owner uucp
fax-group modem
fax-mode 0660

Буду очень благодарен за помощь. Все что мог показал., может кто что поймет...

anonymous
()
Ответ на: комментарий от anonymous

В файл /etc/ppp/options.dialin добавь строчку
logfile /var/log/pppd.log
и смотри уже по логам pppd, ну или сюда запости. Может, кто и сориентируется.

josephson ★★
()
Ответ на: комментарий от josephson

Добавил, но туда ничего не пишется, хотя он и создался :( Такое оущение, что соединение разрывается перед:
12/30 17:57:49 yS1 calling login: cmd='/usr/sbin/pppd', argv[]='pppd file /etc/ppp/options.dialin'
12/30 17:57:49 ##### data dev=ttyS1, pid=3080, caller='none', conn='57600', name='', cmd='/usr/sbin/pppd', user='/AutoPPP/'

12/30 17:57:49 yS1 setenv: 'CALLER_ID=none'
12/30 17:57:49 yS1 setenv: 'CALLED_ID='
12/30 17:57:49 yS1 setenv: 'CONNECT=57600'
, а не после, т.е. mgetty или удаленная машинав ложит трубкy...

anonymous
()
Ответ на: комментарий от anonymous

Нет, ощущение не верно. На удаленной машине поставил slip: UNIX, на удаленной машине выводит консоль, просит ввести логин, выводит собщение и выбрасывает в консоль, но команды как то странно пишет (в лог файле на сервере в папке юзера непонятно что...), а на сервере в /var/log/syslog:
Dec 31 16:46:16 r0y pppd[6102]: The remote system is required to authenticate itself
Dec 31 16:46:16 r0y pppd[6102]: but I couldn't find any suitable secret (password) for it to use to do so.
Dec 31 16:46:16 r0y pppd[6102]: (None of the available passwords would let it use an IP address.)

При уставновлении у клиента PPP: WIN..., происходит то, что описано выше...при чем в логах по этому поводу ничего нет...юзер в системе зарегестрирован, только в качетстве шелла у него баш, но вроде так и надо, если нет - поправьте. Буду очень благодарен за любую помощь, т.к. опыта в этом дел не очень много у меня. Дистрибутив slackware.

anonymous
()
Ответ на: комментарий от anonymous

А тебе обязательно pap..??? может заместо шелла просто pppd воткнуть...? Я делал так - работало... только не забудь убрать auth из кофига pppd..

malmstream
()
Ответ на: комментарий от anonymous

да кстати, прежде чем звонить операционкой, попробуй сначала ручками (из терминалки какой-нибудь)...

malmstream
()
Ответ на: комментарий от anonymous

Проблема с аутентификацией.

>Dec 31 16:46:16 r0y pppd[6102]: The remote system is required to authenticate itself
>Dec 31 16:46:16 r0y pppd[6102]: but I couldn't find any suitable secret (password) for it to use to do so.
Пишет, что удалённая система требует аутентификации сама по себе, но не найден подходящий пароль для этого...
Я для pppd, придерживаюсь таких правил:
> юзер в системе зарегестрирован, только в качетстве шелла у него баш, но вроде так и надо
1) пароли в/etc/ppp/chap-secrets (для тебя, значит /etc/ppp/pap-secrets) и в /etc/shadow одинаковые;
2) не знаю, как в slackware, а в rh есть группа pppusers, и все пользователи, перечисленные в /etc/ppp/chap-secrets принадлежат ей;
3) шела у пользователей из /etc/ppp/chap-secrets (группы pppusers) вообще нет: в /etc/passwd ставлю /bin/true. Тем, кому нужен шелл на сервере, имеют отдельный аккаунт и при установленном соединении входят по ssh.
Не знаю, корректно ли так делать, или нет, но работает... Если, что не так, поправьте другие.

josephson ★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.