LINUX.ORG.RU
ФорумAdmin

VSFTP трабла


0

0

Подскажите, плиз! Есть vsftpd, есть юзера (почтовые, которые /bin/nologin). В конфиге у vsftpd прописано, что local_enable = yes. В pam.d есть vsftpd. Вроде нормально. Не пускает никак юзеров. Аноним нормально заходит. В чем грабли?

★☆☆☆

VSFTP трабла

Shell юзера должен присутствовать в файле /etc/shells чтобы vsftp его пустил.

sdio ★★★★★ ()

Re: VSFTP трабла

лог надо смотреть

anonymous ()

Re: VSFTP трабла

Из /usr/share/doc/vsftpd-1.1.0/FAQ

Q) Help! Local users cannot log in. A) There are various possible problems. A1) By default, vsftpd disables any logins other than anonymous logins. Put local_enable=YES in your /etc/vsftpd.conf to allow local users to log in. A2) vsftpd tries to link with PAM. (Run "ldd vsftpd" and look for libpam to find out whether this has happened or not). If vsftpd links with PAM, then you will need to have a PAM file installed for the vsftpd service. There is a sample one for RedHat systems included in the "RedHat" directory - put it under /etc/pam.d A3) If vsftpd didn't link with PAM, then there are various possible issues. Is the user's shell in /etc/shells? If you have shadowed passwords, does your system have a "shadow.h" file in the include path? A4) If you are not using PAM, then vsftpd will do its own check for a valid user shell in /etc/shells. You may need to disable this if you use an invalid shell to disable logins other than FTP logins. Put check_shell=NO in your /etc/vsftpd.conf.

sdio ★★★★★ ()

Re: VSFTP трабла

TNX for all!!! Убрал в PAM-е проверку шеллов. Все ОК!

sabonez ★☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.